diff mbox

[1/3] nmi: convert cpu_index to cpu-index

Message ID 4D0EF37B.1040702@cn.fujitsu.com
State New
Headers show

Commit Message

Lai Jiangshan Dec. 20, 2010, 6:11 a.m. UTC
"cpu-index" is better name.

Signed-off-by:  Lai Jiangshan <laijs@cn.fujitsu.com>
---

Comments

Markus Armbruster Dec. 20, 2010, 5 p.m. UTC | #1
Lai Jiangshan <laijs@cn.fujitsu.com> writes:

> "cpu-index" is better name.
>
> Signed-off-by:  Lai Jiangshan <laijs@cn.fujitsu.com>
> ---
> diff --git a/hmp-commands.hx b/hmp-commands.hx
> index 4befbe2..8de7aa3 100644
> --- a/hmp-commands.hx
> +++ b/hmp-commands.hx
> @@ -721,7 +721,7 @@ ETEXI
>  #if defined(TARGET_I386)
>      {
>          .name       = "nmi",
> -        .args_type  = "cpu_index:i",
> +        .args_type  = "cpu-index:i",
>          .params     = "cpu",
>          .help       = "inject an NMI on the given CPU",
>          .mhandler.cmd = do_inject_nmi,
> diff --git a/monitor.c b/monitor.c
> index 5d74fe3..c16b39d 100644
> --- a/monitor.c
> +++ b/monitor.c
> @@ -2410,7 +2410,7 @@ static void do_wav_capture(Monitor *mon, const QDict *qdict)
>  static void do_inject_nmi(Monitor *mon, const QDict *qdict)
>  {
>      CPUState *env;
> -    int cpu_index = qdict_get_int(qdict, "cpu_index");
> +    int cpu_index = qdict_get_int(qdict, "cpu-index");
>  
>      for (env = first_cpu; env != NULL; env = env->next_cpu)
>          if (env->cpu_index == cpu_index) {

Fine with me, but it would be nice if we could make up our mind once and
for all whether to use dash or underscore in monitor commands and
arguments.
Lai Jiangshan Dec. 21, 2010, 6:05 a.m. UTC | #2
On 12/21/2010 01:00 AM, Markus Armbruster wrote:
> Lai Jiangshan <laijs@cn.fujitsu.com> writes:
> 
>> "cpu-index" is better name.
>>
>> Signed-off-by:  Lai Jiangshan <laijs@cn.fujitsu.com>
>> ---
>> diff --git a/hmp-commands.hx b/hmp-commands.hx
>> index 4befbe2..8de7aa3 100644
>> --- a/hmp-commands.hx
>> +++ b/hmp-commands.hx
>> @@ -721,7 +721,7 @@ ETEXI
>>  #if defined(TARGET_I386)
>>      {
>>          .name       = "nmi",
>> -        .args_type  = "cpu_index:i",
>> +        .args_type  = "cpu-index:i",
>>          .params     = "cpu",
>>          .help       = "inject an NMI on the given CPU",
>>          .mhandler.cmd = do_inject_nmi,
>> diff --git a/monitor.c b/monitor.c
>> index 5d74fe3..c16b39d 100644
>> --- a/monitor.c
>> +++ b/monitor.c
>> @@ -2410,7 +2410,7 @@ static void do_wav_capture(Monitor *mon, const QDict *qdict)
>>  static void do_inject_nmi(Monitor *mon, const QDict *qdict)
>>  {
>>      CPUState *env;
>> -    int cpu_index = qdict_get_int(qdict, "cpu_index");
>> +    int cpu_index = qdict_get_int(qdict, "cpu-index");
>>  
>>      for (env = first_cpu; env != NULL; env = env->next_cpu)
>>          if (env->cpu_index == cpu_index) {
> 
> Fine with me, but it would be nice if we could make up our mind once and
> for all whether to use dash or underscore in monitor commands and
> arguments.
> 

Currently, I focus on this nmi command, our customers hope they
can inject nmi via libvirt. I may also fix other "underscore"
when these patches applied.

Thanks,
Lai
Luiz Capitulino Jan. 3, 2011, 1:50 p.m. UTC | #3
On Mon, 20 Dec 2010 18:00:34 +0100
Markus Armbruster <armbru@redhat.com> wrote:

> Lai Jiangshan <laijs@cn.fujitsu.com> writes:
> 
> > "cpu-index" is better name.
> >
> > Signed-off-by:  Lai Jiangshan <laijs@cn.fujitsu.com>
> > ---
> > diff --git a/hmp-commands.hx b/hmp-commands.hx
> > index 4befbe2..8de7aa3 100644
> > --- a/hmp-commands.hx
> > +++ b/hmp-commands.hx
> > @@ -721,7 +721,7 @@ ETEXI
> >  #if defined(TARGET_I386)
> >      {
> >          .name       = "nmi",
> > -        .args_type  = "cpu_index:i",
> > +        .args_type  = "cpu-index:i",
> >          .params     = "cpu",
> >          .help       = "inject an NMI on the given CPU",
> >          .mhandler.cmd = do_inject_nmi,
> > diff --git a/monitor.c b/monitor.c
> > index 5d74fe3..c16b39d 100644
> > --- a/monitor.c
> > +++ b/monitor.c
> > @@ -2410,7 +2410,7 @@ static void do_wav_capture(Monitor *mon, const QDict *qdict)
> >  static void do_inject_nmi(Monitor *mon, const QDict *qdict)
> >  {
> >      CPUState *env;
> > -    int cpu_index = qdict_get_int(qdict, "cpu_index");
> > +    int cpu_index = qdict_get_int(qdict, "cpu-index");
> >  
> >      for (env = first_cpu; env != NULL; env = env->next_cpu)
> >          if (env->cpu_index == cpu_index) {
> 
> Fine with me, but it would be nice if we could make up our mind once and
> for all whether to use dash or underscore in monitor commands and
> arguments.

I vote for dash, although we obviously can't change existing commands.
diff mbox

Patch

diff --git a/hmp-commands.hx b/hmp-commands.hx
index 4befbe2..8de7aa3 100644
--- a/hmp-commands.hx
+++ b/hmp-commands.hx
@@ -721,7 +721,7 @@  ETEXI
 #if defined(TARGET_I386)
     {
         .name       = "nmi",
-        .args_type  = "cpu_index:i",
+        .args_type  = "cpu-index:i",
         .params     = "cpu",
         .help       = "inject an NMI on the given CPU",
         .mhandler.cmd = do_inject_nmi,
diff --git a/monitor.c b/monitor.c
index 5d74fe3..c16b39d 100644
--- a/monitor.c
+++ b/monitor.c
@@ -2410,7 +2410,7 @@  static void do_wav_capture(Monitor *mon, const QDict *qdict)
 static void do_inject_nmi(Monitor *mon, const QDict *qdict)
 {
     CPUState *env;
-    int cpu_index = qdict_get_int(qdict, "cpu_index");
+    int cpu_index = qdict_get_int(qdict, "cpu-index");
 
     for (env = first_cpu; env != NULL; env = env->next_cpu)
         if (env->cpu_index == cpu_index) {