diff mbox series

hw/ide/ahci: Rename ahci_internal.h to ahci-internal.h

Message ID 20240227131310.C24EB4E6005@zero.eik.bme.hu
State New
Headers show
Series hw/ide/ahci: Rename ahci_internal.h to ahci-internal.h | expand

Commit Message

BALATON Zoltan Feb. 27, 2024, 1:13 p.m. UTC
Other headers now use dash instead of underscore. Rename
ahci_internal.h accordingly for consistency.

Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
---
 hw/ide/{ahci_internal.h => ahci-internal.h} | 0
 hw/ide/ahci.c                               | 2 +-
 hw/ide/ich.c                                | 2 +-
 3 files changed, 2 insertions(+), 2 deletions(-)
 rename hw/ide/{ahci_internal.h => ahci-internal.h} (100%)

Comments

Markus Armbruster Feb. 27, 2024, 1:38 p.m. UTC | #1
BALATON Zoltan <balaton@eik.bme.hu> writes:

> Other headers now use dash instead of underscore. Rename
> ahci_internal.h accordingly for consistency.
>
> Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>

Reviewed-by: Markus Armbruster <armbru@redhat.com>
Thomas Huth Feb. 27, 2024, 2:06 p.m. UTC | #2
On 27/02/2024 14.13, BALATON Zoltan wrote:
> Other headers now use dash instead of underscore. Rename
> ahci_internal.h accordingly for consistency.
> 
> Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
> ---
>   hw/ide/{ahci_internal.h => ahci-internal.h} | 0
>   hw/ide/ahci.c                               | 2 +-
>   hw/ide/ich.c                                | 2 +-
>   3 files changed, 2 insertions(+), 2 deletions(-)
>   rename hw/ide/{ahci_internal.h => ahci-internal.h} (100%)
> 
> diff --git a/hw/ide/ahci_internal.h b/hw/ide/ahci-internal.h
> similarity index 100%
> rename from hw/ide/ahci_internal.h
> rename to hw/ide/ahci-internal.h
> diff --git a/hw/ide/ahci.c b/hw/ide/ahci.c
> index b8123bc73d..bfefad2965 100644
> --- a/hw/ide/ahci.c
> +++ b/hw/ide/ahci.c
> @@ -37,7 +37,7 @@
>   #include "hw/ide/pci.h"
>   #include "hw/ide/ahci-pci.h"
>   #include "hw/ide/ahci-sysbus.h"
> -#include "ahci_internal.h"
> +#include "ahci-internal.h"
>   #include "ide-internal.h"
>   
>   #include "trace.h"
> diff --git a/hw/ide/ich.c b/hw/ide/ich.c
> index 3ea793d790..9b909c87f3 100644
> --- a/hw/ide/ich.c
> +++ b/hw/ide/ich.c
> @@ -70,7 +70,7 @@
>   #include "sysemu/dma.h"
>   #include "hw/ide/pci.h"
>   #include "hw/ide/ahci-pci.h"
> -#include "ahci_internal.h"
> +#include "ahci-internal.h"
>   
>   #define ICH9_MSI_CAP_OFFSET     0x80
>   #define ICH9_SATA_CAP_OFFSET    0xA8

Reviewed-by: Thomas Huth <thuth@redhat.com>
Philippe Mathieu-Daudé Feb. 27, 2024, 4:39 p.m. UTC | #3
On 27/2/24 14:13, BALATON Zoltan wrote:
> Other headers now use dash instead of underscore. Rename
> ahci_internal.h accordingly for consistency.
> 
> Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
> ---
>   hw/ide/{ahci_internal.h => ahci-internal.h} | 0
>   hw/ide/ahci.c                               | 2 +-
>   hw/ide/ich.c                                | 2 +-
>   3 files changed, 2 insertions(+), 2 deletions(-)
>   rename hw/ide/{ahci_internal.h => ahci-internal.h} (100%)

Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>

Thanks!
BALATON Zoltan March 10, 2024, 2:27 p.m. UTC | #4
On Tue, 27 Feb 2024, Philippe Mathieu-Daudé wrote:
> On 27/2/24 14:13, BALATON Zoltan wrote:
>> Other headers now use dash instead of underscore. Rename
>> ahci_internal.h accordingly for consistency.
>> 
>> Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
>> ---
>>   hw/ide/{ahci_internal.h => ahci-internal.h} | 0
>>   hw/ide/ahci.c                               | 2 +-
>>   hw/ide/ich.c                                | 2 +-
>>   3 files changed, 2 insertions(+), 2 deletions(-)
>>   rename hw/ide/{ahci_internal.h => ahci-internal.h} (100%)
>
> Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>

Was this also queued somewhere? I haven't seen it merged neither with the 
trivial nor the misc-hw pull requests.

Regards,
BALATON Zoltan
Markus Armbruster March 11, 2024, 7:05 a.m. UTC | #5
BALATON Zoltan <balaton@eik.bme.hu> writes:

> On Tue, 27 Feb 2024, Philippe Mathieu-Daudé wrote:
>> On 27/2/24 14:13, BALATON Zoltan wrote:
>>> Other headers now use dash instead of underscore. Rename
>>> ahci_internal.h accordingly for consistency.
>>> Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
>>> ---
>>>   hw/ide/{ahci_internal.h => ahci-internal.h} | 0
>>>   hw/ide/ahci.c                               | 2 +-
>>>   hw/ide/ich.c                                | 2 +-
>>>   3 files changed, 2 insertions(+), 2 deletions(-)
>>>   rename hw/ide/{ahci_internal.h => ahci-internal.h} (100%)
>>
>> Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
>
> Was this also queued somewhere? I haven't seen it merged neither with the trivial nor the misc-hw pull requests.

I figure John (our IDE odd fixer) wouldn't mind this going via
qemu-trivial.  Cc'ed!
Philippe Mathieu-Daudé March 11, 2024, 8:45 a.m. UTC | #6
On 11/3/24 08:05, Markus Armbruster wrote:
> BALATON Zoltan <balaton@eik.bme.hu> writes:
> 
>> On Tue, 27 Feb 2024, Philippe Mathieu-Daudé wrote:
>>> On 27/2/24 14:13, BALATON Zoltan wrote:
>>>> Other headers now use dash instead of underscore. Rename
>>>> ahci_internal.h accordingly for consistency.
>>>> Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
>>>> ---
>>>>    hw/ide/{ahci_internal.h => ahci-internal.h} | 0
>>>>    hw/ide/ahci.c                               | 2 +-
>>>>    hw/ide/ich.c                                | 2 +-
>>>>    3 files changed, 2 insertions(+), 2 deletions(-)
>>>>    rename hw/ide/{ahci_internal.h => ahci-internal.h} (100%)
>>>
>>> Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
>>
>> Was this also queued somewhere? I haven't seen it merged neither with the trivial nor the misc-hw pull requests.
> 
> I figure John (our IDE odd fixer) wouldn't mind this going via
> qemu-trivial.  Cc'ed!

I'll take it, thanks.
diff mbox series

Patch

diff --git a/hw/ide/ahci_internal.h b/hw/ide/ahci-internal.h
similarity index 100%
rename from hw/ide/ahci_internal.h
rename to hw/ide/ahci-internal.h
diff --git a/hw/ide/ahci.c b/hw/ide/ahci.c
index b8123bc73d..bfefad2965 100644
--- a/hw/ide/ahci.c
+++ b/hw/ide/ahci.c
@@ -37,7 +37,7 @@ 
 #include "hw/ide/pci.h"
 #include "hw/ide/ahci-pci.h"
 #include "hw/ide/ahci-sysbus.h"
-#include "ahci_internal.h"
+#include "ahci-internal.h"
 #include "ide-internal.h"
 
 #include "trace.h"
diff --git a/hw/ide/ich.c b/hw/ide/ich.c
index 3ea793d790..9b909c87f3 100644
--- a/hw/ide/ich.c
+++ b/hw/ide/ich.c
@@ -70,7 +70,7 @@ 
 #include "sysemu/dma.h"
 #include "hw/ide/pci.h"
 #include "hw/ide/ahci-pci.h"
-#include "ahci_internal.h"
+#include "ahci-internal.h"
 
 #define ICH9_MSI_CAP_OFFSET     0x80
 #define ICH9_SATA_CAP_OFFSET    0xA8