diff mbox

AcpiDeviceIf: More readable bitmask definition

Message ID 1497879848-7612-1-git-send-email-cludwig@genua.de
State New
Headers show

Commit Message

Christian Ludwig June 19, 2017, 1:44 p.m. UTC
AcpiEventStatusBits defines bits in a bitmask. Having it in decimal
notation is rather uncommon. Make it more clear which bits are meant
there.

No functional change.

Signed-off-by: Christian Ludwig <cludwig@genua.de>
---
 include/hw/acpi/acpi_dev_interface.h | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

no-reply@patchew.org June 20, 2017, 5:13 a.m. UTC | #1
Hi,

This series seems to have some coding style problems. See output below for
more information:

Subject: [Qemu-devel] [PATCH] AcpiDeviceIf: More readable bitmask definition
Type: series
Message-id: 1497879848-7612-1-git-send-email-cludwig@genua.de

=== TEST SCRIPT BEGIN ===
#!/bin/bash

BASE=base
n=1
total=$(git log --oneline $BASE.. | wc -l)
failed=0

git config --local diff.renamelimit 0
git config --local diff.renames True

commits="$(git log --format=%H --reverse $BASE..)"
for c in $commits; do
    echo "Checking PATCH $n/$total: $(git log -n 1 --format=%s $c)..."
    if ! git show $c --format=email | ./scripts/checkpatch.pl --mailback -; then
        failed=1
        echo
    fi
    n=$((n+1))
done

exit $failed
=== TEST SCRIPT END ===

Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
Switched to a new branch 'test'
7da9f99 AcpiDeviceIf: More readable bitmask definition

=== OUTPUT BEGIN ===
Checking PATCH 1/1: AcpiDeviceIf: More readable bitmask definition...
ERROR: code indent should never use tabs
#28: FILE: include/hw/acpi/acpi_dev_interface.h:10:
+    ACPI_PCI_HOTPLUG_STATUS =^I^I(1 << 1),$

ERROR: code indent should never use tabs
#29: FILE: include/hw/acpi/acpi_dev_interface.h:11:
+    ACPI_CPU_HOTPLUG_STATUS =^I^I(1 << 2),$

ERROR: code indent should never use tabs
#30: FILE: include/hw/acpi/acpi_dev_interface.h:12:
+    ACPI_MEMORY_HOTPLUG_STATUS =^I(1 << 3),$

ERROR: code indent should never use tabs
#31: FILE: include/hw/acpi/acpi_dev_interface.h:13:
+    ACPI_NVDIMM_HOTPLUG_STATUS =^I(1 << 4),$

ERROR: code indent should never use tabs
#32: FILE: include/hw/acpi/acpi_dev_interface.h:14:
+    ACPI_VMGENID_CHANGE_STATUS =^I(1 << 5),$

total: 5 errors, 0 warnings, 16 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.

=== OUTPUT END ===

Test command exited with code: 1


---
Email generated automatically by Patchew [http://patchew.org/].
Please send your feedback to patchew-devel@freelists.org
diff mbox

Patch

diff --git a/include/hw/acpi/acpi_dev_interface.h b/include/hw/acpi/acpi_dev_interface.h
index 3c2e4e9..f526a6c 100644
--- a/include/hw/acpi/acpi_dev_interface.h
+++ b/include/hw/acpi/acpi_dev_interface.h
@@ -7,11 +7,11 @@ 
 
 /* These values are part of guest ABI, and can not be changed */
 typedef enum {
-    ACPI_PCI_HOTPLUG_STATUS = 2,
-    ACPI_CPU_HOTPLUG_STATUS = 4,
-    ACPI_MEMORY_HOTPLUG_STATUS = 8,
-    ACPI_NVDIMM_HOTPLUG_STATUS = 16,
-    ACPI_VMGENID_CHANGE_STATUS = 32,
+    ACPI_PCI_HOTPLUG_STATUS =		(1 << 1),
+    ACPI_CPU_HOTPLUG_STATUS =		(1 << 2),
+    ACPI_MEMORY_HOTPLUG_STATUS =	(1 << 3),
+    ACPI_NVDIMM_HOTPLUG_STATUS =	(1 << 4),
+    ACPI_VMGENID_CHANGE_STATUS =	(1 << 5),
 } AcpiEventStatusBits;
 
 #define TYPE_ACPI_DEVICE_IF "acpi-device-interface"