diff mbox

[15/55] ide/atapi: Clean up misleading name in cmd_start_stop_unit()

Message ID 1311179069-27882-16-git-send-email-armbru@redhat.com
State New
Headers show

Commit Message

Markus Armbruster July 20, 2011, 4:23 p.m. UTC
"eject" is misleading; it means "eject" when start is clear, but
"load" when start is set.  Rename to loej, because that's how MMC-5
calls it, in section 6.40.

Signed-off-by: Markus Armbruster <armbru@redhat.com>
---
 hw/ide/atapi.c |    8 ++++----
 1 files changed, 4 insertions(+), 4 deletions(-)

Comments

Christoph Hellwig July 26, 2011, 11:59 a.m. UTC | #1
On Wed, Jul 20, 2011 at 06:23:49PM +0200, Markus Armbruster wrote:
> "eject" is misleading; it means "eject" when start is clear, but
> "load" when start is set.  Rename to loej, because that's how MMC-5
> calls it, in section 6.40.

Just as clear as the bdrv_eject name :)

Looks fine anyway,

Reviewed-by: Christoph Hellwig <hch@lst.de>
diff mbox

Patch

diff --git a/hw/ide/atapi.c b/hw/ide/atapi.c
index fe2fb0b..17fbef8 100644
--- a/hw/ide/atapi.c
+++ b/hw/ide/atapi.c
@@ -892,11 +892,11 @@  static void cmd_seek(IDEState *s, uint8_t* buf)
 
 static void cmd_start_stop_unit(IDEState *s, uint8_t* buf)
 {
-    int start, eject, sense, err = 0;
-    start = buf[4] & 1;
-    eject = (buf[4] >> 1) & 1;
+    int sense, err = 0;
+    bool start = buf[4] & 1;
+    bool loej = buf[4] & 2;
 
-    if (eject) {
+    if (loej) {
         err = bdrv_eject(s->bs, !start);
     }