diff mbox

[4/6] virtio-console-port: Add a new device on the virtio-console-bus for generic host-guest communication

Message ID 1254225888-17093-5-git-send-email-amit.shah@redhat.com
State Superseded
Headers show

Commit Message

Amit Shah Sept. 29, 2009, 12:04 p.m. UTC
This is a new device that uses the virtio-console bus.

Sample uses for such a device can be obtaining info from the
guest like the file systems used, apps installed, etc. for
offline usage and logged-in users, clipboard copy-paste, etc.
for online usage.

    For requirements, use-cases and some history see

        http://www.linux-kvm.org/page/VMchannel_Requirements

Signed-off-by: Amit Shah <amit.shah@redhat.com>
---
 Makefile.target          |    2 +-
 hw/virtio-console-port.c |   54 ++++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 55 insertions(+), 1 deletions(-)
 create mode 100644 hw/virtio-console-port.c

Comments

Gerd Hoffmann Sept. 29, 2009, 6:08 p.m. UTC | #1
> +typedef struct VirtIOConsole
> +{
> +    VirtConPort port;

Your CharDriverState should go here.

> +        DEFINE_PROP_INT32("flush_buffers", VirtConPort, flush_buffers, 0),

Well, we should find a better name for that one.  flush_buffers is very 
unclear.  It actually is dont_cache_data_when_unconnected.  That name is 
insane long though.

cheers,
   Gerd
Nathan Baum Sept. 30, 2009, 8:09 a.m. UTC | #2
On Tue, 2009-09-29 at 20:08 +0200, Gerd Hoffmann wrote:
> > +typedef struct VirtIOConsole
> > +{
> > +    VirtConPort port;
> 
> Your CharDriverState should go here.
> 
> > +        DEFINE_PROP_INT32("flush_buffers", VirtConPort, flush_buffers, 0),
> 
> Well, we should find a better name for that one.  flush_buffers is very 
> unclear.  It actually is dont_cache_data_when_unconnected.  That name is 
> insane long though.

volatile_when_unconnected?
diff mbox

Patch

diff --git a/Makefile.target b/Makefile.target
index 22a2644..918275a 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -173,7 +173,7 @@  obj-y = vl.o monitor.o pci.o isa_mmio.o machine.o \
         gdbstub.o gdbstub-xml.o
 # virtio has to be here due to weird dependency between PCI and virtio-net.
 # need to fix this properly
-obj-y += virtio-blk.o virtio-balloon.o virtio-net.o virtio-console.o virtio-console-bus.o virtio-pci.o
+obj-y += virtio-blk.o virtio-balloon.o virtio-net.o virtio-console.o virtio-console-port.o virtio-console-bus.o virtio-pci.o
 obj-$(CONFIG_KVM) += kvm.o kvm-all.o
 
 LIBS+=-lz
diff --git a/hw/virtio-console-port.c b/hw/virtio-console-port.c
new file mode 100644
index 0000000..f8c0bbc
--- /dev/null
+++ b/hw/virtio-console-port.c
@@ -0,0 +1,54 @@ 
+/*
+ * Virtio Serial Port
+ *
+ * Copyright Red Hat, Inc. 2009
+ *
+ * Authors:
+ *  Amit Shah <amit.shah@redhat.com>
+ *
+ * This work is licensed under the terms of the GNU GPL, version 2.  See
+ * the COPYING file in the top-level directory.
+ *
+ */
+
+#include "hw.h"
+#include "qemu-char.h"
+#include "virtio-console.h"
+
+typedef struct VirtIOConsole
+{
+    VirtConPort port;
+} VirtIOConsole;
+
+static size_t flush_buf(VirtConPort *port, const uint8_t *buf, size_t len)
+{
+    return qemu_chr_write(port->chr, buf, len);
+}
+
+static int vcon_port_initfn(VirtConDevice *dev)
+{
+    VirtConPort *port = DO_UPCAST(VirtConPort, dev, &dev->qdev);
+
+    port->info = dev->info;
+
+    return 0;
+}
+
+static VirtConPortInfo virtcon_port_info = {
+    .qdev.name     = "virtconport",
+    .qdev.size     = sizeof(VirtConPort),
+    .init          = vcon_port_initfn,
+    .have_data     = flush_buf,
+    .qdev.props = (Property[]) {
+        DEFINE_PROP_CHR("chardev", VirtConPort, chr),
+        DEFINE_PROP_STRING("name", VirtConPort, name),
+        DEFINE_PROP_INT32("flush_buffers", VirtConPort, flush_buffers, 0),
+        DEFINE_PROP_END_OF_LIST(),
+    },
+};
+
+static void virtcon_port_register(void)
+{
+    virtcon_port_qdev_register(&virtcon_port_info);
+}
+device_init(virtcon_port_register)