Show patches with: Archived = No       |   430925 patches
« 1 2 ... 1978 1979 19804309 4310 »
Patch Series A/F/R/T S/W/F Date Submitter Delegate State
[v2,18/32] qmp: Don't let JSON errors jump the queue ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,19/32] monitor: Rename use_io_thr to use_io_thread ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,20/32] monitor: Peel off @mon_global wrapper ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,21/32] qobject: New qdict_from_jsonf_nofail() ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,22/32] qmp: De-duplicate error response building ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,23/32] qmp: Use QDict * instead of QObject * for response objects ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,24/32] qmp: Replace monitor_json_emitter{, raw}() by qmp_{queue, send}_response() ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,25/32] qmp: Replace get_qmp_greeting() by qmp_greeting() ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,26/32] qmp: Simplify monitor_qmp_respond() ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,27/32] qmp: Add some comments around null responses ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,28/32] qmp: Switch timestamp_put() to qdict_from_jsonf_nofail() ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,29/32] qobject: Let qobject_from_jsonf() fail instead of abort ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,30/32] qmp: Clean up capability negotiation after commit 02130314d8c ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,31/32] monitor: Improve some comments ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[v2,32/32] qapi: Polish command flags documentation in qapi-code-gen.txt ] qmp: Fixes and cleanups around OOB commands - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,00/32] Monitor patches for 2018-07-03 - - - - --- 2018-07-03 Markus Armbruster New
[PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,02/32] monitor: Spell "I/O thread" consistently in comments [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,03/32] docs/interop/qmp: Improve OOB documentation [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,04/32] qmp: Document COMMAND_DROPPED design flaw [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,05/32] qmp: Get rid of x-oob-test command [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,06/32] tests/qmp-test: Test in-band command doesn't overtake [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,07/32] qmp: Make "id" optional again even in "oob" monitors [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,08/32] tests/test-qga: Demonstrate the guest-agent ignores "id" [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,09/32] qmp qemu-ga: Revert change that accidentally made qemu-ga accept "id" [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,10/32] tests/test-qga: Demonstrate the guest-agent ignores "control" [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,11/32] qmp qemu-ga: Fix qemu-ga not to accept "control" [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,12/32] qmp: Redo how the client requests out-of-band execution [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,13/32] qmp: Revert change to handle_qmp_command tracepoint [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,14/32] qmp: Always free QMPRequest with qmp_request_free() [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,15/32] qmp: Simplify code around monitor_qmp_dispatch_one() [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,16/32] tests/qmp-test: Demonstrate QMP errors jumping the queue [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 2 - --- 2018-07-03 Markus Armbruster New
[PULL,17/32] qmp: Don't let malformed in-band commands jump the queue [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,18/32] qmp: Don't let JSON errors jump the queue [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,19/32] monitor: Rename use_io_thr to use_io_thread [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,20/32] monitor: Peel off @mon_global wrapper [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,21/32] qobject: New qdict_from_jsonf_nofail() [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,22/32] qmp: De-duplicate error response building [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,23/32] qmp: Use QDict * instead of QObject * for response objects [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,24/32] qmp: Replace monitor_json_emitter{, raw}() by qmp_{queue, send}_response() [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,25/32] qmp: Replace get_qmp_greeting() by qmp_greeting() [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,26/32] qmp: Simplify monitor_qmp_respond() [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,27/32] qmp: Add some comments around null responses [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,28/32] qmp: Switch timestamp_put() to qdict_from_jsonf_nofail() [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,29/32] qobject: Let qobject_from_jsonf() fail instead of abort [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,30/32] qmp: Clean up capability negotiation after commit 02130314d8c [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,31/32] monitor: Improve some comments [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,32/32] qapi: Polish command flags documentation in qapi-code-gen.txt [PULL,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,00/14] QAPI patches for 2018-07-03 - - - - --- 2018-07-03 Markus Armbruster New
[PULL,01/14] qapi: add 'if' to top-level expressions [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,02/14] qapi: pass 'if' condition into QAPISchemaEntity objects [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,03/14] qapi: leave the ifcond attribute undefined until check() [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,04/14] qapi: add 'ifcond' to visitor methods [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,05/14] qapi: mcgen() shouldn't indent # lines [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,06/14] qapi: add #if/#endif helpers [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,07/14] qapi-introspect: modify to_qlit() to append ', ' on level > 0 [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,08/14] qapi-introspect: add preprocessor conditions to generated QLit [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,09/14] qapi/commands: add #if conditions to commands [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,10/14] qapi/events: add #if conditions to events [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,11/14] qapi-types: add #if conditions to types & visitors [PULL,01/14] qapi: add 'if' to top-level expressions - - - - --- 2018-07-03 Markus Armbruster New
[PULL,12/14] qapi: add 'If:' section to generated documentation [PULL,01/14] qapi: add 'if' to top-level expressions - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,13/14] qapi: add conditions to VNC type/commands/events on the schema [PULL,01/14] qapi: add 'if' to top-level expressions - - 2 - --- 2018-07-03 Markus Armbruster New
[PULL,14/14] qapi: add conditions to SPICE type/commands/events on the schema [PULL,01/14] qapi: add 'if' to top-level expressions - - 2 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,00/32] Monitor patches for 2018-07-03 - - - - --- 2018-07-03 Markus Armbruster New
[PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,02/32] monitor: Spell "I/O thread" consistently in comments [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,03/32] docs/interop/qmp: Improve OOB documentation [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,04/32] qmp: Document COMMAND_DROPPED design flaw [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,05/32] qmp: Get rid of x-oob-test command [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,06/32] tests/qmp-test: Test in-band command doesn't overtake [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,07/32] qmp: Make "id" optional again even in "oob" monitors [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 2 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,08/32] tests/test-qga: Demonstrate the guest-agent ignores "id" [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,09/32] qmp qemu-ga: Revert change that accidentally made qemu-ga accept "id" [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,10/32] tests/test-qga: Demonstrate the guest-agent ignores "control" [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,11/32] qmp qemu-ga: Fix qemu-ga not to accept "control" [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,12/32] qmp: Redo how the client requests out-of-band execution [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,13/32] qmp: Revert change to handle_qmp_command tracepoint [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,14/32] qmp: Always free QMPRequest with qmp_request_free() [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,15/32] qmp: Simplify code around monitor_qmp_dispatch_one() [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,16/32] tests/qmp-test: Demonstrate QMP errors jumping the queue [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 2 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,17/32] qmp: Don't let malformed in-band commands jump the queue [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,18/32] qmp: Don't let JSON errors jump the queue [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,19/32] monitor: Rename use_io_thr to use_io_thread [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,20/32] monitor: Peel off @mon_global wrapper [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,21/32] qobject: New qdict_from_jsonf_nofail() [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,22/32] qmp: De-duplicate error response building [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,23/32] qmp: Use QDict * instead of QObject * for response objects [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,24/32] qmp: Replace monitor_json_emitter{, raw}() by qmp_{queue, send}_response() [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,25/32] qmp: Replace get_qmp_greeting() by qmp_greeting() [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,26/32] qmp: Simplify monitor_qmp_respond() [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,27/32] qmp: Add some comments around null responses [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,28/32] qmp: Switch timestamp_put() to qdict_from_jsonf_nofail() [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,29/32] qobject: Let qobject_from_jsonf() fail instead of abort [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,30/32] qmp: Clean up capability negotiation after commit 02130314d8c [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,31/32] monitor: Improve some comments [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[PULL,v2,32/32] qapi: Polish command flags documentation in qapi-code-gen.txt [PULL,v2,01/32] qmp: Say "out-of-band" instead of "Out-Of-Band" - - 1 - --- 2018-07-03 Markus Armbruster New
[1/2] qapi: Do not expose "allow-preconfig" in query-qmp-schema Let's not chisel --preconfig in stone without a user - - 1 - --- 2018-07-05 Markus Armbruster New
[2/2] cli qmp: Mark --preconfig, exit-preconfig experimental Let's not chisel --preconfig in stone without a user - - 1 - --- 2018-07-05 Markus Armbruster New
[PULL,0/1] Coverity model patches for 2018-07-05 - - - - --- 2018-07-05 Markus Armbruster New
[PULL,1/1] coverity-model: Fix replay_get_byte() [PULL,1/1] coverity-model: Fix replay_get_byte() - - 1 - --- 2018-07-05 Markus Armbruster New
« 1 2 ... 1978 1979 19804309 4310 »