Show patches with: State = Action Required       |    Archived = No       |   427146 patches
« 1 2 ... 434 435 4364271 4272 »
Patch Series A/F/R/T S/W/F Date Submitter Delegate State
[15/22] usb: Add packet combining functions - - - - --- 2012-10-24 Hans de Goede New
[16/22] combined-packet: Add a workaround for Linux usbfs + live migration - - - - --- 2012-10-24 Hans de Goede New
[17/22] usb-redir: Add support for 32 bits bulk packet length - - - - --- 2012-10-24 Hans de Goede New
[18/22] usb-redir: Add support for input pipelining - - - - --- 2012-10-24 Hans de Goede New
[19/22] usb-redir: Add an usbredir_setup_usb_eps() helper function - - - - --- 2012-10-24 Hans de Goede New
[20/22] usb-redir: Use reject rather the disconnect on bad ep info - - - - --- 2012-10-24 Hans de Goede New
[21/22] usb-redir: Allow to attach USB 2.0 devices to 1.1 host controller - - - - --- 2012-10-24 Hans de Goede New
[22/22] usb-redir: Allow redirecting super speed devices to high speed controllers - - - - --- 2012-10-24 Hans de Goede New
[01/17] usb: Enforce iso endpoints never returing USB_RET_ASYNC - - - - --- 2012-10-24 Hans de Goede New
[02/17] uhci: No need to handle async completion of isoc packets - - - - --- 2012-10-24 Hans de Goede New
[03/17] uhci: cleanup: Add an unlink call to uhci_async_cancel() - - - - --- 2012-10-24 Hans de Goede New
[04/17] uhci: Don't retry on error - - - - --- 2012-10-24 Hans de Goede New
[05/17] uhci: Drop unnecessary forward declaration of some static functions - - - - --- 2012-10-24 Hans de Goede New
[06/17] uhci: Move emptying of the queue's asyncs' queue to uhci_queue_free - - - - --- 2012-10-24 Hans de Goede New
[07/17] uhci: Rename UHCIAsync->td to UHCIAsync->td_addr - - - - --- 2012-10-24 Hans de Goede New
[08/17] uhci: Add uhci_read_td() helper function - - - - --- 2012-10-24 Hans de Goede New
[09/17] uhci: Make uhci_fill_queue() actually operate on an UHCIQueue - - - - --- 2012-10-24 Hans de Goede New
[10/17] uhci: Store ep in UHCIQueue - - - - --- 2012-10-24 Hans de Goede New
[11/17] uhci: Immediately free queues on device disconnect - - - - --- 2012-10-24 Hans de Goede New
[12/17] uhci: Verify queue has not been changed by guest - - - - --- 2012-10-24 Hans de Goede New
[13/17] uhci: Detect guest td re-use - - - - --- 2012-10-24 Hans de Goede New
[14/17] uhci: When the guest marks a pending td non-active, cancel the queue - - - - --- 2012-10-24 Hans de Goede New
[15/17] uhci: Always mark a queue valid when we encounter it - - - - --- 2012-10-24 Hans de Goede New
[16/17] uhci: Retry to fill the queue while waiting for td completion - - - - --- 2012-10-24 Hans de Goede New
[17/17] uhci: Use only one queue for ctrl endpoints - - - - --- 2012-10-24 Hans de Goede New
[01/27] move I/O-related definitions from qemu-common.h to a new header (qemu-stdio.h) - - - - --- 2012-10-24 Eduardo Habkost New
[02/27] cpus.h: include qemu-stdio.h - - - - --- 2012-10-24 Eduardo Habkost New
[03/27] hw/apic.c: rename bit functions to not conflict with bitops.h - - - - --- 2012-10-24 Eduardo Habkost New
[04/27] target-i386: initialize APIC at CPU level - - - - --- 2012-10-24 Eduardo Habkost New
[05/27] kvm: create kvm_arch_vcpu_id() function - - - - --- 2012-10-24 Eduardo Habkost New
[06/27] target-i386: kvm: set vcpu_id to APIC ID instead of CPU index - - - - --- 2012-10-24 Eduardo Habkost New
[07/27] pc: pc_init1(): always use rom_memory on pc_memory_init() call - - - - --- 2012-10-24 Eduardo Habkost New
[08/27] pc: pc_init1(): remove MemoryRegion arguments - - - - --- 2012-10-24 Eduardo Habkost New
[09/27] pc: pc_init1(): get QEMUMachineInitArgs argument - - - - --- 2012-10-24 Eduardo Habkost New
[10/27] pc: create PCInitArgs struct - - - - --- 2012-10-24 Eduardo Habkost New
[11/27] pc: add PC_DEFAULT_CPU_MODEL #define - - - - --- 2012-10-24 Eduardo Habkost New
[12/27] pc: add PCInitArgs parameter to pc_cpus_init() - - - - --- 2012-10-24 Eduardo Habkost New
[13/27] pc: pass PCInitArgs struct to pc_memory_init() - - - - --- 2012-10-24 Eduardo Habkost New
[14/27] pc: use FWCfgState* instead of void* for fw_cfg data - - - - --- 2012-10-24 Eduardo Habkost New
[15/27] pc: rename bochs_bios_init() to pc_bios_init() - - - - --- 2012-10-24 Eduardo Habkost New
[16/27] pc: pass PCInitArgs struct to pc_bios_init() - - - - --- 2012-10-24 Eduardo Habkost New
[17/27] xen_machine_pv: use cpu_init() instead of cpu_x86_init() - - - - --- 2012-10-24 Eduardo Habkost New
[18/27] pc: isolate the code that create CPUs - - - - --- 2012-10-24 Eduardo Habkost New
[19/27] cpu_x86_init: check for x86_cpu_realize() errors - - - - --- 2012-10-24 Eduardo Habkost New
[20/27] target-i386: do not call x86_cpu_realize() on cpu_x86_init() - - - - --- 2012-10-24 Eduardo Habkost New
[21/27] fw_cfg: remove FW_CFG_MAX_CPUS from fw_cfg_init() - - - - --- 2012-10-24 Eduardo Habkost New
[22/27] pc: set CPU APIC ID explicitly - - - - --- 2012-10-24 Eduardo Habkost New
[23/27] pc: set fw_cfg data based on APIC ID calculation - - - - --- 2012-10-24 Eduardo Habkost New
[24/27] tests: support target-specific unit tests - - - - --- 2012-10-24 Eduardo Habkost New
[25/27] target-i386: topology & APIC ID utility functions - - - - --- 2012-10-24 Eduardo Habkost New
[26/27] pc: create separate init function for pc-1.3 - - - - --- 2012-10-24 Eduardo Habkost New
[27/27] pc: generate APIC IDs according to CPU topology - - - - --- 2012-10-24 Eduardo Habkost New
[v3,02/26] blockdev: Introduce IF_AHCI - - - - --- 2012-10-24 Jason Baron New
[QEMU,1/3] target-i385: make cpu_x86_fill_host() void - - - - --- 2012-10-24 Eduardo Habkost New
[QEMU,2/3] target-i386: cpu: make -cpu host/check/enforce code KVM-specific - - - - --- 2012-10-24 Eduardo Habkost New
[QEMU,3/3] target-i386: kvm_cpu_fill_host: use GET_SUPPORTED_CPUID - - - - --- 2012-10-24 Eduardo Habkost New
[v11] kvm: notify host when the guest is panicked - - - - --- 2012-10-25 Hu Tao New
[v11,1/6] start vm after reseting it - - - - --- 2012-10-25 Hu Tao New
[v11,2/6] update kernel headers - - - - --- 2012-10-25 Hu Tao New
[v11,3/6] add a new runstate: RUN_STATE_GUEST_PANICKED - - - - --- 2012-10-25 Hu Tao New
[v11,4/6] add a new qevent: QEVENT_GUEST_PANICKED - - - - --- 2012-10-25 Hu Tao New
[v11,5/6] introduce a new qom device to deal with panicked event - - - - --- 2012-10-25 Hu Tao New
[v11,6/6] allower the user to disable pv event support - - - - --- 2012-10-25 Hu Tao New
[1/2] hw/xtensa_lx60: don't prematurely explode QEMUMachineInitArgs - - - - --- 2012-10-25 Max Filippov New
[2/2] hw/xtensa_sim: get rid of intermediate xtensa_sim_init - - - - --- 2012-10-25 Max Filippov New
[v2,1/5] KVM: define KVM_CAP_READONLY_MEM unconditionally - - - - --- 2012-10-25 Xiao Guangrong New
[v2,2/5] Qemu: update header files - - - - --- 2012-10-25 Xiao Guangrong New
[v2,3/5] Qemu: do not mark bios readonly - - - - --- 2012-10-25 Xiao Guangrong New
[v2,4/5] Qemu: implement readonly memory - - - - --- 2012-10-25 Xiao Guangrong New
[v2,5/5] Qemu: mark pci rom readonly - - - - --- 2012-10-25 Xiao Guangrong New
[v1,1/8] usb/ehci: parameterise the register region offsets - - - - --- 2012-10-25 Peter Crosthwaite New
[v1,2/8] usb/ehci: Abstract away PCI DMA API - - - - --- 2012-10-25 Peter Crosthwaite New
[v1,3/8] usb/ehci: seperate out PCIisms - - - - --- 2012-10-25 Peter Crosthwaite New
[v1,4/8] usb/ehci: Add usb-ehci-sysbus - - - - --- 2012-10-25 Peter Crosthwaite New
[v1,5/8] xilinx_zynq: add USB controllers - - - - --- 2012-10-25 Peter Crosthwaite New
[v1,6/8] usb/ehci: Guard definition of EHCI_DEBUG - - - - --- 2012-10-25 Peter Crosthwaite New
[v1,7/8] usb/ehci: Debug mode compile fixes - - - - --- 2012-10-25 Peter Crosthwaite New
[v1,8/8] usb/ehci: Put RAM in undefined MMIO regions - - - - --- 2012-10-25 Peter Crosthwaite New
pci: avoid destroying bridge address space windows in a transaction 1 - - 1 --- 2012-10-25 Avi Kivity New
[v2,1/2] hw/xtensa_lx60: don't prematurely explode QEMUMachineInitArgs - - - - --- 2012-10-25 Max Filippov New
[v2,2/2] hw/xtensa_sim: get rid of intermediate xtensa_sim_init - - - - --- 2012-10-25 Max Filippov New
hw/qxl: vaildate surface->data - - - - --- 2012-10-25 Alon Levy New
[PULL,00/36] usb patch queue - - - - --- 2012-10-25 Gerd Hoffmann New
[01/36] uhci: Properly unmap packets on cancel / invalid pid - - - - --- 2012-10-25 Gerd Hoffmann New
[02/36] uhci: Move checks to continue queuing to uhci_fill_queue() - - - - --- 2012-10-25 Gerd Hoffmann New
[03/36] ehci: Get rid of packet tbytes field - - - - --- 2012-10-25 Gerd Hoffmann New
[04/36] ehci: Set int flag on a short input packet - - - - --- 2012-10-25 Gerd Hoffmann New
[05/36] ehci: Improve latency of interrupt delivery and async schedule scanning - - - - --- 2012-10-25 Gerd Hoffmann New
[06/36] ehci: Speed up the timer of raising int from the async schedule - - - - --- 2012-10-25 Gerd Hoffmann New
[07/36] ehci: Detect going in circles when filling the queue - - - - --- 2012-10-25 Gerd Hoffmann New
[08/36] ehci: Retry to fill the queue while waiting for td completion - - - - --- 2012-10-25 Gerd Hoffmann New
[09/36] xhci: Add a xhci_ep_nuke_one_xfer helper function - - - - --- 2012-10-25 Gerd Hoffmann New
[10/36] usb: Rename __usb_packet_complete to usb_packet_complete_one - - - - --- 2012-10-25 Gerd Hoffmann New
[11/36] usb: Add USB_RET_ADD_TO_QUEUE packet result code - - - - --- 2012-10-25 Gerd Hoffmann New
[12/36] usb: Move clearing of queue on halt to the core - - - - --- 2012-10-25 Gerd Hoffmann New
[13/36] usb: Move short-not-ok handling to the core - - - - --- 2012-10-25 Gerd Hoffmann New
[14/36] usb: Add an int_req flag to USBPacket - - - - --- 2012-10-25 Gerd Hoffmann New
[15/36] usb: Enforce iso endpoints never returing USB_RET_ASYNC - - - - --- 2012-10-25 Gerd Hoffmann New
[16/36] uhci: No need to handle async completion of isoc packets - - - - --- 2012-10-25 Gerd Hoffmann New
[17/36] uhci: cleanup: Add an unlink call to uhci_async_cancel() - - - - --- 2012-10-25 Gerd Hoffmann New
« 1 2 ... 434 435 4364271 4272 »