Show patches with: Archived = No       |   435808 patches
« 1 2 ... 1522 1523 15244358 4359 »
Patch Series A/F/R/T S/W/F Date Submitter Delegate State
[v1] target/riscv: fix pmp implementation [v1] target/riscv: fix pmp implementation - - 1 - --- 2020-07-06 Alexandre Mergnat New
[v3,44/44] hmp: Ignore Error objects where the return value suffices Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,43/44] qdev: Ignore Error objects where the return value suffices Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,42/44] qemu-img: Ignore Error objects where the return value suffices Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,41/44] error: Avoid error_propagate() after migrate_add_blocker() Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,40/44] qapi: Purge error_propagate() from QAPI core Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,39/44] qapi: Smooth visitor error checking in generated code Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,38/44] qapi: Smooth another visitor error checking pattern Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,37/44] block/parallels: Simplify parallels_open() after previous commit Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,36/44] error: Reduce unnecessary error propagation Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,35/44] error: Eliminate error_propagate() manually Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,34/44] error: Eliminate error_propagate() with Coccinelle, part 2 Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,33/44] error: Eliminate error_propagate() with Coccinelle, part 1 Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,32/44] error: Avoid unnecessary error_propagate() after error_setg() Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,31/44] qdev: Use returned bool to check for failure, Coccinelle part Less clumsy error checking - - 1 - --- 2020-07-06 Markus Armbruster New
[v3,30/44] qdev: Make functions taking Error ** return bool, not void Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,29/44] qom: Make functions taking Error ** return bool, not 0/-1 Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,28/44] qom: Use returned bool to check for failure, manual part Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,27/44] qom: Use returned bool to check for failure, Coccinelle part Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,26/44] qom: Make functions taking Error ** return bool, not void Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,25/44] qom: Put name parameter before value / visitor parameter Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,24/44] qom: Use return values to check for error where that's simpler Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,23/44] qom: Don't handle impossible object_property_get_link() failure Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,22/44] qom: Crash more nicely on object_property_get_link() failure Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,21/44] qom: Rename qdev_get_type() to object_get_type() Less clumsy error checking - - 3 - --- 2020-07-06 Markus Armbruster New
[v3,20/44] qom: Use error_reportf_err() instead of g_printerr() in examples Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,19/44] s390x/pci: Fix harmless mistake in zpci's property fid's setter Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,18/44] qapi: Use returned bool to check for failure, manual part Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,17/44] qapi: Use returned bool to check for failure, Coccinelle part Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,16/44] qapi: Make visitor functions taking Error ** return bool, not void Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,15/44] hmp: Eliminate a variable in hmp_migrate_set_parameter() Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,14/44] block: Avoid error accumulation in bdrv_img_create() Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,13/44] qemu-option: Use returned bool to check for failure Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,12/44] qemu-option: Make functions taking Error ** return bool, not void Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,11/44] qemu-option: Replace opt_set() by cleaner opt_validate() Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,10/44] qemu-option: Factor out helper opt_create() Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,09/44] qemu-option: Simplify around find_default_by_name() Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,08/44] qemu-option: Factor out helper find_default_by_name() Less clumsy error checking - - 3 - --- 2020-07-06 Markus Armbruster New
[v3,07/44] qemu-option: Make uses of find_desc_by_name() more similar Less clumsy error checking - - 3 - --- 2020-07-06 Markus Armbruster New
[v3,06/44] qemu-option: Check return value instead of @err where convenient Less clumsy error checking - - 3 - --- 2020-07-06 Markus Armbruster New
[v3,05/44] virtio-crypto-pci: Tidy up virtio_crypto_pci_realize() Less clumsy error checking - - 3 - --- 2020-07-06 Markus Armbruster New
[v3,04/44] macio: Tidy up error handling in macio_newworld_realize() Less clumsy error checking 1 - 3 - --- 2020-07-06 Markus Armbruster New
[v3,03/44] qdev: Use returned bool to check for qdev_realize() etc. failure Less clumsy error checking - - 2 - --- 2020-07-06 Markus Armbruster New
[v3,02/44] error: Document Error API usage rules Less clumsy error checking - - 3 - --- 2020-07-06 Markus Armbruster New
[v3,01/44] error: Improve examples in error.h's big comment Less clumsy error checking - - 3 - --- 2020-07-06 Markus Armbruster New
[PULL,6/6] tests/acceptance: Add a test for the sun4u sparc64 machine [PULL,1/6] fuzz: fix broken qtest check at rcu_disable_atfork - - 1 2 --- 2020-07-06 Thomas Huth New
[PULL,5/6] hw/m68k/mcf5206: Replace remaining hw_error()s by qemu_log_mask() [PULL,1/6] fuzz: fix broken qtest check at rcu_disable_atfork - - 2 - --- 2020-07-06 Thomas Huth New
[PULL,4/6] configure / util: Auto-detect the availability of openpty() [PULL,1/6] fuzz: fix broken qtest check at rcu_disable_atfork - - - 1 --- 2020-07-06 Thomas Huth New
[PULL,3/6] tests/qtest: Unify the test for the xenfv and xenpv machines [PULL,1/6] fuzz: fix broken qtest check at rcu_disable_atfork - - 1 - --- 2020-07-06 Thomas Huth New
[PULL,2/6] fuzz: do not use POSIX shm for coverage bitmap [PULL,1/6] fuzz: fix broken qtest check at rcu_disable_atfork - - 2 - --- 2020-07-06 Thomas Huth New
[PULL,1/6] fuzz: fix broken qtest check at rcu_disable_atfork [PULL,1/6] fuzz: fix broken qtest check at rcu_disable_atfork - - - - --- 2020-07-06 Thomas Huth New
[PULL,0/6] qtest and misc patches - - - - --- 2020-07-06 Thomas Huth New
ram: add support for dirty page tracking ram: add support for dirty page tracking - - - - --- 2020-07-06 Bingsong Si New
[v3,18/18] hw/block/nvme: bump supported version to v1.3 hw/block/nvme: bump to v1.3 - - 2 - --- 2020-07-06 Klaus Jensen New
[v3,17/18] hw/block/nvme: provide the mandatory subnqn field hw/block/nvme: bump to v1.3 - - 3 - --- 2020-07-06 Klaus Jensen New
[v3,16/18] hw/block/nvme: enforce valid queue creation sequence hw/block/nvme: bump to v1.3 - - 2 - --- 2020-07-06 Klaus Jensen New
[v3,15/18] hw/block/nvme: reject invalid nsid values in active namespace id list hw/block/nvme: bump to v1.3 - - 3 - --- 2020-07-06 Klaus Jensen New
[v3,14/18] hw/block/nvme: support identify namespace descriptor list hw/block/nvme: bump to v1.3 - - 2 - --- 2020-07-06 Klaus Jensen New
[v3,13/18] hw/block/nvme: make sure ncqr and nsqr is valid hw/block/nvme: bump to v1.3 1 - 2 - --- 2020-07-06 Klaus Jensen New
[v3,12/18] hw/block/nvme: support the get/set features select and save fields hw/block/nvme: bump to v1.3 - - 2 - --- 2020-07-06 Klaus Jensen New
[v3,11/18] hw/block/nvme: add remaining mandatory controller parameters hw/block/nvme: bump to v1.3 - - 2 - --- 2020-07-06 Klaus Jensen New
[v3,10/18] hw/block/nvme: flush write cache when disabled hw/block/nvme: bump to v1.3 - - 2 - --- 2020-07-06 Klaus Jensen New
[v3,09/18] hw/block/nvme: move NvmeFeatureVal into hw/block/nvme.h hw/block/nvme: bump to v1.3 - - 2 - --- 2020-07-06 Klaus Jensen New
[v3,08/18] hw/block/nvme: add support for the asynchronous event request command hw/block/nvme: bump to v1.3 1 - 2 - --- 2020-07-06 Klaus Jensen New
[v3,07/18] hw/block/nvme: add support for the get log page command hw/block/nvme: bump to v1.3 1 - 2 - --- 2020-07-06 Klaus Jensen New
[v3,06/18] hw/block/nvme: mark fw slot 1 as read-only hw/block/nvme: bump to v1.3 - - 2 - --- 2020-07-06 Klaus Jensen New
[v3,05/18] hw/block/nvme: add temperature threshold feature hw/block/nvme: bump to v1.3 1 - 2 - --- 2020-07-06 Klaus Jensen New
[v3,04/18] hw/block/nvme: add support for the abort command hw/block/nvme: bump to v1.3 1 - 2 - --- 2020-07-06 Klaus Jensen New
[v3,03/18] hw/block/nvme: additional tracing hw/block/nvme: bump to v1.3 - - 3 - --- 2020-07-06 Klaus Jensen New
[v3,02/18] hw/block/nvme: fix missing endian conversion hw/block/nvme: bump to v1.3 - - 3 - --- 2020-07-06 Klaus Jensen New
[v3,01/18] hw/block/nvme: bump spec data structures to v1.3 hw/block/nvme: bump to v1.3 1 - 2 - --- 2020-07-06 Klaus Jensen New
target/xtensa: implement NMI support target/xtensa: implement NMI support - - - - --- 2020-07-06 Max Filippov New
[2/2] target/i386: Enable TSX Suspend Load Address Tracking feature Add new features for intel processor - - - - --- 2020-07-05 Cathy Zhang New
[1/2] target/i386: Add SERIALIZE cpu feature Add new features for intel processor - - - - --- 2020-07-05 Cathy Zhang New
[v2,5/5] hw/i2c: Document the I2C qdev helpers hw/i2c: Rename method names for consistency and add documentation - - 2 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v2,4/5] hw/i2c: Rename i2c_create_slave() as i2c_slave_create_simple() hw/i2c: Rename method names for consistency and add documentation - - 2 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v2,3/5] hw/i2c: Rename i2c_realize_and_unref() as i2c_slave_realize_and_unref() hw/i2c: Rename method names for consistency and add documentation - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v2,2/5] hw/i2c: Rename i2c_try_create_slave() as i2c_slave_new() hw/i2c: Rename method names for consistency and add documentation - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v2,1/5] hw/i2c/aspeed_i2c: Simplify aspeed_i2c_get_bus() hw/i2c: Rename method names for consistency and add documentation - - 2 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v2] hw/core/qdev: Increase qdev_realize() kindness [v2] hw/core/qdev: Increase qdev_realize() kindness - - - - --- 2020-07-05 Philippe Mathieu-Daudé New
[RFC,2/2] hw/sd/sdcard: Deprecate the SPI mode hw/sd: Deprecate the SPI mode and the SPI to SD adapter 1 - - - --- 2020-07-05 Philippe Mathieu-Daudé New
[RFC,1/2] hw/sd/ssi-sd: Deprecate the SPI to SD card 'adapter' hw/sd: Deprecate the SPI mode and the SPI to SD adapter 1 - - - --- 2020-07-05 Philippe Mathieu-Daudé New
[2/2] hw/sd/pxa2xx_mmci: Trivial simplification hw/sd/pxa2xx_mmci: Do not create SD card within the SDHCI controller - - 2 - --- 2020-07-05 Philippe Mathieu-Daudé New
[1/2] hw/sd/pxa2xx_mmci: Do not create SD card within the SDHCI controller hw/sd/pxa2xx_mmci: Do not create SD card within the SDHCI controller - - 2 - --- 2020-07-05 Philippe Mathieu-Daudé New
[4/4] hw/sd/milkymist: Do not create SD card within the SDHCI controller hw/sd/milkymist: Do not create SD card within the SDHCI controller - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[3/4] hw/sd/milkymist: Create the SDBus at init() hw/sd/milkymist: Do not create SD card within the SDHCI controller - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[2/4] hw/lm32/milkymist: Comment to remember some IRQs lines are left unwired hw/sd/milkymist: Do not create SD card within the SDHCI controller - - - - --- 2020-07-05 Philippe Mathieu-Daudé New
[1/4] hw/lm32/milkymist: Un-inline milkymist_memcard_create() hw/sd/milkymist: Do not create SD card within the SDHCI controller - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v4,10/10] hw/sd: move sdcard legacy API to 'hw/sd/sdcard_legacy.h' hw/sd: convert legacy SDHCI devices to the SDBus API - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v4,09/10] hw/sd/sdcard: make sd_data_ready() static hw/sd: convert legacy SDHCI devices to the SDBus API - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v4,08/10] hw/sd/pl181: Replace disabled fprintf()s by trace events hw/sd: convert legacy SDHCI devices to the SDBus API - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v4,07/10] hw/sd/pl181: Do not create SD card within the SDHCI controller hw/sd: convert legacy SDHCI devices to the SDBus API - - 2 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v4,06/10] hw/sd/pl181: Expose a SDBus and connect the SDCard to it hw/sd: convert legacy SDHCI devices to the SDBus API - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v4,05/10] hw/sd/pl181: Use named GPIOs hw/sd: convert legacy SDHCI devices to the SDBus API - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v4,04/10] hw/arm/versatilepb: Comment to remember some IRQs lines are left unwired hw/sd: convert legacy SDHCI devices to the SDBus API - - - - --- 2020-07-05 Philippe Mathieu-Daudé New
[v4,03/10] hw/sd/pl181: Add TODO to use Fifo32 API hw/sd: convert legacy SDHCI devices to the SDBus API - - - - --- 2020-07-05 Philippe Mathieu-Daudé New
[v4,02/10] hw/sd/pl181: Rename pl181_send_command() as pl181_do_command() hw/sd: convert legacy SDHCI devices to the SDBus API - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
[v4,01/10] hw/sd/pl181: Replace fprintf(stderr, "*\n") with error_report() hw/sd: convert legacy SDHCI devices to the SDBus API - - 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
hw/arm/aspeed: Do not create and attach empty SD cards by default hw/arm/aspeed: Do not create and attach empty SD cards by default - 1 1 - --- 2020-07-05 Philippe Mathieu-Daudé New
load_elf: Remove unused address variables from callers load_elf: Remove unused address variables from callers 2 - 2 - --- 2020-07-05 BALATON Zoltan New
« 1 2 ... 1522 1523 15244358 4359 »