mbox series

[0/9] hw/block/pflash: Refactors around setting the device in read-array mode

Message ID 20210309235028.912078-1-philmd@redhat.com
Headers show
Series hw/block/pflash: Refactors around setting the device in read-array mode | expand

Message

Philippe Mathieu-Daudé March 9, 2021, 11:50 p.m. UTC
I remembered this almost 2 years old series while reviewing
David Edmondson's patches... (which I plan to apply on top).

Basically we move things around to make the code easier to maintain.

Please review :)

Regards,

Phil.

Philippe Mathieu-Daudé (9):
  hw/block/pflash_cfi: Fix code style for checkpatch.pl
  hw/block/pflash_cfi01: Extract pflash_cfi01_fill_cfi_table()
  hw/block/pflash_cfi02: Extract pflash_cfi02_fill_cfi_table()
  hw/block/pflash_cfi02: Set rom_mode to true in pflash_setup_mappings()
  hw/block/pflash_cfi02: Open-code pflash_register_memory(rom=false)
  hw/block/pflash_cfi02: Rename register_memory(true) as mode_read_array
  hw/block/pflash_cfi02: Factor out DeviceReset method
  hw/block/pflash_cfi01: Clarify trace events
  hw/block/pflash_cfi01: Extract pflash_mode_read_array()

 hw/block/pflash_cfi01.c | 201 +++++++++++++++++----------------
 hw/block/pflash_cfi02.c | 238 +++++++++++++++++++++-------------------
 hw/block/trace-events   |   1 +
 3 files changed, 235 insertions(+), 205 deletions(-)