mbox series

[v4,0/5] CPU unplug timeout/LMB unplug cleanup in DRC reconfiguration

Message ID 20210222194531.62717-1-danielhb413@gmail.com
Headers show
Series CPU unplug timeout/LMB unplug cleanup in DRC reconfiguration | expand

Message

Daniel Henrique Barboza Feb. 22, 2021, 7:45 p.m. UTC
Hi,

This new version contains fixes proposed during the review of v3.
Patches were rebased on top of David's ppc-for-6.0.


changes from v3:
- former patch 1: already pushed to ppc-for-6.0
- former patch 2: dropped
- all patches: commit message trimmed to < 76 chars per line
- all patches: added R-bs from previous review
- patch 3:
    * removed the migratable state of the unplug timer
    * added a 'spapr_drc_start_unplug_timeout_timer()' helper to start the timer
    * added a .post_load implementation to vmstate_spapr_drc, pointed to
      a new spapr_drc_post_load() function
    * spapr_drc_post_load() starts the DRC unplug timer from the beginning using
      spapr_drc_start_unplug_timeout_timer()

- patch 4:
    * use spapr_drc_start_unplug_timeout_timer() to start the timer in spapr_drc_unplug_request()
    (To David: I kept your Reviewed-by in this patch despite this change - feel free
     to review it again)

- patch 5:
    * removed the 'DIMM' wording when referring to kernel internals
    * move the g_assert() to spapr_clear_pending_dimm_unplug_state()
    * do not g_assert(dev), but g_assert(ds) if dev != NULL inside
      spapr_clear_pending_dimm_unplug_state()

- v3 link: https://lists.gnu.org/archive/html/qemu-devel/2021-02/msg04196.html

Daniel Henrique Barboza (5):
  spapr_drc.c: use spapr_drc_release() in isolate_physical/set_unusable
  spapr: rename spapr_drc_detach() to spapr_drc_unplug_request()
  spapr_drc.c: introduce unplug_timeout_timer
  spapr_drc.c: add hotunplug timeout for CPUs
  spapr_drc.c: use DRC reconfiguration to cleanup DIMM unplug state

 hw/ppc/spapr.c             | 53 ++++++++++++++++++--
 hw/ppc/spapr_drc.c         | 99 +++++++++++++++++++++++++++++++-------
 hw/ppc/spapr_pci.c         |  4 +-
 hw/ppc/trace-events        |  2 +-
 include/hw/ppc/spapr.h     |  2 +
 include/hw/ppc/spapr_drc.h |  7 ++-
 6 files changed, 142 insertions(+), 25 deletions(-)

Comments

David Gibson Feb. 23, 2021, 4:31 a.m. UTC | #1
On Mon, Feb 22, 2021 at 04:45:26PM -0300, Daniel Henrique Barboza wrote:
> Hi,
> 
> This new version contains fixes proposed during the review of v3.
> Patches were rebased on top of David's ppc-for-6.0.

Applied to ppc-for-6.0.

> 
> 
> changes from v3:
> - former patch 1: already pushed to ppc-for-6.0
> - former patch 2: dropped
> - all patches: commit message trimmed to < 76 chars per line
> - all patches: added R-bs from previous review
> - patch 3:
>     * removed the migratable state of the unplug timer
>     * added a 'spapr_drc_start_unplug_timeout_timer()' helper to start the timer
>     * added a .post_load implementation to vmstate_spapr_drc, pointed to
>       a new spapr_drc_post_load() function
>     * spapr_drc_post_load() starts the DRC unplug timer from the beginning using
>       spapr_drc_start_unplug_timeout_timer()
> 
> - patch 4:
>     * use spapr_drc_start_unplug_timeout_timer() to start the timer in spapr_drc_unplug_request()
>     (To David: I kept your Reviewed-by in this patch despite this change - feel free
>      to review it again)
> 
> - patch 5:
>     * removed the 'DIMM' wording when referring to kernel internals
>     * move the g_assert() to spapr_clear_pending_dimm_unplug_state()
>     * do not g_assert(dev), but g_assert(ds) if dev != NULL inside
>       spapr_clear_pending_dimm_unplug_state()
> 
> - v3 link: https://lists.gnu.org/archive/html/qemu-devel/2021-02/msg04196.html
> 
> Daniel Henrique Barboza (5):
>   spapr_drc.c: use spapr_drc_release() in isolate_physical/set_unusable
>   spapr: rename spapr_drc_detach() to spapr_drc_unplug_request()
>   spapr_drc.c: introduce unplug_timeout_timer
>   spapr_drc.c: add hotunplug timeout for CPUs
>   spapr_drc.c: use DRC reconfiguration to cleanup DIMM unplug state
> 
>  hw/ppc/spapr.c             | 53 ++++++++++++++++++--
>  hw/ppc/spapr_drc.c         | 99 +++++++++++++++++++++++++++++++-------
>  hw/ppc/spapr_pci.c         |  4 +-
>  hw/ppc/trace-events        |  2 +-
>  include/hw/ppc/spapr.h     |  2 +
>  include/hw/ppc/spapr_drc.h |  7 ++-
>  6 files changed, 142 insertions(+), 25 deletions(-)
>