mbox series

[0/3] machine: Make compat_props arrays shorter and more readable

Message ID 20190107193020.21744-1-ehabkost@redhat.com
Headers show
Series machine: Make compat_props arrays shorter and more readable | expand

Message

Eduardo Habkost Jan. 7, 2019, 7:30 p.m. UTC
Current declarations of compat_props arrays are very verbose,
with each entry taking 4 lines of code.  By omitting the field
designators, we can make each array entry fit a single line of
code and be more readable.

Eduardo Habkost (3):
  spapr: Eliminate SPAPR_PCI_2_7_MMIO_WIN_SIZE macro
  machine: Eliminate unnecessary stringify() usage
  machine: Use shorter format for GlobalProperty arrays

 include/hw/i386/pc.h        |  18 +-
 include/hw/pci-host/spapr.h |   1 -
 hw/core/machine.c           | 338 ++++-------------
 hw/i386/pc.c                | 720 +++++++-----------------------------
 hw/i386/pc_piix.c           | 192 ++--------
 hw/ppc/spapr.c              |  72 +---
 hw/s390x/s390-virtio-ccw.c  |  75 +---
 hw/xen/xen-common.c         |  18 +-
 8 files changed, 265 insertions(+), 1169 deletions(-)