mbox series

[v2,0/4] tests: Rename pc-cpu-test.c to cpu-plug-test.c

Message ID 1513597251-21942-1-git-send-email-thuth@redhat.com
Headers show
Series tests: Rename pc-cpu-test.c to cpu-plug-test.c | expand

Message

Thomas Huth Dec. 18, 2017, 11:40 a.m. UTC
So far the CPU hot-plug qtest was only checking "cpu-add" on x86. With
these patches, we now test "device_add" for hot-plugging CPUs on x86,
and enable the test on ppc64 and s390x, too.

v2:
 - Rebased to current master, fixed contextual conflicts in
   tests/Makefile.include
 - Adjusted the data->device_model to the current version of QEMU
   (e.g. use "qemu-s390x-cpu" instead of "qemu-s390-cpu")

Thomas Huth (4):
  tests: Rename pc-cpu-test.c to cpu-plug-test.c
  tests/cpu-plug-test: Check the CPU hot-plugging with device_add, too
  tests/cpu-plug-test: Check CPU hot-plugging on ppc64, too
  tests/cpu-plug-test: Test CPU hot-plugging on s390x

 tests/Makefile.include |   6 +-
 tests/cpu-plug-test.c  | 267 +++++++++++++++++++++++++++++++++++++++++++++++++
 tests/pc-cpu-test.c    | 135 -------------------------
 3 files changed, 271 insertions(+), 137 deletions(-)
 create mode 100644 tests/cpu-plug-test.c
 delete mode 100644 tests/pc-cpu-test.c