mbox series

[00/11] IB netboot 1/3: flexible hwaddrs

Message ID cover.1587059209.git.weeksd2@rpi.edu
Headers show
Series IB netboot 1/3: flexible hwaddrs | expand

Message

Daniel M. Weeks April 16, 2020, 5:53 p.m. UTC
This is the first of three series of patches to petitboot 1.7.x to
support network booting over Infiniband. This series makes all the
changes necessary to support different sized hardware addresses in the
data structures. It also begins with minor additions for debugging that
were useful while developing support for Infiniband. Beyond those
logging additions there should be no functional changes to petitboot.

Daniel M. Weeks (11):
  Debug parsing hwaddr in NVRAM config read
  Debug failure to find device during requery
  Use hwsize rather than HWADDR_SIZE
  Make MAC address length requirement explicit
  Add hwaddr length field to interface config
  Add hwaddr length field to interface
  Set hwaddr_len field when hwaddr is set
  New function to compare hardware addresses
  Use hwaddr_len over sizeof hwaddr
  Use helper when comparing hardware addresses
  Rename HWADDR_SIZE for clarity

 discover/ipmi.c               |  3 +-
 discover/network.c            | 55 +++++++++++++++++++----------------
 discover/platform-powerpc.c   | 12 +++++---
 discover/sysinfo.c            | 11 ++-----
 discover/udev.c               |  6 ++--
 lib/pb-config/pb-config.c     |  1 +
 lib/pb-protocol/pb-protocol.c | 24 +++++++++------
 lib/types/types.h             |  7 +++--
 lib/util/util.c               | 13 +++++++++
 lib/util/util.h               |  3 ++
 test/parser/network.c         |  4 +--
 ui/ncurses/nc-config.c        |  6 ++--
 ui/ncurses/nc-sysinfo.c       |  2 +-
 13 files changed, 89 insertions(+), 58 deletions(-)