diff mbox series

[2/2] docs: Mention Postgres for Docker development install

Message ID 20190501062718.17548-2-ruscur@russell.cc
State Accepted
Headers show
Series [1/2] docker: Use Ubuntu ports repositories on non-x86 architectures | expand

Commit Message

Russell Currey May 1, 2019, 6:27 a.m. UTC
Might as well since it's there, and it gives some clue to anyone trying
to use Docker on non-x86.  I figured it was best to leave this out of
the README since it's incredibly niche.

Signed-off-by: Russell Currey <ruscur@russell.cc>
---
 docs/development/installation.rst | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Andrew Donnellan May 1, 2019, 7:36 a.m. UTC | #1
On 1/5/19 4:27 pm, Russell Currey wrote:
> Might as well since it's there, and it gives some clue to anyone trying
> to use Docker on non-x86.  I figured it was best to leave this out of
> the README since it's incredibly niche.
> 
> Signed-off-by: Russell Currey <ruscur@russell.cc>

Postgres is also what's used in production on ozlabs.org, idk about 
other instances, so we should definitely mention this actively.

Reviewed-by: Andrew Donnellan <andrew.donnellan@au1.ibm.com>

> ---
>   docs/development/installation.rst | 4 ++++
>   1 file changed, 4 insertions(+)
> 
> diff --git a/docs/development/installation.rst b/docs/development/installation.rst
> index 52dc2c3..0ab755f 100644
> --- a/docs/development/installation.rst
> +++ b/docs/development/installation.rst
> @@ -37,6 +37,10 @@ configure Patchwork using Docker:
>   
>         $ docker-compose build
>   
> +   To use Postgres instead of MySQL, give the ``-f docker-compose-pg.yml``
> +   argument to ``docker-compose``.  This is required on non-x86 architectures
> +   as the MySQL Docker images do not have multiarch support.
> +
>   #. Run ``docker-compose up``:
>   
>      .. code-block:: shell
>
diff mbox series

Patch

diff --git a/docs/development/installation.rst b/docs/development/installation.rst
index 52dc2c3..0ab755f 100644
--- a/docs/development/installation.rst
+++ b/docs/development/installation.rst
@@ -37,6 +37,10 @@  configure Patchwork using Docker:
 
       $ docker-compose build
 
+   To use Postgres instead of MySQL, give the ``-f docker-compose-pg.yml``
+   argument to ``docker-compose``.  This is required on non-x86 architectures
+   as the MySQL Docker images do not have multiarch support.
+
 #. Run ``docker-compose up``:
 
    .. code-block:: shell