diff mbox series

[3/3] ccache: Add 030-make-documentation-optional.patch

Message ID mailman.4491.1621033995.1230.openwrt-devel@lists.openwrt.org
State Deferred
Delegated to: Petr Štetiar
Headers show
Series ccache: Disable Documentation build ( fix 21.02 build failure ) | expand

Commit Message

David Adair May 14, 2021, 11:12 p.m. UTC
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
Added patch 030-make-documentation-optional.patch to include upstream
commit: b96ca763c453a602 which allows us to avoid the build failures
due to non-ascii characters in the documentation.  Since we don't need
docs anyway it is easier to just build with -D ENABLE_DOCUMENTATION=OFF
rather than attempt to fix the docs which break from time to time.

This patch is only required for the 21.02 branch since other branches
do not have the non-ascii character build failures at this time.  By the
time they *did* have a problem they would also include this change.

Note: patch itself is not my work it is:
Signed-off-by: Petr Štetiar <ynezz@true.cz>

Signed-off-by: David Adair <djabhead@aol.com>
---
 .../030-make-documentation-optional.patch     | 37 +++++++++++++++++++
 1 file changed, 37 insertions(+)
 create mode 100644 tools/ccache/patches/030-make-documentation-optional.patch

+
diff mbox series

Patch

diff --git a/tools/ccache/patches/030-make-documentation-optional.patch
b/tools/ccache/patches/030-make-documentation-optional.patch
new file mode 100644
index 0000000000..ccd25067cb
--- /dev/null
+++ b/tools/ccache/patches/030-make-documentation-optional.patch
@@ -0,0 +1,37 @@ 
+From b96ca763c453a602b5516b4b9ca5e2829528e318 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
+Date: Mon, 3 May 2021 18:44:53 +0200
+Subject: [PATCH] CMake: make build of documentation optional (#842)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+So we don't need to support corner cases as for example one fixed in
+commit f6202db308e3 ("doc/MANUAL.adoc: Don't use non-ASCII quotes
+(#761)") when the documentation is actually not needed at all as ccache
+is used as a build tool only.
+
+Signed-off-by: Petr Štetiar <ynezz@true.cz>
+---
+ CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0825f2af..e186e812 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -133,7 +133,10 @@ target_link_libraries(ccache PRIVATE standard_settings
standard_warnings ccache_
+ #
+ # Documentation
+ #
+-add_subdirectory(doc)
++option(ENABLE_DOCUMENTATION "Enable documentation" ON)
++if(ENABLE_DOCUMENTATION)
++  add_subdirectory(doc)
++endif()
+ 
+ #
+ # Installation
+-- 
+2.27.0