diff mbox series

ramips: fix build error on Airlink AR670W

Message ID TYAP286MB03154BC901D87800024AD1D4BC7C9@TYAP286MB0315.JPNP286.PROD.OUTLOOK.COM
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series ramips: fix build error on Airlink AR670W | expand

Commit Message

Shiji Yang May 19, 2023, 6:05 a.m. UTC
From: Shiji Yang <yangshiji66@qq.com>

The 'KERNEL' is not referenced by other objects, so double '$$' will
cause shell unable to parse the variable 'BLOCKSIZE':
  dd ... bs=$(BLOCKSIZE) conv=sync
  bash: line 1: BLOCKSIZE: command not found

fixes: 09a0efbe83(ramips: set default BLOCKSIZE to 64k for nor flash devices)

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
---
 target/linux/ramips/image/rt288x.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index 3d2d0c7ae0..c93d7d78e5 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -15,7 +15,7 @@  define Device/airlink101_ar670w
   DEVICE_VENDOR := Airlink
   DEVICE_MODEL := AR670W
   IMAGE_SIZE := 3840k
-  KERNEL := $(KERNEL_DTB) | pad-to $$$$(BLOCKSIZE)
+  KERNEL := $(KERNEL_DTB) | pad-to $$(BLOCKSIZE)
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
 	wrg-header wrgn16a_airlink_ar670w