diff mbox

[OpenWrt-Devel] zd1201: add missing dependency

Message ID 5520EFCC.5090700@web.de
State Rejected
Headers show

Commit Message

Dirk Neukirchen April 5, 2015, 8:18 a.m. UTC
this module gets only (?) build on omap because of config symbol differences it seems

fixes buildbot error:
http://buildbot.openwrt.org:8010/builders/omap/builds/337/steps/compile_5/logs/stdio

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
---
 package/kernel/linux/modules/wireless.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Hauke Mehrtens April 5, 2015, 5:56 p.m. UTC | #1
On 04/05/2015 10:18 AM, Dirk Neukirchen wrote:
> this module gets only (?) build on omap because of config symbol differences it seems
> 
> fixes buildbot error:
> http://buildbot.openwrt.org:8010/builders/omap/builds/337/steps/compile_5/logs/stdio
> 
> Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
> ---
>  package/kernel/linux/modules/wireless.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/kernel/linux/modules/wireless.mk b/package/kernel/linux/modules/wireless.mk
> index 30ba0a8..8989d79 100644
> --- a/package/kernel/linux/modules/wireless.mk
> +++ b/package/kernel/linux/modules/wireless.mk
> @@ -26,7 +26,7 @@ $(eval $(call KernelPackage,net-airo))
>  define KernelPackage/net-zd1201
>    SUBMENU:=$(WIRELESS_MENU)
>    TITLE:=Zydas ZD1201 support
> -  DEPENDS:=@USB_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-usb-core
> +  DEPENDS:=@USB_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-usb-core +kmod-cfg80211
>    KCONFIG:=CONFIG_USB_ZD1201
>    FILES:=$(LINUX_DIR)/drivers/net/wireless/zd1201.ko
>    AUTOLOAD:=$(call AutoProbe,zd1201)
> 
This driver should be build from backports/compat-wireless. OpenWrt
ships the cfg80211 module from backports and every driver depending on
it should be build against its header files. This driver currently build
against the cfg80211 header files shipped in the kernel and at runtime
it will be run with cfg80211 from backports, which will cause problems.

I just saw  zd1201 is currently not shipped by backports, I will change
that.

Hauke
Dirk Neukirchen April 6, 2015, 9:30 a.m. UTC | #2
On 05.04.2015 19:56, Hauke Mehrtens wrote:
> On 04/05/2015 10:18 AM, Dirk Neukirchen wrote:
>> this module gets only (?) build on omap because of config symbol differences it seems
>>
>> fixes buildbot error:
>> http://buildbot.openwrt.org:8010/builders/omap/builds/337/steps/compile_5/logs/stdio
>>
>> Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
>> ---
>>  package/kernel/linux/modules/wireless.mk | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/package/kernel/linux/modules/wireless.mk b/package/kernel/linux/modules/wireless.mk
>> index 30ba0a8..8989d79 100644
>> --- a/package/kernel/linux/modules/wireless.mk
>> +++ b/package/kernel/linux/modules/wireless.mk
>> @@ -26,7 +26,7 @@ $(eval $(call KernelPackage,net-airo))
>>  define KernelPackage/net-zd1201
>>    SUBMENU:=$(WIRELESS_MENU)
>>    TITLE:=Zydas ZD1201 support
>> -  DEPENDS:=@USB_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-usb-core
>> +  DEPENDS:=@USB_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-usb-core +kmod-cfg80211
>>    KCONFIG:=CONFIG_USB_ZD1201
>>    FILES:=$(LINUX_DIR)/drivers/net/wireless/zd1201.ko
>>    AUTOLOAD:=$(call AutoProbe,zd1201)
>>
> This driver should be build from backports/compat-wireless. OpenWrt
> ships the cfg80211 module from backports and every driver depending on
> it should be build against its header files. This driver currently build
> against the cfg80211 header files shipped in the kernel and at runtime
> it will be run with cfg80211 from backports, which will cause problems.
> 
> I just saw  zd1201 is currently not shipped by backports, I will change
> that.
> 
> Hauke
> 

At least one other driver is affected by this too kmod-net-airo.
seems like all drivers in /drivers/net/wireless that are not in a subdirectory are missing ?
(checking build_dir/target-<arch>/linux-<arch>/compat-wireless-.../drivers/net/wireless )

What about the staging wireless drivers: 
- Should they be included in backports too ?
- Should all wireless.mk drivers be moved to backports ?
diff mbox

Patch

diff --git a/package/kernel/linux/modules/wireless.mk b/package/kernel/linux/modules/wireless.mk
index 30ba0a8..8989d79 100644
--- a/package/kernel/linux/modules/wireless.mk
+++ b/package/kernel/linux/modules/wireless.mk
@@ -26,7 +26,7 @@  $(eval $(call KernelPackage,net-airo))
 define KernelPackage/net-zd1201
   SUBMENU:=$(WIRELESS_MENU)
   TITLE:=Zydas ZD1201 support
-  DEPENDS:=@USB_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-usb-core
+  DEPENDS:=@USB_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-usb-core +kmod-cfg80211
   KCONFIG:=CONFIG_USB_ZD1201
   FILES:=$(LINUX_DIR)/drivers/net/wireless/zd1201.ko
   AUTOLOAD:=$(call AutoProbe,zd1201)