diff mbox

[OpenWrt-Devel] Install .pc files of Python

Message ID 54AF0477.1020304@pfeifferszilard.hu
State Deferred
Headers show

Commit Message

Szilárd Pfeiffer Jan. 8, 2015, 10:28 p.m. UTC
Hi,

.pc files are not copied to the install directory, so python (as a
library) cannot be checked from configure.ac by PKG_CHECK_MODULES. It
caused problem during the port of Zorp GPL to OpenWrt. Possible solution
is attached.

Best regards,
Szilárd Pfeiffer

Comments

Felix Fietkau Jan. 9, 2015, 10:25 a.m. UTC | #1
On 2015-01-08 23:28, Szilárd Pfeiffer wrote:
> Hi,
> 
> .pc files are not copied to the install directory, so python (as a
> library) cannot be checked from configure.ac by PKG_CHECK_MODULES. It
> caused problem during the port of Zorp GPL to OpenWrt. Possible solution
> is attached.
> 
> Best regards,
> Szilárd Pfeiffer
Python is maintained on the packages GitHub repository:
https://github.com/openwrt/packages
You should submit an issue or pull request there.

- Felix
Alexandru Ardelean Jan. 9, 2015, 10:30 a.m. UTC | #2
I've already picked up the patch and looking into.
Was going to come back with an answer, but I have some other stuff to look
into.

@Szilárd: if you want, you can also do a PR on Github. If not, then I'll
apply your patch. Looks good to me.

On Fri, Jan 9, 2015 at 12:25 PM, Felix Fietkau <nbd@openwrt.org> wrote:

> On 2015-01-08 23:28, Szilárd Pfeiffer wrote:
> > Hi,
> >
> > .pc files are not copied to the install directory, so python (as a
> > library) cannot be checked from configure.ac by PKG_CHECK_MODULES. It
> > caused problem during the port of Zorp GPL to OpenWrt. Possible solution
> > is attached.
> >
> > Best regards,
> > Szilárd Pfeiffer
> Python is maintained on the packages GitHub repository:
> https://github.com/openwrt/packages
> You should submit an issue or pull request there.
>
> - Felix
>
diff mbox

Patch

From b7a1ac80ec6536b165e2f1db61d4bac9a086c4bf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Szil=C3=A1rd=20Pfeiffer?= <coroner@pfeifferszilard.hu>
Date: Thu, 27 Nov 2014 23:19:40 +0100
Subject: [PATCH] Install .pc files from Python package.

---
 lang/python/Makefile | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/lang/python/Makefile b/lang/python/Makefile
index 954612f..6039b2e 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -104,7 +104,7 @@  endef
 
 define Build/InstallDev
 	$(INSTALL_DIR) $(STAGING_DIR)/mk/
-	$(INSTALL_DIR) $(1)/usr/include/ $(1)/usr/lib/
+	$(INSTALL_DIR) $(1)/usr/include/ $(1)/usr/lib/ $(1)/usr/lib/pkgconfig
 	$(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON_VERSION)/
 	$(INSTALL_DATA) ./files/python-package.mk $(STAGING_DIR)/mk/
 	$(CP) \
@@ -115,6 +115,11 @@  define Build/InstallDev
 		$(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* \
 		$(1)/usr/lib/
 	$(CP) \
+		$(STAGING_DIR_HOST)/lib/pkgconfig/python.pc \
+		$(STAGING_DIR_HOST)/lib/pkgconfig/python2.pc \
+		$(STAGING_DIR_HOST)/lib/pkgconfig/python-$(PYTHON_VERSION).pc \
+		$(1)/usr/lib/pkgconfig
+	$(CP) \
 		$(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/config \
 		$(1)/usr/lib/python$(PYTHON_VERSION)/
 endef
-- 
1.9.1