diff mbox series

[OpenWrt-Devel] bcm63xx: Livebox1: reenable the image generation

Message ID 3676440.c42S0g3a1G@tool
State Rejected
Headers show
Series [OpenWrt-Devel] bcm63xx: Livebox1: reenable the image generation | expand

Commit Message

Daniel González Cabanelas May 17, 2020, 4:51 p.m. UTC
This old BCM6348 device still runs quite fine with OpenWrt snapshots when
the board is modded with 64MB of RAM.

Reenable the image generation and advertise the mod in the image filename

Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
---
 target/linux/bcm63xx/image/bcm63xx.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Adrian Schmutzler May 17, 2020, 5 p.m. UTC | #1
Hi,

> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org]
> On Behalf Of Daniel González Cabanelas
> Sent: Sonntag, 17. Mai 2020 18:52
> To: openwrt-devel@lists.openwrt.org
> Cc: noltari@gmail.com
> Subject: [OpenWrt-Devel] [PATCH] bcm63xx: Livebox1: reenable the image
> generation
> 
> This old BCM6348 device still runs quite fine with OpenWrt snapshots when
> the board is modded with 64MB of RAM.
> 
> Reenable the image generation and advertise the mod in the image filename

OpenWrt does not officially support modded devices. If you require something like that, just build the appropriate image yourself.

Despite that, I don't think the way you modify the image name would fit the naming logic on that target very well.

I will mark this patch as Rejected. Sorry.

Best

Adrian

> 
> Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
> ---
>  target/linux/bcm63xx/image/bcm63xx.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/target/linux/bcm63xx/image/bcm63xx.mk
> b/target/linux/bcm63xx/image/bcm63xx.mk
> index d5601e2c3c..1e5b0b9776 100644
> --- a/target/linux/bcm63xx/image/bcm63xx.mk
> +++ b/target/linux/bcm63xx/image/bcm63xx.mk
> @@ -759,7 +759,7 @@ define Device/inventel_livebox-1
>    DEVICE_MODEL := Livebox 1
>    SOC := bcm6348
>    DEVICE_PACKAGES := $(B43_PACKAGES) $(USB1_PACKAGES)
> -  DEFAULT := n
> +  IMAGE_NAME = $$(IMAGE_PREFIX)-64RAM_mod-$$(1).$$(2)
>  endef
>  TARGET_DEVICES += inventel_livebox-1
> 
> --
> 2.26.2
> 
> 
> 
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Daniel González Cabanelas May 17, 2020, 5:56 p.m. UTC | #2
Hi Adrian,

El dom., 17 may. 2020 a las 19:00, <mail@adrianschmutzler.de> escribió:
>
> Hi,
>
> > -----Original Message-----
> > From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org]
> > On Behalf Of Daniel González Cabanelas
> > Sent: Sonntag, 17. Mai 2020 18:52
> > To: openwrt-devel@lists.openwrt.org
> > Cc: noltari@gmail.com
> > Subject: [OpenWrt-Devel] [PATCH] bcm63xx: Livebox1: reenable the image
> > generation
> >
> > This old BCM6348 device still runs quite fine with OpenWrt snapshots when
> > the board is modded with 64MB of RAM.
> >
> > Reenable the image generation and advertise the mod in the image filename
>
> OpenWrt does not officially support modded devices. If you require something like that, just build the appropriate image yourself.

I was't aware of that rule. I thought this project was engaged with
the spirit of hacking (software or hardware). Furthermore, one of
features which leaded Openwrt success was the hardware modding.
Without hardware modding a lot of devices couldn't be supported. This
fact has no discussion for me.

Appart from that, this is the only one device in the bcm63xx target
with Redboot support. Without the image generation it will be
difficult to test otherwise. Therefore the support should be also
dropped for this kernel subtarget if no one cares about testing the
snapshot images appart from me. This is a bit sad, but would make more
sense.

Of course I can build my own images. But I don't make tests or fix
issues on this device only for myself but also for others. So, with no
image generation I will probably stop testing snapshots on this
device. As a result of this, I won't either detect and fix other
issues on this target as I made in the past.

> Despite that, I don't think the way you modify the image name would fit the naming logic on that target very well.

Not sure about what's wrong with this naming logic. I made it the most
concise and less disruptive I could.

Regards.

Daniel.

>
> I will mark this patch as Rejected. Sorry.
>
> Best
>
> Adrian
>
> >
> > Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
> > ---
> >  target/linux/bcm63xx/image/bcm63xx.mk | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/target/linux/bcm63xx/image/bcm63xx.mk
> > b/target/linux/bcm63xx/image/bcm63xx.mk
> > index d5601e2c3c..1e5b0b9776 100644
> > --- a/target/linux/bcm63xx/image/bcm63xx.mk
> > +++ b/target/linux/bcm63xx/image/bcm63xx.mk
> > @@ -759,7 +759,7 @@ define Device/inventel_livebox-1
> >    DEVICE_MODEL := Livebox 1
> >    SOC := bcm6348
> >    DEVICE_PACKAGES := $(B43_PACKAGES) $(USB1_PACKAGES)
> > -  DEFAULT := n
> > +  IMAGE_NAME = $$(IMAGE_PREFIX)-64RAM_mod-$$(1).$$(2)
> >  endef
> >  TARGET_DEVICES += inventel_livebox-1
> >
> > --
> > 2.26.2
> >
> >
> >
> >
> >
> > _______________________________________________
> > openwrt-devel mailing list
> > openwrt-devel@lists.openwrt.org
> > https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Adrian Schmutzler May 17, 2020, 6:21 p.m. UTC | #3
Hi Daniel,

> -----Original Message-----
> From: Daniel González Cabanelas [mailto:dgcbueu@gmail.com]
> Sent: Sonntag, 17. Mai 2020 19:57
> To: mail@adrianschmutzler.de
> Cc: openwrt-devel@lists.openwrt.org; Álvaro Fernández Rojas
> <noltari@gmail.com>
> Subject: Re: [OpenWrt-Devel] [PATCH] bcm63xx: Livebox1: reenable the
> image generation
> 
> Hi Adrian,
> 
> El dom., 17 may. 2020 a las 19:00, <mail@adrianschmutzler.de> escribió:
> >
> > Hi,
> >
> > > -----Original Message-----
> > > From: openwrt-devel [mailto:openwrt-devel-
> bounces@lists.openwrt.org]
> > > On Behalf Of Daniel González Cabanelas
> > > Sent: Sonntag, 17. Mai 2020 18:52
> > > To: openwrt-devel@lists.openwrt.org
> > > Cc: noltari@gmail.com
> > > Subject: [OpenWrt-Devel] [PATCH] bcm63xx: Livebox1: reenable the
> > > image generation
> > >
> > > This old BCM6348 device still runs quite fine with OpenWrt snapshots
> > > when the board is modded with 64MB of RAM.
> > >
> > > Reenable the image generation and advertise the mod in the image
> > > filename
> >
> > OpenWrt does not officially support modded devices. If you require
> something like that, just build the appropriate image yourself.
> 
> I was't aware of that rule. I thought this project was engaged with the spirit
> of hacking (software or hardware). Furthermore, one of features which
> leaded Openwrt success was the hardware modding.
> Without hardware modding a lot of devices couldn't be supported. This fact
> has no discussion for me.

There are so many devices out there that we typically receive more requests for devices to add than we can process.

Despite, for a device sold officially you regularly can assume that the hardware in it is defined and stays the same, at least within a revision.
If we started to accept modified devices, we would
- get a multiple of devices to review and maintain
- completely loose our ability to name devices properly, as there are no defined names (would be easy for flash/RAM, but what about other mods)
- could never be sure that we properly supported a specific device, as we'd never really know what some modder out there really did

So, it doesn't make much sense to officially support and add a modded device as explicitly supported device in OpenWrt.

However, OpenWrt of course is still perfectly suitable for supporting these devices. You just have to build it yourself.

> 
> Appart from that, this is the only one device in the bcm63xx target with
> Redboot support. Without the image generation it will be difficult to test
> otherwise. Therefore the support should be also dropped for this kernel
> subtarget if no one cares about testing the snapshot images appart from me.
> This is a bit sad, but would make more sense.
> 
> Of course I can build my own images. But I don't make tests or fix issues on
> this device only for myself but also for others. So, with no image generation I
> will probably stop testing snapshots on this device. As a result of this, I won't
> either detect and fix other issues on this target as I made in the past.

If you really rely on someone to build the images, than this might be the case, although it's a pity.

> 
> > Despite that, I don't think the way you modify the image name would fit
> the naming logic on that target very well.
> 
> Not sure about what's wrong with this naming logic. I made it the most
> concise and less disruptive I could.

IMO the proper way would be to rename the device, not having the image name deviate from the device name.

If it was an official device, one would e.g. use
Device/inventel_livebox-1-64m
and adjust compatible etc. appropriately.

Best

Adrian

> 
> Regards.
> 
> Daniel.
> 
> >
> > I will mark this patch as Rejected. Sorry.
> >
> > Best
> >
> > Adrian
> >
> > >
> > > Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
> > > ---
> > >  target/linux/bcm63xx/image/bcm63xx.mk | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/target/linux/bcm63xx/image/bcm63xx.mk
> > > b/target/linux/bcm63xx/image/bcm63xx.mk
> > > index d5601e2c3c..1e5b0b9776 100644
> > > --- a/target/linux/bcm63xx/image/bcm63xx.mk
> > > +++ b/target/linux/bcm63xx/image/bcm63xx.mk
> > > @@ -759,7 +759,7 @@ define Device/inventel_livebox-1
> > >    DEVICE_MODEL := Livebox 1
> > >    SOC := bcm6348
> > >    DEVICE_PACKAGES := $(B43_PACKAGES) $(USB1_PACKAGES)
> > > -  DEFAULT := n
> > > +  IMAGE_NAME = $$(IMAGE_PREFIX)-64RAM_mod-$$(1).$$(2)
> > >  endef
> > >  TARGET_DEVICES += inventel_livebox-1
> > >
> > > --
> > > 2.26.2
> > >
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > openwrt-devel mailing list
> > > openwrt-devel@lists.openwrt.org
> > > https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/bcm63xx/image/bcm63xx.mk b/target/linux/bcm63xx/image/bcm63xx.mk
index d5601e2c3c..1e5b0b9776 100644
--- a/target/linux/bcm63xx/image/bcm63xx.mk
+++ b/target/linux/bcm63xx/image/bcm63xx.mk
@@ -759,7 +759,7 @@  define Device/inventel_livebox-1
   DEVICE_MODEL := Livebox 1
   SOC := bcm6348
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB1_PACKAGES)
-  DEFAULT := n
+  IMAGE_NAME = $$(IMAGE_PREFIX)-64RAM_mod-$$(1).$$(2)
 endef
 TARGET_DEVICES += inventel_livebox-1