diff mbox series

[OpenWrt-Devel,2/4] bcm63xx: image: don't add the CFE to the sercomm factory

Message ID 3608830.1HcjCr2GE9@tool
State Superseded, archived
Headers show
Series [OpenWrt-Devel,1/4] bcm63xx: kernel: add BCM63167 cpuid variant | expand

Commit Message

Daniel González Cabanelas June 3, 2020, 10:48 p.m. UTC
There is no need to include the CFE bootloader in the Sercomm factory
images.

There might be a case when this could be useful:
  - We are running the stock firmware on the first Sercomm image
  - The second partition storing the botloader was erased (unlikely)
Even in this case flashing an image without a bootlader is harmless.

Don't include the bootloader in the factory image creation and rid of the
risk of flashing factory images with an untested bootloader partition.

Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
---
 target/linux/bcm63xx/image/Makefile | 12 ------------
 1 file changed, 12 deletions(-)

Comments

Álvaro Fernández Rojas June 4, 2020, 7:04 a.m. UTC | #1
Ok, I assume it’s safe to drop this, since the bootloader is on a separate partition and all Sercomm devices seem to have both bootloaders available from factory.

> El 4 jun 2020, a las 0:48, Daniel González Cabanelas <dgcbueu@gmail.com> escribió:
> 
> There is no need to include the CFE bootloader in the Sercomm factory
> images.
> 
> There might be a case when this could be useful:
>  - We are running the stock firmware on the first Sercomm image
>  - The second partition storing the botloader was erased (unlikely)
> Even in this case flashing an image without a bootlader is harmless.
> 
> Don't include the bootloader in the factory image creation and rid of the
> risk of flashing factory images with an untested bootloader partition.
> 
> Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
> ---
> target/linux/bcm63xx/image/Makefile | 12 ------------
> 1 file changed, 12 deletions(-)
> 
> diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
> index eb4b78b06a..e57b99391f 100644
> --- a/target/linux/bcm63xx/image/Makefile
> +++ b/target/linux/bcm63xx/image/Makefile
> @@ -242,20 +242,8 @@ define Build/cfe-sercomm-part
> 		--part-name rootfs_lib \
> 		--part-version $(SERCOMM_VERSION)
> 
> -	rm -rf $@-bootloader
> -	mkdir -p $@-bootloader
> -	cp $(KDIR)/bcm63xx-cfe/$(CFE_RAM_FILE) $@-bootloader/$(CFE_RAM_JFFS2_NAME)
> -	$(call Build/cfe-jffs2,$@-bootloader)
> -	$(call Build/pad-to,$(BLOCKSIZE))
> -	$(TOPDIR)/scripts/sercomm-partition-tag.py \
> -		--input-file $@ \
> -		--output-file $@.bootloader \
> -		--part-name bootloader \
> -		--part-version $(SERCOMM_VERSION)
> -
> 	mv $@.kernel_rootfs $@
> 	dd if=$@.rootfs_lib >> $@
> -	dd if=$@.bootloader >> $@
> endef
> 
> define Build/cfe-sercomm-load
> -- 
> 2.27.0
> 
> 
> 
>
diff mbox series

Patch

diff --git a/target/linux/bcm63xx/image/Makefile b/target/linux/bcm63xx/image/Makefile
index eb4b78b06a..e57b99391f 100644
--- a/target/linux/bcm63xx/image/Makefile
+++ b/target/linux/bcm63xx/image/Makefile
@@ -242,20 +242,8 @@  define Build/cfe-sercomm-part
 		--part-name rootfs_lib \
 		--part-version $(SERCOMM_VERSION)
 
-	rm -rf $@-bootloader
-	mkdir -p $@-bootloader
-	cp $(KDIR)/bcm63xx-cfe/$(CFE_RAM_FILE) $@-bootloader/$(CFE_RAM_JFFS2_NAME)
-	$(call Build/cfe-jffs2,$@-bootloader)
-	$(call Build/pad-to,$(BLOCKSIZE))
-	$(TOPDIR)/scripts/sercomm-partition-tag.py \
-		--input-file $@ \
-		--output-file $@.bootloader \
-		--part-name bootloader \
-		--part-version $(SERCOMM_VERSION)
-
 	mv $@.kernel_rootfs $@
 	dd if=$@.rootfs_lib >> $@
-	dd if=$@.bootloader >> $@
 endef
 
 define Build/cfe-sercomm-load