diff mbox series

valgrind: fix config missing in menuconfig.

Message ID 20231107020006.2923792-1-quic_shoudil@quicinc.com
State Rejected, archived
Delegated to: Chuanhong Guo
Headers show
Series valgrind: fix config missing in menuconfig. | expand

Commit Message

Shoudi Li (Stephen) Nov. 7, 2023, 2 a.m. UTC
From: shoudil <quic_shoudil@quicinc.com>

Enable valgrind related configs in menuconfig to support compile on
32bit arm targets.

Signed-off-by: shoudil <quic_shoudil@quicinc.com>
---
 package/devel/valgrind/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Chuanhong Guo Jan. 6, 2024, 2:41 a.m. UTC | #1
Hi!

On Tue, Nov 7, 2023 at 10:04 AM <quic_shoudil@quicinc.com> wrote:
>
> From: shoudil <quic_shoudil@quicinc.com>
>
> Enable valgrind related configs in menuconfig to support compile on
> 32bit arm targets.

Valgrind only runs on ARMv7 and newer targets, so it's only built on
arm_v7 and aarch64.
Are you using an ARMv8 core in aarch32 mode? If that's the case
you should make CONFIG_CPU_V7 available in your kernel config.
Shoudi Li (Stephen) Jan. 6, 2024, 10:51 a.m. UTC | #2
On 2024/1/6 10:41, Chuanhong Guo wrote:
> Hi!
> 
> On Tue, Nov 7, 2023 at 10:04 AM <quic_shoudil@quicinc.com> wrote:
>>
>> From: shoudil <quic_shoudil@quicinc.com>
>>
>> Enable valgrind related configs in menuconfig to support compile on
>> 32bit arm targets.
> 
> Valgrind only runs on ARMv7 and newer targets, so it's only built on
> arm_v7 and aarch64.
> Are you using an ARMv8 core in aarch32 mode? If that's the case
> you should make CONFIG_CPU_V7 available in your kernel config.
> 

We are using cortex-a7 core (ARMv7 32bit),thanks for the suggestion, we 
will add CONFIG_CPU_V7 kernel config to have a check.

Shoudil
diff mbox series

Patch

diff --git a/package/devel/valgrind/Makefile b/package/devel/valgrind/Makefile
index f696b28c3c..694d63983c 100644
--- a/package/devel/valgrind/Makefile
+++ b/package/devel/valgrind/Makefile
@@ -33,7 +33,7 @@  include $(INCLUDE_DIR)/kernel.mk
 define Package/valgrind
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:=@mips||mipsel||mips64||mips64el||i386||x86_64||powerpc||arm_v7||aarch64 +libpthread +librt
+  DEPENDS:=@mips||mipsel||mips64||mips64el||i386||x86_64||powerpc||arm||arm_v7||aarch64 +libpthread +librt
   TITLE:=debugging and profiling tools for Linux
   URL:=http://www.valgrind.org
 endef