diff mbox series

[v3,03/10] kernel: Add kmod-rtc-x1205

Message ID 20231012-ixp4xx-v3-3-e09c74712c0b@linaro.org
State Accepted
Headers show
Series Resurrect OpenWrt IXP4xx support | expand

Commit Message

Linus Walleij Oct. 12, 2023, 8:42 a.m. UTC
To support the IXP42x platforms we need a kernel module
for the X1205 RTC so we can load it as an optional module.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
ChangeLog v1->v3:
- Use autoprobe, exclude from preinit.
---
 package/kernel/linux/modules/other.mk | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

Robert Marko Oct. 12, 2023, 9:26 a.m. UTC | #1
On Thu, 12 Oct 2023 at 10:43, Linus Walleij <linus.walleij@linaro.org> wrote:
>
> To support the IXP42x platforms we need a kernel module
> for the X1205 RTC so we can load it as an optional module.
>
> Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
> ---
> ChangeLog v1->v3:
> - Use autoprobe, exclude from preinit.

LGTM,
Reviewed-by: Robert Marko <robimarko@gmail.com>

> ---
>  package/kernel/linux/modules/other.mk | 16 ++++++++++++++++
>  1 file changed, 16 insertions(+)
>
> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
> index ac26c2a15037..2cd01d84d516 100644
> --- a/package/kernel/linux/modules/other.mk
> +++ b/package/kernel/linux/modules/other.mk
> @@ -780,6 +780,22 @@ endef
>
>  $(eval $(call KernelPackage,rtc-s35390a))
>
> +define KernelPackage/rtc-x1205
> +  SUBMENU:=$(OTHER_MENU)
> +  TITLE:=Xicor Intersil X1205
> +  DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
> +  DEPENDS:=+kmod-i2c-core
> +  KCONFIG:=CONFIG_RTC_DRV_X1205 \
> +       CONFIG_RTC_CLASS=y
> +  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-x1205.ko
> +  AUTOLOAD:=$(call AutoProbe,rtc-x1205)
> +endef
> +
> +define KernelPackage/rtc-x1205/description
> + Kernel module for Xicor Intersil X1205 I2C RTC chip
> +endef
> +
> +$(eval $(call KernelPackage,rtc-x1205))
>
>  define KernelPackage/mtdtests
>    SUBMENU:=$(OTHER_MENU)
>
> --
> 2.34.1
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index ac26c2a15037..2cd01d84d516 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -780,6 +780,22 @@  endef
 
 $(eval $(call KernelPackage,rtc-s35390a))
 
+define KernelPackage/rtc-x1205
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Xicor Intersil X1205
+  DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+  DEPENDS:=+kmod-i2c-core
+  KCONFIG:=CONFIG_RTC_DRV_X1205 \
+	CONFIG_RTC_CLASS=y
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-x1205.ko
+  AUTOLOAD:=$(call AutoProbe,rtc-x1205)
+endef
+
+define KernelPackage/rtc-x1205/description
+ Kernel module for Xicor Intersil X1205 I2C RTC chip
+endef
+
+$(eval $(call KernelPackage,rtc-x1205))
 
 define KernelPackage/mtdtests
   SUBMENU:=$(OTHER_MENU)