diff mbox series

[PATCH-22.03,1/3] octeontx: add default packages for on-board devices

Message ID 20230223232847.1871098-1-tharvey@gateworks.com
State Accepted
Headers show
Series [PATCH-22.03,1/3] octeontx: add default packages for on-board devices | expand

Commit Message

Tim Harvey Feb. 23, 2023, 11:28 p.m. UTC
The Gateworks Newport boards supported by the octeontx target have
the following on-board devices:
 - Gateworks System Controller
 - GPIO buttons
 - GPIO leds
 - GPS PPS
 - Accelerometer
 - MCP251X CAN controller

Add kernel drivers for these devices in DEFAULT_PACKAGES

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
---
 target/linux/octeontx/Makefile | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/target/linux/octeontx/Makefile b/target/linux/octeontx/Makefile
index 03ab287bd53a..83fcb4aca0b5 100644
--- a/target/linux/octeontx/Makefile
+++ b/target/linux/octeontx/Makefile
@@ -19,4 +19,8 @@  include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=Image
 
+DEFAULT_PACKAGES += kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
+		    kmod-gpio-button-hotplug kmod-input-evdev kmod-rtc-ds1672 \
+		    kmod-can kmod-can-mcp251x
+
 $(eval $(call BuildTarget))