diff mbox series

[6/8] kernel: Add kmod-sound-soc-ipq8064-storm

Message ID 20230102232534.592501-6-computersforpeace@gmail.com
State Superseded
Delegated to: Petr Štetiar
Headers show
Series [1/8] base-files: Remove nand.sh dependency from emmc upgrade | expand

Commit Message

Brian Norris Jan. 2, 2023, 11:25 p.m. UTC
For IPQ8064 systems based off the "Google Storm" reference platform,
such as the TP-Link OnHub.

Signed-off-by: Brian Norris <computersforpeace@gmail.com>
---

 package/kernel/linux/modules/sound.mk | 24 ++++++++++++++++++++++++
 target/linux/generic/config-5.10      |  3 +++
 target/linux/generic/config-5.15      |  3 +++
 3 files changed, 30 insertions(+)

Comments

Christian Marangi Jan. 4, 2023, 12:55 p.m. UTC | #1
On Mon, Jan 02, 2023 at 03:25:32PM -0800, Brian Norris wrote:
> For IPQ8064 systems based off the "Google Storm" reference platform,
> such as the TP-Link OnHub.

As this is really ipq806x specific, instead of bloating the kernel/linux
mk a better approach is to create some .mk specific for the target... We
should have some example with other target with mvebu I think.

With this approach we should be able to also add the LPASS module in
this target specific mk

> 
> Signed-off-by: Brian Norris <computersforpeace@gmail.com>
> ---
> 
>  package/kernel/linux/modules/sound.mk | 24 ++++++++++++++++++++++++
>  target/linux/generic/config-5.10      |  3 +++
>  target/linux/generic/config-5.15      |  3 +++
>  3 files changed, 30 insertions(+)
> 
> diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
> index 2bfa146207aa..92ad8bceed9b 100644
> --- a/package/kernel/linux/modules/sound.mk
> +++ b/package/kernel/linux/modules/sound.mk
> @@ -254,6 +254,30 @@ endef
>  $(eval $(call KernelPackage,sound-soc-imx-sgtl5000))
>  
>  
> +define KernelPackage/sound-soc-ipq8064-storm
> +  TITLE:=Qualcomm IPQ8064 SoC support for Google Storm
> +  KCONFIG:=\
> +	CONFIG_SND_SOC_QCOM \
> +	CONFIG_SND_SOC_STORM
> +  FILES:=\
> +	$(LINUX_DIR)/sound/soc/codecs/snd-soc-max98357a.ko \
> +	$(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-cpu.ko \
> +	$(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-ipq806x.ko \
> +	$(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-platform.ko \
> +	$(LINUX_DIR)/sound/soc/qcom/snd-soc-storm.ko
> +  AUTOLOAD:=$(call AutoLoad,57,snd-soc-max98357a snd-soc-lpass-cpu \
> +	snd-soc-lpass-ipq806x snd-soc-lpass-platform snd-soc-storm)
> +  DEPENDS:=@TARGET_ipq806x +kmod-sound-soc-core
> +  $(call AddDepends/sound)
> +endef
> +
> +define KernelPackage/sound-soc-ipq8064-storm/description
> + Support for Qualcomm IPQ8064 / Google Storm Platform sound
> +endef
> +
> +$(eval $(call KernelPackage,sound-soc-ipq8064-storm))
> +
> +
>  define KernelPackage/sound-soc-spdif
>    TITLE:=SoC S/PDIF codec support
>    KCONFIG:=CONFIG_SND_SOC_SPDIF
> diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
> index a2dc9b90b1fc..324401244155 100644
> --- a/target/linux/generic/config-5.10
> +++ b/target/linux/generic/config-5.10
> @@ -5649,6 +5649,7 @@ CONFIG_SND_PROC_FS=y
>  # CONFIG_SND_SOC_AMD_ACP is not set
>  # CONFIG_SND_SOC_AMD_ACP3x is not set
>  # CONFIG_SND_SOC_AMD_RENOIR is not set
> +# CONFIG_SND_SOC_APQ8016_SBC is not set
>  # CONFIG_SND_SOC_AU1XAUDIO is not set
>  # CONFIG_SND_SOC_AU1XPSC is not set
>  # CONFIG_SND_SOC_BD28623 is not set
> @@ -5786,6 +5787,7 @@ CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
>  # CONFIG_SND_SOC_RT5616 is not set
>  # CONFIG_SND_SOC_RT5631 is not set
>  # CONFIG_SND_SOC_RT5677_SPI is not set
> +# CONFIG_SND_SOC_SC7180 is not set
>  # CONFIG_SND_SOC_SGTL5000 is not set
>  # CONFIG_SND_SOC_SIMPLE_AMPLIFIER is not set
>  # CONFIG_SND_SOC_SIRF_AUDIO_CODEC is not set
> @@ -5795,6 +5797,7 @@ CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
>  # CONFIG_SND_SOC_SSM2602_I2C is not set
>  # CONFIG_SND_SOC_SSM2602_SPI is not set
>  # CONFIG_SND_SOC_SSM4567 is not set
> +# CONFIG_SND_SOC_STORM is not set
>  # CONFIG_SND_SOC_STA32X is not set
>  # CONFIG_SND_SOC_STA350 is not set
>  # CONFIG_SND_SOC_STI_SAS is not set
> diff --git a/target/linux/generic/config-5.15 b/target/linux/generic/config-5.15
> index df9755b19e68..5ccc1dc41594 100644
> --- a/target/linux/generic/config-5.15
> +++ b/target/linux/generic/config-5.15
> @@ -5940,6 +5940,7 @@ CONFIG_SND_PROC_FS=y
>  # CONFIG_SND_SOC_AMD_ACP3x is not set
>  # CONFIG_SND_SOC_AMD_ACP5x is not set
>  # CONFIG_SND_SOC_AMD_RENOIR is not set
> +# CONFIG_SND_SOC_APQ8016_SBC is not set
>  # CONFIG_SND_SOC_AU1XAUDIO is not set
>  # CONFIG_SND_SOC_AU1XPSC is not set
>  # CONFIG_SND_SOC_BD28623 is not set
> @@ -6097,6 +6098,7 @@ CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
>  # CONFIG_SND_SOC_RT5640 is not set
>  # CONFIG_SND_SOC_RT5659 is not set
>  # CONFIG_SND_SOC_RT5677_SPI is not set
> +# CONFIG_SND_SOC_SC7180 is not set
>  # CONFIG_SND_SOC_SGTL5000 is not set
>  # CONFIG_SND_SOC_SIMPLE_AMPLIFIER is not set
>  # CONFIG_SND_SOC_SIMPLE_MUX is not set
> @@ -6111,6 +6113,7 @@ CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
>  # CONFIG_SND_SOC_STA32X is not set
>  # CONFIG_SND_SOC_STA350 is not set
>  # CONFIG_SND_SOC_STI_SAS is not set
> +# CONFIG_SND_SOC_STORM is not set
>  # CONFIG_SND_SOC_TAS2552 is not set
>  # CONFIG_SND_SOC_TAS2562 is not set
>  # CONFIG_SND_SOC_TAS2764 is not set
> -- 
> 2.39.0
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Robert Marko Jan. 4, 2023, 1:34 p.m. UTC | #2
On Wed, 4 Jan 2023 at 14:24, Christian Marangi <ansuelsmth@gmail.com> wrote:
>
> On Mon, Jan 02, 2023 at 03:25:32PM -0800, Brian Norris wrote:
> > For IPQ8064 systems based off the "Google Storm" reference platform,
> > such as the TP-Link OnHub.
>
> As this is really ipq806x specific, instead of bloating the kernel/linux
> mk a better approach is to create some .mk specific for the target... We
> should have some example with other target with mvebu I think.
>
> With this approach we should be able to also add the LPASS module in
> this target specific mk

bcm27xx uses in-target module definitions extensively.
It makes sense to package the LCC clock and this inside of the target
itself as its
not reusable for other targets.

Regards,
Robert
>
> >
> > Signed-off-by: Brian Norris <computersforpeace@gmail.com>
> > ---
> >
> >  package/kernel/linux/modules/sound.mk | 24 ++++++++++++++++++++++++
> >  target/linux/generic/config-5.10      |  3 +++
> >  target/linux/generic/config-5.15      |  3 +++
> >  3 files changed, 30 insertions(+)
> >
> > diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
> > index 2bfa146207aa..92ad8bceed9b 100644
> > --- a/package/kernel/linux/modules/sound.mk
> > +++ b/package/kernel/linux/modules/sound.mk
> > @@ -254,6 +254,30 @@ endef
> >  $(eval $(call KernelPackage,sound-soc-imx-sgtl5000))
> >
> >
> > +define KernelPackage/sound-soc-ipq8064-storm
> > +  TITLE:=Qualcomm IPQ8064 SoC support for Google Storm
> > +  KCONFIG:=\
> > +     CONFIG_SND_SOC_QCOM \
> > +     CONFIG_SND_SOC_STORM
> > +  FILES:=\
> > +     $(LINUX_DIR)/sound/soc/codecs/snd-soc-max98357a.ko \
> > +     $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-cpu.ko \
> > +     $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-ipq806x.ko \
> > +     $(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-platform.ko \
> > +     $(LINUX_DIR)/sound/soc/qcom/snd-soc-storm.ko
> > +  AUTOLOAD:=$(call AutoLoad,57,snd-soc-max98357a snd-soc-lpass-cpu \
> > +     snd-soc-lpass-ipq806x snd-soc-lpass-platform snd-soc-storm)
> > +  DEPENDS:=@TARGET_ipq806x +kmod-sound-soc-core
> > +  $(call AddDepends/sound)
> > +endef
> > +
> > +define KernelPackage/sound-soc-ipq8064-storm/description
> > + Support for Qualcomm IPQ8064 / Google Storm Platform sound
> > +endef
> > +
> > +$(eval $(call KernelPackage,sound-soc-ipq8064-storm))
> > +
> > +
> >  define KernelPackage/sound-soc-spdif
> >    TITLE:=SoC S/PDIF codec support
> >    KCONFIG:=CONFIG_SND_SOC_SPDIF
> > diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
> > index a2dc9b90b1fc..324401244155 100644
> > --- a/target/linux/generic/config-5.10
> > +++ b/target/linux/generic/config-5.10
> > @@ -5649,6 +5649,7 @@ CONFIG_SND_PROC_FS=y
> >  # CONFIG_SND_SOC_AMD_ACP is not set
> >  # CONFIG_SND_SOC_AMD_ACP3x is not set
> >  # CONFIG_SND_SOC_AMD_RENOIR is not set
> > +# CONFIG_SND_SOC_APQ8016_SBC is not set
> >  # CONFIG_SND_SOC_AU1XAUDIO is not set
> >  # CONFIG_SND_SOC_AU1XPSC is not set
> >  # CONFIG_SND_SOC_BD28623 is not set
> > @@ -5786,6 +5787,7 @@ CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
> >  # CONFIG_SND_SOC_RT5616 is not set
> >  # CONFIG_SND_SOC_RT5631 is not set
> >  # CONFIG_SND_SOC_RT5677_SPI is not set
> > +# CONFIG_SND_SOC_SC7180 is not set
> >  # CONFIG_SND_SOC_SGTL5000 is not set
> >  # CONFIG_SND_SOC_SIMPLE_AMPLIFIER is not set
> >  # CONFIG_SND_SOC_SIRF_AUDIO_CODEC is not set
> > @@ -5795,6 +5797,7 @@ CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
> >  # CONFIG_SND_SOC_SSM2602_I2C is not set
> >  # CONFIG_SND_SOC_SSM2602_SPI is not set
> >  # CONFIG_SND_SOC_SSM4567 is not set
> > +# CONFIG_SND_SOC_STORM is not set
> >  # CONFIG_SND_SOC_STA32X is not set
> >  # CONFIG_SND_SOC_STA350 is not set
> >  # CONFIG_SND_SOC_STI_SAS is not set
> > diff --git a/target/linux/generic/config-5.15 b/target/linux/generic/config-5.15
> > index df9755b19e68..5ccc1dc41594 100644
> > --- a/target/linux/generic/config-5.15
> > +++ b/target/linux/generic/config-5.15
> > @@ -5940,6 +5940,7 @@ CONFIG_SND_PROC_FS=y
> >  # CONFIG_SND_SOC_AMD_ACP3x is not set
> >  # CONFIG_SND_SOC_AMD_ACP5x is not set
> >  # CONFIG_SND_SOC_AMD_RENOIR is not set
> > +# CONFIG_SND_SOC_APQ8016_SBC is not set
> >  # CONFIG_SND_SOC_AU1XAUDIO is not set
> >  # CONFIG_SND_SOC_AU1XPSC is not set
> >  # CONFIG_SND_SOC_BD28623 is not set
> > @@ -6097,6 +6098,7 @@ CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
> >  # CONFIG_SND_SOC_RT5640 is not set
> >  # CONFIG_SND_SOC_RT5659 is not set
> >  # CONFIG_SND_SOC_RT5677_SPI is not set
> > +# CONFIG_SND_SOC_SC7180 is not set
> >  # CONFIG_SND_SOC_SGTL5000 is not set
> >  # CONFIG_SND_SOC_SIMPLE_AMPLIFIER is not set
> >  # CONFIG_SND_SOC_SIMPLE_MUX is not set
> > @@ -6111,6 +6113,7 @@ CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
> >  # CONFIG_SND_SOC_STA32X is not set
> >  # CONFIG_SND_SOC_STA350 is not set
> >  # CONFIG_SND_SOC_STI_SAS is not set
> > +# CONFIG_SND_SOC_STORM is not set
> >  # CONFIG_SND_SOC_TAS2552 is not set
> >  # CONFIG_SND_SOC_TAS2562 is not set
> >  # CONFIG_SND_SOC_TAS2764 is not set
> > --
> > 2.39.0
> >
> >
> > _______________________________________________
> > openwrt-devel mailing list
> > openwrt-devel@lists.openwrt.org
> > https://lists.openwrt.org/mailman/listinfo/openwrt-devel
>
> --
>         Ansuel
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 2bfa146207aa..92ad8bceed9b 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -254,6 +254,30 @@  endef
 $(eval $(call KernelPackage,sound-soc-imx-sgtl5000))
 
 
+define KernelPackage/sound-soc-ipq8064-storm
+  TITLE:=Qualcomm IPQ8064 SoC support for Google Storm
+  KCONFIG:=\
+	CONFIG_SND_SOC_QCOM \
+	CONFIG_SND_SOC_STORM
+  FILES:=\
+	$(LINUX_DIR)/sound/soc/codecs/snd-soc-max98357a.ko \
+	$(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-cpu.ko \
+	$(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-ipq806x.ko \
+	$(LINUX_DIR)/sound/soc/qcom/snd-soc-lpass-platform.ko \
+	$(LINUX_DIR)/sound/soc/qcom/snd-soc-storm.ko
+  AUTOLOAD:=$(call AutoLoad,57,snd-soc-max98357a snd-soc-lpass-cpu \
+	snd-soc-lpass-ipq806x snd-soc-lpass-platform snd-soc-storm)
+  DEPENDS:=@TARGET_ipq806x +kmod-sound-soc-core
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-ipq8064-storm/description
+ Support for Qualcomm IPQ8064 / Google Storm Platform sound
+endef
+
+$(eval $(call KernelPackage,sound-soc-ipq8064-storm))
+
+
 define KernelPackage/sound-soc-spdif
   TITLE:=SoC S/PDIF codec support
   KCONFIG:=CONFIG_SND_SOC_SPDIF
diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
index a2dc9b90b1fc..324401244155 100644
--- a/target/linux/generic/config-5.10
+++ b/target/linux/generic/config-5.10
@@ -5649,6 +5649,7 @@  CONFIG_SND_PROC_FS=y
 # CONFIG_SND_SOC_AMD_ACP is not set
 # CONFIG_SND_SOC_AMD_ACP3x is not set
 # CONFIG_SND_SOC_AMD_RENOIR is not set
+# CONFIG_SND_SOC_APQ8016_SBC is not set
 # CONFIG_SND_SOC_AU1XAUDIO is not set
 # CONFIG_SND_SOC_AU1XPSC is not set
 # CONFIG_SND_SOC_BD28623 is not set
@@ -5786,6 +5787,7 @@  CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
 # CONFIG_SND_SOC_RT5616 is not set
 # CONFIG_SND_SOC_RT5631 is not set
 # CONFIG_SND_SOC_RT5677_SPI is not set
+# CONFIG_SND_SOC_SC7180 is not set
 # CONFIG_SND_SOC_SGTL5000 is not set
 # CONFIG_SND_SOC_SIMPLE_AMPLIFIER is not set
 # CONFIG_SND_SOC_SIRF_AUDIO_CODEC is not set
@@ -5795,6 +5797,7 @@  CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
 # CONFIG_SND_SOC_SSM2602_I2C is not set
 # CONFIG_SND_SOC_SSM2602_SPI is not set
 # CONFIG_SND_SOC_SSM4567 is not set
+# CONFIG_SND_SOC_STORM is not set
 # CONFIG_SND_SOC_STA32X is not set
 # CONFIG_SND_SOC_STA350 is not set
 # CONFIG_SND_SOC_STI_SAS is not set
diff --git a/target/linux/generic/config-5.15 b/target/linux/generic/config-5.15
index df9755b19e68..5ccc1dc41594 100644
--- a/target/linux/generic/config-5.15
+++ b/target/linux/generic/config-5.15
@@ -5940,6 +5940,7 @@  CONFIG_SND_PROC_FS=y
 # CONFIG_SND_SOC_AMD_ACP3x is not set
 # CONFIG_SND_SOC_AMD_ACP5x is not set
 # CONFIG_SND_SOC_AMD_RENOIR is not set
+# CONFIG_SND_SOC_APQ8016_SBC is not set
 # CONFIG_SND_SOC_AU1XAUDIO is not set
 # CONFIG_SND_SOC_AU1XPSC is not set
 # CONFIG_SND_SOC_BD28623 is not set
@@ -6097,6 +6098,7 @@  CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
 # CONFIG_SND_SOC_RT5640 is not set
 # CONFIG_SND_SOC_RT5659 is not set
 # CONFIG_SND_SOC_RT5677_SPI is not set
+# CONFIG_SND_SOC_SC7180 is not set
 # CONFIG_SND_SOC_SGTL5000 is not set
 # CONFIG_SND_SOC_SIMPLE_AMPLIFIER is not set
 # CONFIG_SND_SOC_SIMPLE_MUX is not set
@@ -6111,6 +6113,7 @@  CONFIG_SND_SOC_INTEL_SST_TOPLEVEL=y
 # CONFIG_SND_SOC_STA32X is not set
 # CONFIG_SND_SOC_STA350 is not set
 # CONFIG_SND_SOC_STI_SAS is not set
+# CONFIG_SND_SOC_STORM is not set
 # CONFIG_SND_SOC_TAS2552 is not set
 # CONFIG_SND_SOC_TAS2562 is not set
 # CONFIG_SND_SOC_TAS2764 is not set