diff mbox series

ipq40xx: cut ath10k board file for mikrotik subtarget

Message ID 20220520221321.1806503-1-git@johnthomson.fastmail.com.au
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series ipq40xx: cut ath10k board file for mikrotik subtarget | expand

Commit Message

John Thomson May 20, 2022, 10:13 p.m. UTC
Avoid shipping ath10k board file in Mikrotik initram images

Most will only ever need to use these initram images once—to initially
load OpenWrt, but fix these images for more consistent Wi-Fi performance
between the initram and installed squashfs images.

OpenWrt BUILDBOT config ignores -cut packages in the initram images build.
This results in BUILDBOT initram images including the linux-firmware
qca4019 board-2.bin, and (initram image booted) Mikrotik devices loading
a generic BDF, rather than the intended BDF data loaded
from NOR as an api 1 board_file.

buildbot snapshot booted as initram image:
cat /etc/openwrt_version
r19679-810eac8c7f
dmesg | grep ath10k | grep -E board\|BDF
[    9.794556] ath10k_ahb a000000.wifi: Loading BDF type 0
[    9.807192] ath10k_ahb a000000.wifi: board_file api 2 bmi_id 0:16
crc32 11892f9b
[   12.457105] ath10k_ahb a800000.wifi: Loading BDF type 0
[   12.464945] ath10k_ahb a800000.wifi: board_file api 2 bmi_id 0:17
crc32 11892f9b

CC: Robert Marko <robimarko@gmail.com>
Fixes: 5eee67a72fed ("ipq40xx: mikrotik: dont include ath10k-board-qca4019 by default")

Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
---
 target/linux/ipq40xx/Makefile           | 2 +-
 target/linux/ipq40xx/chromium/target.mk | 1 +
 target/linux/ipq40xx/generic/target.mk  | 1 +
 target/linux/ipq40xx/mikrotik/target.mk | 1 -
 4 files changed, 3 insertions(+), 2 deletions(-)

Comments

Robert Marko May 27, 2022, 8:50 a.m. UTC | #1
On Sat, 21 May 2022 at 00:13, John Thomson
<git@johnthomson.fastmail.com.au> wrote:
>
> Avoid shipping ath10k board file in Mikrotik initram images
>
> Most will only ever need to use these initram images once—to initially
> load OpenWrt, but fix these images for more consistent Wi-Fi performance
> between the initram and installed squashfs images.
>
> OpenWrt BUILDBOT config ignores -cut packages in the initram images build.
> This results in BUILDBOT initram images including the linux-firmware
> qca4019 board-2.bin, and (initram image booted) Mikrotik devices loading
> a generic BDF, rather than the intended BDF data loaded
> from NOR as an api 1 board_file.
>
> buildbot snapshot booted as initram image:
> cat /etc/openwrt_version
> r19679-810eac8c7f
> dmesg | grep ath10k | grep -E board\|BDF
> [    9.794556] ath10k_ahb a000000.wifi: Loading BDF type 0
> [    9.807192] ath10k_ahb a000000.wifi: board_file api 2 bmi_id 0:16
> crc32 11892f9b
> [   12.457105] ath10k_ahb a800000.wifi: Loading BDF type 0
> [   12.464945] ath10k_ahb a800000.wifi: board_file api 2 bmi_id 0:17
> crc32 11892f9b
>
> CC: Robert Marko <robimarko@gmail.com>
> Fixes: 5eee67a72fed ("ipq40xx: mikrotik: dont include ath10k-board-qca4019 by default")
>
> Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>

LGTM, so:
Reviewed-by: Robert Marko <robimarko@gmail.com>

Regards,
Robert
> ---
>  target/linux/ipq40xx/Makefile           | 2 +-
>  target/linux/ipq40xx/chromium/target.mk | 1 +
>  target/linux/ipq40xx/generic/target.mk  | 1 +
>  target/linux/ipq40xx/mikrotik/target.mk | 1 -
>  4 files changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/target/linux/ipq40xx/Makefile b/target/linux/ipq40xx/Makefile
> index 7df920e2d8..19b63cdd65 100644
> --- a/target/linux/ipq40xx/Makefile
> +++ b/target/linux/ipq40xx/Makefile
> @@ -19,6 +19,6 @@ DEFAULT_PACKAGES += \
>         kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
>         kmod-ath10k-ct wpad-basic-wolfssl \
>         kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct \
> -       ath10k-board-qca4019 uboot-envtools
> +       uboot-envtools
>
>  $(eval $(call BuildTarget))
> diff --git a/target/linux/ipq40xx/chromium/target.mk b/target/linux/ipq40xx/chromium/target.mk
> index 3983a9281a..98bd37ed71 100644
> --- a/target/linux/ipq40xx/chromium/target.mk
> +++ b/target/linux/ipq40xx/chromium/target.mk
> @@ -1,2 +1,3 @@
>  BOARDNAME:=Google Chromium
>  FEATURES += emmc boot-part rootfs-part
> +DEFAULT_PACKAGES += ath10k-board-qca4019
> diff --git a/target/linux/ipq40xx/generic/target.mk b/target/linux/ipq40xx/generic/target.mk
> index e158b1c98b..90c1b762af 100644
> --- a/target/linux/ipq40xx/generic/target.mk
> +++ b/target/linux/ipq40xx/generic/target.mk
> @@ -1,2 +1,3 @@
>  BOARDNAME:=Generic
>  FEATURES+=emmc
> +DEFAULT_PACKAGES += ath10k-board-qca4019
> diff --git a/target/linux/ipq40xx/mikrotik/target.mk b/target/linux/ipq40xx/mikrotik/target.mk
> index 8b17c61585..4530a90985 100644
> --- a/target/linux/ipq40xx/mikrotik/target.mk
> +++ b/target/linux/ipq40xx/mikrotik/target.mk
> @@ -2,4 +2,3 @@ BOARDNAME:=MikroTik
>  FEATURES += minor
>  KERNEL_IMAGES:=vmlinux
>  IMAGES_DIR:=compressed
> -DEFAULT_PACKAGES += -ath10k-board-qca4019
> --
> 2.36.1
>
diff mbox series

Patch

diff --git a/target/linux/ipq40xx/Makefile b/target/linux/ipq40xx/Makefile
index 7df920e2d8..19b63cdd65 100644
--- a/target/linux/ipq40xx/Makefile
+++ b/target/linux/ipq40xx/Makefile
@@ -19,6 +19,6 @@  DEFAULT_PACKAGES += \
 	kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
 	kmod-ath10k-ct wpad-basic-wolfssl \
 	kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct \
-	ath10k-board-qca4019 uboot-envtools
+	uboot-envtools
 
 $(eval $(call BuildTarget))
diff --git a/target/linux/ipq40xx/chromium/target.mk b/target/linux/ipq40xx/chromium/target.mk
index 3983a9281a..98bd37ed71 100644
--- a/target/linux/ipq40xx/chromium/target.mk
+++ b/target/linux/ipq40xx/chromium/target.mk
@@ -1,2 +1,3 @@ 
 BOARDNAME:=Google Chromium
 FEATURES += emmc boot-part rootfs-part
+DEFAULT_PACKAGES += ath10k-board-qca4019
diff --git a/target/linux/ipq40xx/generic/target.mk b/target/linux/ipq40xx/generic/target.mk
index e158b1c98b..90c1b762af 100644
--- a/target/linux/ipq40xx/generic/target.mk
+++ b/target/linux/ipq40xx/generic/target.mk
@@ -1,2 +1,3 @@ 
 BOARDNAME:=Generic
 FEATURES+=emmc
+DEFAULT_PACKAGES += ath10k-board-qca4019
diff --git a/target/linux/ipq40xx/mikrotik/target.mk b/target/linux/ipq40xx/mikrotik/target.mk
index 8b17c61585..4530a90985 100644
--- a/target/linux/ipq40xx/mikrotik/target.mk
+++ b/target/linux/ipq40xx/mikrotik/target.mk
@@ -2,4 +2,3 @@  BOARDNAME:=MikroTik
 FEATURES += minor
 KERNEL_IMAGES:=vmlinux
 IMAGES_DIR:=compressed
-DEFAULT_PACKAGES += -ath10k-board-qca4019