diff mbox series

[v2,3/3] realtek: Fix tc default package

Message ID 20220325133845.639556-4-hauke@hauke-m.de
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series realtek: Fix default package selection | expand

Commit Message

Hauke Mehrtens March 25, 2022, 1:38 p.m. UTC
The tc package does not exits any more, it was split into tc-tiny,
tc-full and tc-bpf. Include tc-bpf by default into realtek images.

This increases the compressed image size by about 232KBytes.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

Use tc-bpf instead of tc-tiny. We already have libbpf and libelf in for ip-full.

 target/linux/realtek/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Paul Spooren March 25, 2022, 4:35 p.m. UTC | #1
Looks good to me. I’m just wondering if LuCI will pull in dnsmasq et al again for release builds.

> On 25. Mar 2022, at 13:42, Hauke Mehrtens <hauke@hauke-m.de> wrote:
> 
> The tc package does not exits any more, it was split into tc-tiny,
> tc-full and tc-bpf. Include tc-bpf by default into realtek images.
> 
> This increases the compressed image size by about 232KBytes.
> 
> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
> ---
> 
> Use tc-bpf instead of tc-tiny. We already have libbpf and libelf in for ip-full.
> 
> target/linux/realtek/Makefile | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/target/linux/realtek/Makefile b/target/linux/realtek/Makefile
> index 8bed3d8a7232..037ba7ac7db8 100644
> --- a/target/linux/realtek/Makefile
> +++ b/target/linux/realtek/Makefile
> @@ -19,6 +19,6 @@ include $(INCLUDE_DIR)/target.mk
> 
> DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
>    firewall4 nftables kmod-nft-offload odhcp6c \
> -    ip-full ip-bridge tc
> +    ip-full ip-bridge tc-bpf
> 
> $(eval $(call BuildTarget))
> -- 
> 2.30.2
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Hauke Mehrtens March 29, 2022, 11:45 a.m. UTC | #2
On 3/25/22 17:35, Paul Spooren wrote:
> Looks good to me. I’m just wondering if LuCI will pull in dnsmasq et al again for release builds.
> 

Stijn tested this on top of OpenWrt 22.03 branch successfully. He also 
activated LuCI and dnsmasq was not pulled in.

Hauke
Paul Spooren March 29, 2022, 1:05 p.m. UTC | #3
> On 29. Mar 2022, at 12:45, Hauke Mehrtens <hauke@hauke-m.de> wrote:
> 
> On 3/25/22 17:35, Paul Spooren wrote:
>> Looks good to me. I’m just wondering if LuCI will pull in dnsmasq et al again for release builds.
> 
> Stijn tested this on top of OpenWrt 22.03 branch successfully. He also activated LuCI and dnsmasq was not pulled in.

Great, please proceed then!

> 
> Hauke
diff mbox series

Patch

diff --git a/target/linux/realtek/Makefile b/target/linux/realtek/Makefile
index 8bed3d8a7232..037ba7ac7db8 100644
--- a/target/linux/realtek/Makefile
+++ b/target/linux/realtek/Makefile
@@ -19,6 +19,6 @@  include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
 	firewall4 nftables kmod-nft-offload odhcp6c \
-	ip-full ip-bridge tc
+	ip-full ip-bridge tc-bpf
 
 $(eval $(call BuildTarget))