diff mbox series

octeon: Switch to kernel 5.10 and mark source only

Message ID 20220204000701.966792-1-hauke@hauke-m.de
State Rejected
Delegated to: Hauke Mehrtens
Headers show
Series octeon: Switch to kernel 5.10 and mark source only | expand

Commit Message

Hauke Mehrtens Feb. 4, 2022, 12:07 a.m. UTC
Stijn Tintel reported a memory leak in octeon with kernel 5.10. With
kernel 5.4 it worked fine. The memory leak was seen with IPsec tunnels,
VRRP IPs, conntrack syncing, full IPv6 BGP feed, etc.
See details here: https://github.com/openwrt/openwrt/pull/4610

Move this target to kernel 5.10 anyway, but mark it as source only so
the binaries will not be included in the next release. If someone fixes
the memory leak please remove the source only tag again so we can create
binary images again.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
 target/linux/octeon/Makefile | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Comments

Rui Salvaterra Feb. 4, 2022, 9:04 a.m. UTC | #1
Hi, Hauke,

On Fri, 4 Feb 2022 at 00:10, Hauke Mehrtens <hauke@hauke-m.de> wrote:
>
> Stijn Tintel reported a memory leak in octeon with kernel 5.10. With
> kernel 5.4 it worked fine. The memory leak was seen with IPsec tunnels,
> VRRP IPs, conntrack syncing, full IPv6 BGP feed, etc.
> See details here: https://github.com/openwrt/openwrt/pull/4610
>
> Move this target to kernel 5.10 anyway, but mark it as source only so
> the binaries will not be included in the next release. If someone fixes
> the memory leak please remove the source only tag again so we can create
> binary images again.
>
> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
> ---
>  target/linux/octeon/Makefile | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
> index 3a6bce0e9fe8..62be0df01457 100644
> --- a/target/linux/octeon/Makefile
> +++ b/target/linux/octeon/Makefile
> @@ -7,11 +7,10 @@ include $(TOPDIR)/rules.mk
>  ARCH:=mips64
>  BOARD:=octeon
>  BOARDNAME:=Cavium Networks Octeon
> -FEATURES:=squashfs ramdisk pci usb
> +FEATURES:=squashfs ramdisk pci usb source-only
>  CPU_TYPE:=octeonplus
>
> -KERNEL_PATCHVER:=5.4
> -KERNEL_TESTING_PATCHVER:=5.10
> +KERNEL_PATCHVER:=5.10
>
>  define Target/Description
>         Build firmware images for Cavium Networks Octeon-based boards.
> --
> 2.30.2

I think Stijn was actually able to pinpoint and revert the offending
commit, so this might be a bit hasty, hopefully. :) But let's wait for
his definitive answer.

Cheers,
Rui
diff mbox series

Patch

diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
index 3a6bce0e9fe8..62be0df01457 100644
--- a/target/linux/octeon/Makefile
+++ b/target/linux/octeon/Makefile
@@ -7,11 +7,10 @@  include $(TOPDIR)/rules.mk
 ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs ramdisk pci usb
+FEATURES:=squashfs ramdisk pci usb source-only
 CPU_TYPE:=octeonplus
 
-KERNEL_PATCHVER:=5.4
-KERNEL_TESTING_PATCHVER:=5.10
+KERNEL_PATCHVER:=5.10
 
 define Target/Description
 	Build firmware images for Cavium Networks Octeon-based boards.