diff mbox series

x86: geode: add kmod-crypto-ebc needed for hw acceleration

Message ID 20220121171229.4033-1-fercerpav@gmail.com
State Accepted
Delegated to: Petr Štetiar
Headers show
Series x86: geode: add kmod-crypto-ebc needed for hw acceleration | expand

Commit Message

Paul Fertser Jan. 21, 2022, 5:12 p.m. UTC
Module kmod-crypto-hw-geode provides accelerated cbc(aes) and ecb(aes)
but the software implementation is also needed when AES key size isn't
128 so that the operation can fall back. Add the kmod so that it would
all work as expected out of the box.

Tested-by: timur_davletshin
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
---
 target/linux/x86/image/geode.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/x86/image/geode.mk b/target/linux/x86/image/geode.mk
index 6cea887926db..ce5e93a2c5bc 100644
--- a/target/linux/x86/image/geode.mk
+++ b/target/linux/x86/image/geode.mk
@@ -1,7 +1,8 @@ 
 define Device/generic
   DEVICE_VENDOR := Generic
   DEVICE_MODEL := x86/Geode
-  DEVICE_PACKAGES += kmod-crypto-cbc kmod-crypto-hw-geode kmod-ledtrig-gpio
+  DEVICE_PACKAGES += kmod-crypto-cbc kmod-crypto-ebc kmod-crypto-hw-geode \
+	kmod-ledtrig-gpio
   GRUB2_VARIANT := legacy
 endef
 TARGET_DEVICES += generic