diff mbox series

[3/5] bcm43436-firmware: new package

Message ID 20211120034152.2612831-4-stijn@linux-ipv6.be
State Rejected, archived
Delegated to: Stijn Tintel
Headers show
Series add support for Raspberry Pi Zero 2 | expand

Commit Message

Stijn Tintel Nov. 20, 2021, 3:41 a.m. UTC
This package contains the firmware for the Wi-Fi chip used in the
Raspberry Pi Zero 2. This firmware is not available in
linux-firmware.git, nor in the latest Cypress Linux Wi-Fi archive.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
---
 package/firmware/bcm43436-firmware/Makefile | 36 +++++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 package/firmware/bcm43436-firmware/Makefile
diff mbox series

Patch

diff --git a/package/firmware/bcm43436-firmware/Makefile b/package/firmware/bcm43436-firmware/Makefile
new file mode 100644
index 0000000000..4fec44bf15
--- /dev/null
+++ b/package/firmware/bcm43436-firmware/Makefile
@@ -0,0 +1,36 @@ 
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bcm43436-firmware
+PKG_SOURCE_DATE:=2021-11-02
+PKG_SOURCE_VERSION:=54ffdd6e2ea6055d46656b78e148fe7def3ec9d8
+PKG_MIRROR_HASH:=
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/RPi-Distro/firmware-nonfree.git
+
+PKG_FLAGS:=nonshared
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bcm43436-firmware
+  TITLE:=BCM43436 firmware
+  SECTION:=firmware
+  CATEGORY:=Firmware
+  DEPENDS:=@TARGET_bcm27xx
+  URL:=https://github.com/RPi-Distro/firmware-nonfree
+  PROVIDES:=brcmfmac-firmware-43436-sdio
+endef
+
+define Build/Compile
+	true
+endef
+
+define Package/bcm43436-firmware/install
+	$(INSTALL_DIR) $(1)/lib/firmware/brcm
+	$(INSTALL_DATA) \
+		$(PKG_BUILD_DIR)/brcm/brcmfmac43436* \
+		$(1)/lib/firmware/brcm
+endef
+
+$(eval $(call BuildPackage,bcm43436-firmware))