diff mbox series

vti: squash vtiv4 and vtiv6 packages into vti

Message ID 20211027135425.15421-1-fe@dev.tdt.de
State Accepted
Delegated to: Hans Dedecker
Headers show
Series vti: squash vtiv4 and vtiv6 packages into vti | expand

Commit Message

Florian Eckert Oct. 27, 2021, 1:54 p.m. UTC
This change adds the same package behaviour as gre package.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
---
 package/network/config/vti/Makefile | 43 +++++------------------------
 1 file changed, 7 insertions(+), 36 deletions(-)
diff mbox series

Patch

diff --git a/package/network/config/vti/Makefile b/package/network/config/vti/Makefile
index 292ab111e5..548b8f951f 100644
--- a/package/network/config/vti/Makefile
+++ b/package/network/config/vti/Makefile
@@ -8,47 +8,28 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vti
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vti/Default
-  SECTION:=net
-  CATEGORY:=Network
-  MAINTAINER:=Andre Valentin <avalentin@marcant.net>
-  PKGARCH:=all
 endef
 
 define Package/vti
-$(call Package/vti/Default)
+  SECTION:=net
+  CATEGORY:=Network
+  MAINTAINER:=Andre Valentin <avalentin@marcant.net>
   TITLE:=Virtual IPsec Tunnel Interface config support
+  DEPENDS:=+kmod-ip-vti +IPV6:kmod-ip6-vti
+  PROVIDES:=vtiv4 vtiv6
+  PKGARCH:=all
 endef
 
 define Package/vti/description
  Virtual IPsec Tunnel Interface config support (IPv4 and IPv6) in /etc/config/network.
 endef
 
-define Package/vtiv4
-$(call Package/vti/Default)
-  TITLE:=Virtual IPsec Tunnel Interface (IPv4) config support
-  DEPENDS:=@(PACKAGE_vti) +kmod-ip-vti
-endef
-
-define Package/vtiv4/description
- Virtual IPsec Tunnel Interface config support (IPv4) in /etc/config/network.
-endef
-
-define Package/vtiv6
-$(call Package/vti/Default)
-  TITLE:=Virtual IPsec Tunnel Interface (IPv6) config support
-  DEPENDS:=@(PACKAGE_vti) @IPV6 +kmod-ip6-vti
-endef
-
-define Package/vtiv6/description
- Virtual IPsec Tunnel Interface config support (IPv6) in /etc/config/network.
-endef
-
 define Build/Compile
 endef
 
@@ -60,14 +41,4 @@  define Package/vti/install
 	$(INSTALL_BIN) ./files/vti.sh $(1)/lib/netifd/proto/vti.sh
 endef
 
-define Package/vtiv4/install
-	:
-endef
-
-define Package/vtiv6/install
-	:
-endef
-
 $(eval $(call BuildPackage,vti))
-$(eval $(call BuildPackage,vtiv4))
-$(eval $(call BuildPackage,vtiv6))