diff mbox series

[v3,3/3] realtek: add PoE budget and rtl83xx-poe package for DGS-1210-10P

Message ID 20210412220130.542146-4-foss@volatilesystems.org
State Not Applicable
Delegated to: Petr Štetiar
Headers show
Series realtek: PoE budgets and rtl83xx-poe package | expand

Commit Message

Stijn Segers April 12, 2021, 10:01 p.m. UTC
The PoE power budget for the DGS-1210-10P is known to be 65W, so set it.
Also add the rtl83xx-poe package to the device profile so we can manage
PoE with OpenWrt just like one would with the vendor firmware.

Signed-off-by: Stijn Segers <foss@volatilesystems.org>
---
 target/linux/realtek/base-files/etc/board.d/02_network | 3 +++
 target/linux/realtek/image/Makefile                    | 2 +-
 2 files changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/realtek/base-files/etc/board.d/02_network b/target/linux/realtek/base-files/etc/board.d/02_network
index b27bed9a63..a65066a522 100644
--- a/target/linux/realtek/base-files/etc/board.d/02_network
+++ b/target/linux/realtek/base-files/etc/board.d/02_network
@@ -48,6 +48,9 @@  done
 [ -n "$label_mac" ] && ucidef_set_label_macaddr $label_mac
 
 case $board in
+d-link,dgs-1210-10p)
+	ucidef_set_poe 65 "$lan_list"
+	;;
 netgear,gs110tpp-v1)
 	ucidef_set_poe 120 "$lan_list"
 	;;
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 4d34aabd5e..da1b5fb2ed 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -56,7 +56,7 @@  endef
 define Device/d-link_dgs-1210-10p
   $(Device/d-link_dgs-1210)
   DEVICE_MODEL := DGS-1210-10P
-  DEVICE_PACKAGES += lua-rs232
+  DEVICE_PACKAGES += rtl83xx-poe
 endef
 TARGET_DEVICES += d-link_dgs-1210-10p