diff mbox series

[2/3] scripts: fix checkpatch.pl for changed license dir

Message ID 20210212125318.2002-2-freifunk@adrianschmutzler.de
State Accepted
Delegated to: Adrian Schmutzler
Headers show
Series [1/3] LICENSES: include all used licenses in LICENSES directory | expand

Commit Message

Adrian Schmutzler Feb. 12, 2021, 12:53 p.m. UTC
From: Paul Spooren <mail@aparcar.org>

As multiple LICENSES are shipped and no longer just LICENSE, modify the
OpenWrt tree detecation in checkpatch.pl.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 scripts/checkpatch.pl | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index 8ffc093548..81b1ffcb56 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -1113,7 +1113,7 @@  sub top_of_openwrt_tree {
 	my ($root) = @_;
 
 	my @tree_check = (
-		"BSDmakefile", "Config.in", "LICENSE", "Makefile", "README.md",
+		"BSDmakefile", "Config.in", "LICENSES", "Makefile", "README.md",
 		"feeds.conf.default", "include", "package", "rules.mk",
 		"scripts", "target", "toolchain", "tools"
 	);