diff mbox series

treewide: unify OpenWrt hosted source URL

Message ID 20210130215459.1458959-1-mail@aparcar.org
State Superseded
Delegated to: Paul Spooren
Headers show
Series treewide: unify OpenWrt hosted source URL | expand

Commit Message

Paul Spooren Jan. 30, 2021, 9:54 p.m. UTC
Multiple sources are hosted on OpenWrts source server only. The source
URLs to point to the server vary based on different epochs in OpenWrts
history. Unify them to use always the new source CDN and HTTPS.

If the CDN fails, sources.o.o is used as a fallback via downloads.pl.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 package/boot/fconfig/Makefile                             | 2 +-
 package/firmware/b43legacy-firmware/Makefile              | 2 +-
 package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile | 2 +-
 package/kernel/broadcom-wl/Makefile                       | 2 +-
 package/kernel/lantiq/ltq-adsl/Makefile                   | 2 +-
 package/kernel/lantiq/ltq-tapi/Makefile                   | 2 +-
 package/kernel/lantiq/ltq-vdsl-mei/Makefile               | 2 +-
 package/kernel/lantiq/ltq-vdsl/Makefile                   | 2 +-
 package/kernel/lantiq/ltq-vmmc/Makefile                   | 2 +-
 package/kernel/mac80211/broadcom.mk                       | 6 +++---
 package/network/config/ltq-adsl-app/Makefile              | 2 +-
 package/network/config/ltq-vdsl-app/Makefile              | 2 +-
 tools/lzma-old/Makefile                                   | 2 +-
 tools/lzma/Makefile                                       | 2 +-
 14 files changed, 16 insertions(+), 16 deletions(-)

Comments

Hannu Nyman Jan. 31, 2021, 8:08 a.m. UTC | #1
Paul Spooren kirjoitti 30.1.2021 klo 23.54:
> Multiple sources are hosted on OpenWrts source server only. The source
> URLs to point to the server vary based on different epochs in OpenWrts
> history. Unify them to use always the new source CDN and HTTPS.
>
> If the CDN fails, sources.o.o is used as a fallback via downloads.pl.
>
> Signed-off-by: Paul Spooren <mail@aparcar.org>
> ---
>   package/boot/fconfig/Makefile                             | 2 +-
>   package/firmware/b43legacy-firmware/Makefile              | 2 +-
>   package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile | 2 +-
>   package/kernel/broadcom-wl/Makefile                       | 2 +-
>   package/kernel/lantiq/ltq-adsl/Makefile                   | 2 +-
>   package/kernel/lantiq/ltq-tapi/Makefile                   | 2 +-
>   package/kernel/lantiq/ltq-vdsl-mei/Makefile               | 2 +-
>   package/kernel/lantiq/ltq-vdsl/Makefile                   | 2 +-
>   package/kernel/lantiq/ltq-vmmc/Makefile                   | 2 +-
>   package/kernel/mac80211/broadcom.mk                       | 6 +++---
>   package/network/config/ltq-adsl-app/Makefile              | 2 +-
>   package/network/config/ltq-vdsl-app/Makefile              | 2 +-
>   tools/lzma-old/Makefile                                   | 2 +-
>   tools/lzma/Makefile                                       | 2 +-
>   14 files changed, 16 insertions(+), 16 deletions(-)
>
> diff --git a/package/boot/fconfig/Makefile b/package/boot/fconfig/Makefile
> index 9b806fe97c..31986e6942 100644
> --- a/package/boot/fconfig/Makefile
> +++ b/package/boot/fconfig/Makefile
> @@ -12,7 +12,7 @@ PKG_VERSION:=20080329
>   PKG_RELEASE:=1
>   
>   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
> -PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
> +PKG_SOURCE_URL:=https://sources.cdn.openwrt.org


Would it make sense to define a similar @OPENWRT alias in scripts/download.pl 
as we have done for SF, APACHE, GITHUB, GNU, SAVANNAH, KERNEL and GNOME ?

https://github.com/openwrt/openwrt/blob/master/scripts/download.pl#L192-L255

Then we could in future change those download locations centrally in 
download.pl, instead of changing it every single Makefile where it is used. 
The Makefiles could just contain PKG_SOURCE_URL:=@OPENWRT

(One afterthought: the pushed contents might actually be empty, as the actual 
download locations are pushed on lines 261-263 to the same trial queue. Not 
quite sure about the pushing order logic, but might work.)
Paul Spooren Jan. 31, 2021, 9:19 a.m. UTC | #2
On Sun, Jan 31, 2021 at 10:08, Hannu Nyman <hannu.nyman@iki.fi> wrote:
> Paul Spooren kirjoitti 30.1.2021 klo 23.54:
>> Multiple sources are hosted on OpenWrts source server only. The 
>> source
>> URLs to point to the server vary based on different epochs in 
>> OpenWrts
>> history. Unify them to use always the new source CDN and HTTPS.
>> 
>> If the CDN fails, sources.o.o is used as a fallback via downloads.pl.
>> 
>> Signed-off-by: Paul Spooren <mail@aparcar.org>
>> ---
>>   package/boot/fconfig/Makefile                             | 2 +-
>>   package/firmware/b43legacy-firmware/Makefile              | 2 +-
>>   package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile | 2 +-
>>   package/kernel/broadcom-wl/Makefile                       | 2 +-
>>   package/kernel/lantiq/ltq-adsl/Makefile                   | 2 +-
>>   package/kernel/lantiq/ltq-tapi/Makefile                   | 2 +-
>>   package/kernel/lantiq/ltq-vdsl-mei/Makefile               | 2 +-
>>   package/kernel/lantiq/ltq-vdsl/Makefile                   | 2 +-
>>   package/kernel/lantiq/ltq-vmmc/Makefile                   | 2 +-
>>   package/kernel/mac80211/broadcom.mk                       | 6 
>> +++---
>>   package/network/config/ltq-adsl-app/Makefile              | 2 +-
>>   package/network/config/ltq-vdsl-app/Makefile              | 2 +-
>>   tools/lzma-old/Makefile                                   | 2 +-
>>   tools/lzma/Makefile                                       | 2 +-
>>   14 files changed, 16 insertions(+), 16 deletions(-)
>> 
>> diff --git a/package/boot/fconfig/Makefile 
>> b/package/boot/fconfig/Makefile
>> index 9b806fe97c..31986e6942 100644
>> --- a/package/boot/fconfig/Makefile
>> +++ b/package/boot/fconfig/Makefile
>> @@ -12,7 +12,7 @@ PKG_VERSION:=20080329
>>   PKG_RELEASE:=1
>>     PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
>> -PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
>> +PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
> 
> 
> Would it make sense to define a similar @OPENWRT alias in 
> scripts/download.pl as we have done for SF, APACHE, GITHUB, GNU, 
> SAVANNAH, KERNEL and GNOME ?

I had the same idea but thought it's awkward to define a variable which 
is then empty. I'll give it a try and see how it looks. We could then 
decide for either solution.

> 
> https://github.com/openwrt/openwrt/blob/master/scripts/download.pl#L192-L255
> 
> Then we could in future change those download locations centrally in 
> download.pl, instead of changing it every single Makefile where it is 
> used. The Makefiles could just contain PKG_SOURCE_URL:=@OPENWRT
> 
> (One afterthought: the pushed contents might actually be empty, as 
> the actual download locations are pushed on lines 261-263 to the same 
> trial queue. Not quite sure about the pushing order logic, but might 
> work.)
>
Hannu Nyman Jan. 31, 2021, 11:29 a.m. UTC | #3
Paul Spooren kirjoitti 31.1.2021 klo 11.19:
>
>
> On Sun, Jan 31, 2021 at 10:08, Hannu Nyman <hannu.nyman@iki.fi> wrote:
>> Paul Spooren kirjoitti 30.1.2021 klo 23.54:
>>> Multiple sources are hosted on OpenWrts source server only. The source
>>> URLs to point to the server vary based on different epochs in OpenWrts
>>> history. Unify them to use always the new source CDN and HTTPS.
>>>
>>> If the CDN fails, sources.o.o is used as a fallback via downloads.pl.
>>>
>>> Signed-off-by: Paul Spooren <mail@aparcar.org>
>>> ---
>>> ...
>>>     PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
>>> -PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
>>> +PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
>>
>>
>> Would it make sense to define a similar @OPENWRT alias in 
>> scripts/download.pl as we have done for SF, APACHE, GITHUB, GNU, SAVANNAH, 
>> KERNEL and GNOME ?
>
> I had the same idea but thought it's awkward to define a variable which is 
> then empty. I'll give it a try and see how it looks. We could then decide 
> for either solution.


Just an elsif block with a comment about the actual sites being added at the 
end as deafult fallback sites in any case. (and possibly a no-op line like 
sleep(1), if the elsif block needs some actual contents. (not sure about perl)).

Or possibly an elsif block containing the same cdn line, so that it gets 
added twice (once here, once as fallback). Seems extraflous, but would look tidy.


>
>>
>> https://github.com/openwrt/openwrt/blob/master/scripts/download.pl#L192-L255
>>
>> Then we could in future change those download locations centrally in 
>> download.pl, instead of changing it every single Makefile where it is 
>> used. The Makefiles could just contain PKG_SOURCE_URL:=@OPENWRT
>>
>> (One afterthought: the pushed contents might actually be empty, as the 
>> actual download locations are pushed on lines 261-263 to the same trial 
>> queue. Not quite sure about the pushing order logic, but might work.)
>>
>
>
diff mbox series

Patch

diff --git a/package/boot/fconfig/Makefile b/package/boot/fconfig/Makefile
index 9b806fe97c..31986e6942 100644
--- a/package/boot/fconfig/Makefile
+++ b/package/boot/fconfig/Makefile
@@ -12,7 +12,7 @@  PKG_VERSION:=20080329
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=4ff0e8f07e35e46b705c0dbe9d9544ede01ea092a69e3f7db03e55a3f2bb8eb7
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
diff --git a/package/firmware/b43legacy-firmware/Makefile b/package/firmware/b43legacy-firmware/Makefile
index 9b9c0070b2..0108c2a169 100644
--- a/package/firmware/b43legacy-firmware/Makefile
+++ b/package/firmware/b43legacy-firmware/Makefile
@@ -12,7 +12,7 @@  PKG_VERSION:=3.130.20.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=wl_apsta-$(PKG_VERSION).o
-PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=7dba610b1d96dd14e901bcbce14cd6ecd1b1ac6f5c0035b0d6b6dc46a7c3ef90
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile b/package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile
index a076fe2596..781c85ec87 100644
--- a/package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile
+++ b/package/firmware/lantiq/dsl-vrx200-firmware-xdsl/Makefile
@@ -10,7 +10,7 @@  PKG_NAME:=dsl_vr9_firmware_xdsl
 PKG_VERSION:=05.08.01.08.01.06_05.08.00.0B.01.01_osc
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=44cd94130571fe42dfa8f0f9d44597d104e9e77962617fe38646b7a0b4184a2b
 PKG_BUILD_DEPENDS:=bsdiff/host
 
diff --git a/package/kernel/broadcom-wl/Makefile b/package/kernel/broadcom-wl/Makefile
index 661c7f0589..8774b64dc0 100644
--- a/package/kernel/broadcom-wl/Makefile
+++ b/package/kernel/broadcom-wl/Makefile
@@ -13,7 +13,7 @@  PKG_VERSION:=5.10.56.27.3
 PKG_RELEASE:=10
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
-PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 
 ifeq ($(ARCH),mipsel)
 PKG_HASH:=26a8c370f48fc129d0731cfd751c36cae1419b0bc8ca35781126744e60eae009
diff --git a/package/kernel/lantiq/ltq-adsl/Makefile b/package/kernel/lantiq/ltq-adsl/Makefile
index 1a9128fc58..e7cd23f48a 100644
--- a/package/kernel/lantiq/ltq-adsl/Makefile
+++ b/package/kernel/lantiq/ltq-adsl/Makefile
@@ -13,7 +13,7 @@  PKG_VERSION:=3.24.4.4
 PKG_RELEASE:=3
 PKG_SOURCE:=drv_dsl_cpe_api_danube-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/ltq-dsl-$(BUILD_VARIANT)/drv_dsl_cpe_api-$(PKG_VERSION)
-PKG_SOURCE_URL:=https://mirror2.openwrt.org/sources/
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=eb2ed59715d3bf4e8a1460bbbe2f1660039e0a9f9d72afb1b2b16590094eb33c
 PKG_MAINTAINER:=John Crispin <john@phrozen.org>
 
diff --git a/package/kernel/lantiq/ltq-tapi/Makefile b/package/kernel/lantiq/ltq-tapi/Makefile
index 072041c589..f364dca723 100644
--- a/package/kernel/lantiq/ltq-tapi/Makefile
+++ b/package/kernel/lantiq/ltq-tapi/Makefile
@@ -13,7 +13,7 @@  PKG_VERSION:=3.13.0
 PKG_RELEASE:=4
 
 PKG_SOURCE:=drv_tapi-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=109374d52872716570fca3fef3b93c9a93159a804dfd42484b19152b825af5c0
 PKG_MAINTAINER:=John Crispin <john@phrozen.org>
 
diff --git a/package/kernel/lantiq/ltq-vdsl-mei/Makefile b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
index 5d15f2650b..82c779daa0 100644
--- a/package/kernel/lantiq/ltq-vdsl-mei/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
@@ -14,7 +14,7 @@  PKG_RELEASE:=4
 PKG_BASE_NAME:=drv_mei_cpe
 PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=94f6904364348b7f74087e721968abc28b2564fb9bd8899aa930d36490387662
 PKG_FIXUP:=autoreconf
 PKG_FLAGS:=nonshared
diff --git a/package/kernel/lantiq/ltq-vdsl/Makefile b/package/kernel/lantiq/ltq-vdsl/Makefile
index d518bd647d..ca0e1bf0d2 100644
--- a/package/kernel/lantiq/ltq-vdsl/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl/Makefile
@@ -14,7 +14,7 @@  PKG_RELEASE:=3
 PKG_BASE_NAME:=drv_dsl_cpe_api
 PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=b4966a60653acc49254b168c6cc9c49eb36c54548e763617788aa4f252a29f21
 PKG_LICENSE:=GPL-2.0 BSD-2-Clause
 PKG_LICENSE_FILES:=LICENSE
diff --git a/package/kernel/lantiq/ltq-vmmc/Makefile b/package/kernel/lantiq/ltq-vmmc/Makefile
index 586d9f6c75..0e95d92186 100644
--- a/package/kernel/lantiq/ltq-vmmc/Makefile
+++ b/package/kernel/lantiq/ltq-vmmc/Makefile
@@ -14,7 +14,7 @@  PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_HASH:=707f515eb727c032418c4da67d7e86884bb56cdc2a606e8f6ded6057d8767e57
-PKG_SOURCE_URL:=https://mirror2.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_MAINTAINER:=John Crispin <john@phrozen.org>
 
 PKG_CHECK_FORMAT_SECURITY:=0
diff --git a/package/kernel/mac80211/broadcom.mk b/package/kernel/mac80211/broadcom.mk
index fb8071e747..b1db3537e2 100644
--- a/package/kernel/mac80211/broadcom.mk
+++ b/package/kernel/mac80211/broadcom.mk
@@ -51,7 +51,7 @@  ifneq ($(CONFIG_B43_FW_5_10),)
   PKG_B43_FWV4_VERSION:=5.10.56.27.3
   PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)/driver/wl_apsta/wl_prebuilt.o
   PKG_B43_FWV4_SOURCE:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)_mipsel.tar.bz2
-  PKG_B43_FWV4_SOURCE_URL:=http://mirror2.openwrt.org/sources/
+  PKG_B43_FWV4_SOURCE_URL:=https://sources.cdn.openwrt.org
   PKG_B43_FWV4_HASH:=26a8c370f48fc129d0731cfd751c36cae1419b0bc8ca35781126744e60eae009
 else
 ifneq ($(CONFIG_B43_FW_4_178),)
@@ -59,7 +59,7 @@  ifneq ($(CONFIG_B43_FW_4_178),)
   PKG_B43_FWV4_VERSION:=4.178.10.4
   PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)/linux/wl_apsta.o
   PKG_B43_FWV4_SOURCE:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION).tar.bz2
-  PKG_B43_FWV4_SOURCE_URL:=http://mirror2.openwrt.org/sources/
+  PKG_B43_FWV4_SOURCE_URL:=https://sources.cdn.openwrt.org
   PKG_B43_FWV4_HASH:=32f6ad98facbb9045646fdc8b54bb03086d204153253f9c65d0234a5d90ae53f
 else
 ifneq ($(CONFIG_B43_FW_5_100_138),)
@@ -74,7 +74,7 @@  else
   PKG_B43_FWV4_VERSION:=4.150.10.5
   PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)/driver/wl_apsta_mimo.o
   PKG_B43_FWV4_SOURCE:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION).tar.bz2
-  PKG_B43_FWV4_SOURCE_URL:=http://mirror2.openwrt.org/sources/
+  PKG_B43_FWV4_SOURCE_URL:=https://sources.cdn.openwrt.org
   PKG_B43_FWV4_HASH:=a9f4e276a4d8d3a1cd0f2eb87080ae89b77f0a7140f06d4e9e2135fc44fdd533
 endif
 endif
diff --git a/package/network/config/ltq-adsl-app/Makefile b/package/network/config/ltq-adsl-app/Makefile
index cfd66d0ee4..d149d9e4e8 100644
--- a/package/network/config/ltq-adsl-app/Makefile
+++ b/package/network/config/ltq-adsl-app/Makefile
@@ -13,7 +13,7 @@  PKG_VERSION:=3.24.4.4
 PKG_RELEASE:=9
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/dsl_cpe_control-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=af0bdf45cc7a62e2b38d39aad4924dd83c24fae170ae5bbd8190c2a3d9106257
 PKG_MAINTAINER:=John Crispin <john@phrozen.org>
 PKG_LICENSE:=BSD-3-Clause
diff --git a/package/network/config/ltq-vdsl-app/Makefile b/package/network/config/ltq-vdsl-app/Makefile
index 5e2db1d5c6..070468dd3a 100644
--- a/package/network/config/ltq-vdsl-app/Makefile
+++ b/package/network/config/ltq-vdsl-app/Makefile
@@ -12,7 +12,7 @@  PKG_VERSION:=4.17.18.6
 PKG_RELEASE:=5
 PKG_BASE_NAME:=dsl_cpe_control
 PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=da8bb929526a61aea0e153ef524331fcd472a1ebbc6d88ca017735a4f82ece02
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
 PKG_LICENSE:=BSD-2-Clause
diff --git a/tools/lzma-old/Makefile b/tools/lzma-old/Makefile
index 4ccd336ed0..a8134e5ad8 100644
--- a/tools/lzma-old/Makefile
+++ b/tools/lzma-old/Makefile
@@ -10,7 +10,7 @@  PKG_NAME:=lzma-old
 PKG_VERSION:=4.32
 
 PKG_SOURCE:=lzma-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=49053e4bb5e0646a841d250d9cb81f7714f5fff04a133216c4748163567acc3d
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/lzma-$(PKG_VERSION)
diff --git a/tools/lzma/Makefile b/tools/lzma/Makefile
index 04c427a3a9..c369ca6b1a 100644
--- a/tools/lzma/Makefile
+++ b/tools/lzma/Makefile
@@ -10,7 +10,7 @@  PKG_NAME:=lzma
 PKG_VERSION:=4.65
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
+PKG_SOURCE_URL:=https://sources.cdn.openwrt.org
 PKG_HASH:=dcbdb5f4843eff638e4a5e8be0e2486a3c5483df73c70823618db8e66f609ec2
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)