diff mbox series

[v3,3/3] uboot-envtools: use `commitcount` for release

Message ID 20210110092400.144356-3-mail@aparcar.org
State Superseded
Delegated to: Paul Spooren
Headers show
Series None | expand

Commit Message

Paul Spooren Jan. 10, 2021, 9:24 a.m. UTC
Use `commitcount` function rather than manually setting a PKG_RELEASE.

Signed-off-by: Paul Spooren <mail@aparcar.org>
---
 package/boot/uboot-envtools/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 8bc2c00ba5..77018ef8a9 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -10,7 +10,6 @@  include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2020.04
-PKG_RELEASE:=17
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
@@ -38,6 +37,7 @@  define Package/uboot-envtools
   SUBMENU:=Boot Loaders
   TITLE:=read/modify U-Boot bootloader environment
   URL:=http://www.denx.de/wiki/U-Boot
+  VERSION:=$(PKG_VERSION)-$(call commitcount)
 endef
 
 define Package/uboot-envtools/description