diff mbox series

[v2,2/4] kmod-tcp-bbr: leave CONFIG_TCP_CONG_ADVANCED to target config

Message ID 20201224063801.211843-3-yszhou4tech@gmail.com
State Accepted
Delegated to: Yousong Zhou
Headers show
Series add tcp hybla congestion control algorithm | expand

Commit Message

Yousong Zhou Dec. 24, 2020, 6:37 a.m. UTC
Since generic has the option set to y and other targets now inherit that
choice, there is no behaviour change

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
---
 package/kernel/linux/modules/netsupport.mk | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 0c68b394d1..958b510015 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -926,9 +926,7 @@  $(eval $(call KernelPackage,sched))
 define KernelPackage/tcp-bbr
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=BBR TCP congestion control
-  KCONFIG:= \
-	CONFIG_TCP_CONG_ADVANCED=y \
-	CONFIG_TCP_CONG_BBR
+  KCONFIG:=CONFIG_TCP_CONG_BBR
   FILES:=$(LINUX_DIR)/net/ipv4/tcp_bbr.ko
   AUTOLOAD:=$(call AutoLoad,74,tcp_bbr)
 endef