diff mbox series

[RFC,2/5] kernel: deactivate usb on ath79-tiny

Message ID 20201206010639.10181-3-devel-sven@geroedel.de
State Rejected
Delegated to: Petr Štetiar
Headers show
Series ath79: add a lower RAM-using version of 8/32 devices | expand

Commit Message

Sven Roederer Dec. 6, 2020, 1:06 a.m. UTC
From: adminuser <adminuser@cvt.bln.roederer.dhs.org>

---
 target/linux/ath79/image/tiny-tp-link.mk | 4 ----
 target/linux/ath79/image/tiny-ubnt.mk    | 2 --
 target/linux/ath79/image/tiny.mk         | 1 -
 target/linux/ath79/tiny/config-default   | 5 +++--
 4 files changed, 3 insertions(+), 9 deletions(-)

Comments

Adrian Schmutzler Dec. 6, 2020, 1:05 p.m. UTC | #1
Hi,

> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org]
> On Behalf Of Sven Roederer
> Sent: Sonntag, 6. Dezember 2020 02:07
> To: openwrt-devel@lists.openwrt.org
> Cc: adminuser <adminuser@cvt.bln.roederer.dhs.org>
> Subject: [RFC PATCH 2/5] kernel: deactivate usb on ath79-tiny
> 
> From: adminuser <adminuser@cvt.bln.roederer.dhs.org>

This has various obvious formal shortcomings:

- From without name
- Missing SOB
- Missing description (why?)

Apart from that, I don't see disabling basic features like USB on a device with USB ports as an option for pure OpenWrt.

If the basic configuration does not run or build, we should simply put "DEFAULT := n" and have the user select the configuration he/she needs.
One might reorganize features between kernel and modules or remove really optional stuff, but this patch is too much of forcing here.

Best

Adrian

> 
> ---
>  target/linux/ath79/image/tiny-tp-link.mk | 4 ----
>  target/linux/ath79/image/tiny-ubnt.mk    | 2 --
>  target/linux/ath79/image/tiny.mk         | 1 -
>  target/linux/ath79/tiny/config-default   | 5 +++--
>  4 files changed, 3 insertions(+), 9 deletions(-)
> 
> diff --git a/target/linux/ath79/image/tiny-tp-link.mk
> b/target/linux/ath79/image/tiny-tp-link.mk
> index d5b36de577..ab931f02fb 100644
> --- a/target/linux/ath79/image/tiny-tp-link.mk
> +++ b/target/linux/ath79/image/tiny-tp-link.mk
> @@ -16,7 +16,6 @@ define Device/tplink_tl-mr3020-v1
>    SOC := ar9331
>    DEVICE_MODEL := TL-MR3020
>    DEVICE_VARIANT := v1
> -  DEVICE_PACKAGES := kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
>    TPLINK_HWID := 0x30200001
>    SUPPORTED_DEVICES += tl-mr3020
>  endef
> @@ -27,7 +26,6 @@ define Device/tplink_tl-mr3040-v2
>    SOC := ar9331
>    DEVICE_MODEL := TL-MR3040
>    DEVICE_VARIANT := v2
> -  DEVICE_PACKAGES := kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
>    TPLINK_HWID := 0x30400002
>    SUPPORTED_DEVICES += tl-mr3040-v2
>  endef
> @@ -39,7 +37,6 @@ define Device/tplink_tl-mr3220-v1
>    DEVICE_MODEL := TL-MR3220
>    DEVICE_VARIANT := v1
>    TPLINK_HWID := 0x32200001
> -  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
>    SUPPORTED_DEVICES += tl-mr3220
>  endef
>  TARGET_DEVICES += tplink_tl-mr3220-v1
> @@ -238,7 +235,6 @@ define Device/tplink_tl-wr703n
>    $(Device/tplink-4mlzma)
>    SOC := ar9331
>    DEVICE_MODEL := TL-WR703N
> -  DEVICE_PACKAGES := kmod-usb-chipidea2
>    TPLINK_HWID := 0x07030101
>    SUPPORTED_DEVICES += tl-wr703n
>  endef
> diff --git a/target/linux/ath79/image/tiny-ubnt.mk
> b/target/linux/ath79/image/tiny-ubnt.mk
> index a8c5a2cf68..be7dd46761 100644
> --- a/target/linux/ath79/image/tiny-ubnt.mk
> +++ b/target/linux/ath79/image/tiny-ubnt.mk
> @@ -31,7 +31,6 @@ endef
>  # UBNT_VERSION e.g. one of (6.0.0, 8.5.3)  define Device/ubnt
>    DEVICE_VENDOR := Ubiquiti
> -  DEVICE_PACKAGES := kmod-usb2
>    IMAGES += factory.bin
>    IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
>  	append-rootfs | pad-rootfs | check-size | mkubntimage-split @@ -
> 40,7 +39,6 @@ endef  define Device/ubnt-xm
>    $(Device/ubnt)
>    DEVICE_VARIANT := XM
> -  DEVICE_PACKAGES += kmod-usb-ohci
>    IMAGE_SIZE := 7448k
>    UBNT_BOARD := XM
>    UBNT_CHIP := ar7240
> diff --git a/target/linux/ath79/image/tiny.mk
> b/target/linux/ath79/image/tiny.mk
> index 83c34d718b..800b2055db 100644
> --- a/target/linux/ath79/image/tiny.mk
> +++ b/target/linux/ath79/image/tiny.mk
> @@ -34,7 +34,6 @@ define Device/pqi_air-pen
>    SOC := ar9330
>    DEVICE_VENDOR := PQI
>    DEVICE_MODEL := Air-Pen
> -  DEVICE_PACKAGES := kmod-usb2
>    IMAGE_SIZE := 7680k
>    SUPPORTED_DEVICES += pqi-air-pen
>  endef
> diff --git a/target/linux/ath79/tiny/config-default
> b/target/linux/ath79/tiny/config-default
> index 42243cfc48..8a83323bc2 100644
> --- a/target/linux/ath79/tiny/config-default
> +++ b/target/linux/ath79/tiny/config-default
> @@ -7,7 +7,8 @@ CONFIG_NET_DSA_MV88E6060=y
> CONFIG_NET_DSA_TAG_TRAILER=y  CONFIG_NET_SWITCHDEV=y
> CONFIG_PHYLINK=y -CONFIG_PHY_AR7100_USB=y -
> CONFIG_PHY_AR7200_USB=y
> +# CONFIG_PHY_AR7100_USB is not set
> +# CONFIG_PHY_AR7200_USB is not set
>  CONFIG_REGULATOR=y
>  CONFIG_REGULATOR_FIXED_VOLTAGE=y
> +# CONFIG_USB_SUPPORT is not set
> --
> 2.20.1
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Sven Roederer Dec. 6, 2020, 9 p.m. UTC | #2
Am Sonntag, 6. Dezember 2020, 14:05:15 CET schrieb Adrian Schmutzler:
> 
> Apart from that, I don't see disabling basic features like USB on a device
> with USB ports as an option for pure OpenWrt.
> 

Disabling USB was just a pragmatic solution, as without SCSI-support, 
partition-handling and USB-ACM, I did not see a usecae the USB-port might be 
needed for. 

> If the basic configuration does not run or build, we should simply put
> "DEFAULT := n" and have the user select the configuration he/she needs. One
> might reorganize features between kernel and modules or remove really
> optional stuff, but this patch is too much of forcing here.
> 
To me it looked like kernel USB-support is present, even the OpenWrt USB-
support is not enabled I've choosen the hardcoded way. So I was able to test 
the change and ask for comments, without long rework of the config-menu 
options.

Sven
diff mbox series

Patch

diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index d5b36de577..ab931f02fb 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -16,7 +16,6 @@  define Device/tplink_tl-mr3020-v1
   SOC := ar9331
   DEVICE_MODEL := TL-MR3020
   DEVICE_VARIANT := v1
-  DEVICE_PACKAGES := kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
   TPLINK_HWID := 0x30200001
   SUPPORTED_DEVICES += tl-mr3020
 endef
@@ -27,7 +26,6 @@  define Device/tplink_tl-mr3040-v2
   SOC := ar9331
   DEVICE_MODEL := TL-MR3040
   DEVICE_VARIANT := v2
-  DEVICE_PACKAGES := kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
   TPLINK_HWID := 0x30400002
   SUPPORTED_DEVICES += tl-mr3040-v2
 endef
@@ -39,7 +37,6 @@  define Device/tplink_tl-mr3220-v1
   DEVICE_MODEL := TL-MR3220
   DEVICE_VARIANT := v1
   TPLINK_HWID := 0x32200001
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
   SUPPORTED_DEVICES += tl-mr3220
 endef
 TARGET_DEVICES += tplink_tl-mr3220-v1
@@ -238,7 +235,6 @@  define Device/tplink_tl-wr703n
   $(Device/tplink-4mlzma)
   SOC := ar9331
   DEVICE_MODEL := TL-WR703N
-  DEVICE_PACKAGES := kmod-usb-chipidea2
   TPLINK_HWID := 0x07030101
   SUPPORTED_DEVICES += tl-wr703n
 endef
diff --git a/target/linux/ath79/image/tiny-ubnt.mk b/target/linux/ath79/image/tiny-ubnt.mk
index a8c5a2cf68..be7dd46761 100644
--- a/target/linux/ath79/image/tiny-ubnt.mk
+++ b/target/linux/ath79/image/tiny-ubnt.mk
@@ -31,7 +31,6 @@  endef
 # UBNT_VERSION e.g. one of (6.0.0, 8.5.3)
 define Device/ubnt
   DEVICE_VENDOR := Ubiquiti
-  DEVICE_PACKAGES := kmod-usb2
   IMAGES += factory.bin
   IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
 	append-rootfs | pad-rootfs | check-size | mkubntimage-split
@@ -40,7 +39,6 @@  endef
 define Device/ubnt-xm
   $(Device/ubnt)
   DEVICE_VARIANT := XM
-  DEVICE_PACKAGES += kmod-usb-ohci
   IMAGE_SIZE := 7448k
   UBNT_BOARD := XM
   UBNT_CHIP := ar7240
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index 83c34d718b..800b2055db 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -34,7 +34,6 @@  define Device/pqi_air-pen
   SOC := ar9330
   DEVICE_VENDOR := PQI
   DEVICE_MODEL := Air-Pen
-  DEVICE_PACKAGES := kmod-usb2
   IMAGE_SIZE := 7680k
   SUPPORTED_DEVICES += pqi-air-pen
 endef
diff --git a/target/linux/ath79/tiny/config-default b/target/linux/ath79/tiny/config-default
index 42243cfc48..8a83323bc2 100644
--- a/target/linux/ath79/tiny/config-default
+++ b/target/linux/ath79/tiny/config-default
@@ -7,7 +7,8 @@  CONFIG_NET_DSA_MV88E6060=y
 CONFIG_NET_DSA_TAG_TRAILER=y
 CONFIG_NET_SWITCHDEV=y
 CONFIG_PHYLINK=y
-CONFIG_PHY_AR7100_USB=y
-CONFIG_PHY_AR7200_USB=y
+# CONFIG_PHY_AR7100_USB is not set
+# CONFIG_PHY_AR7200_USB is not set
 CONFIG_REGULATOR=y
 CONFIG_REGULATOR_FIXED_VOLTAGE=y
+# CONFIG_USB_SUPPORT is not set