diff mbox series

Revert "netifd: update to the latest version"

Message ID 20201113101904.1238-1-rsalvaterra@gmail.com
State Rejected
Headers show
Series Revert "netifd: update to the latest version" | expand

Commit Message

Rui Salvaterra Nov. 13, 2020, 10:19 a.m. UTC
This broke the switch VLAN configuration on at least Archer C6 v2 EU and Archer
C7 (both switchdev-based one-armed routers).

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
---
 package/network/config/netifd/Makefile | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Felix Fietkau Nov. 13, 2020, 10:25 a.m. UTC | #1
On 2020-11-13 11:19, Rui Salvaterra wrote:
> This broke the switch VLAN configuration on at least Archer C6 v2 EU and Archer
> C7 (both switchdev-based one-armed routers).
> 
> Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Please git-bisect this and show me the config that doesn't work anymore,
so that I can fix it properly.

Thanks,

- Felix
Rui Salvaterra Nov. 13, 2020, 10:34 a.m. UTC | #2
Hi, Felix,

On Fri, 13 Nov 2020 at 10:25, Felix Fietkau <nbd@nbd.name> wrote:
>
> Please git-bisect this and show me the config that doesn't work anymore,
> so that I can fix it properly.

I can't bisect this now, as I'm using the router. The config (in
/etc/config/network), however, is trivial:

config switch
    option enable_vlan '1'
    option name 'switch0'
    option reset '1'

config switch_vlan
    option device 'switch0'
    option ports '2 3 4 5 0t'
    option vlan '1'

config switch_vlan
    option device 'switch0'
    option ports '1 0t'
    option vlan '2'

Symptom: with the netifd update, only the VLAN 1 (eth0.1@eth0)
interface exists, VLAN 2 (eth0.2@eth0) doesn't.

Thanks,
Rui
Felix Fietkau Nov. 13, 2020, 10:35 a.m. UTC | #3
On 2020-11-13 11:34, Rui Salvaterra wrote:
> Hi, Felix,
> 
> On Fri, 13 Nov 2020 at 10:25, Felix Fietkau <nbd@nbd.name> wrote:
>>
>> Please git-bisect this and show me the config that doesn't work anymore,
>> so that I can fix it properly.
> 
> I can't bisect this now, as I'm using the router. The config (in
> /etc/config/network), however, is trivial:
> 
> config switch
>     option enable_vlan '1'
>     option name 'switch0'
>     option reset '1'
> 
> config switch_vlan
>     option device 'switch0'
>     option ports '2 3 4 5 0t'
>     option vlan '1'
> 
> config switch_vlan
>     option device 'switch0'
>     option ports '1 0t'
>     option vlan '2'
> 
> Symptom: with the netifd update, only the VLAN 1 (eth0.1@eth0)
> interface exists, VLAN 2 (eth0.2@eth0) doesn't.
Please show me the full /etc/config/network so I can test with it as-is.

Thanks,

- Felix
Rui Salvaterra Nov. 13, 2020, 10:41 a.m. UTC | #4
On Fri, 13 Nov 2020 at 10:35, Felix Fietkau <nbd@nbd.name> wrote:
>
> Please show me the full /etc/config/network so I can test with it as-is.

Here it goes (WG keys redacted):

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    list ipaddr '127.0.0.1/8'

config interface 'lan'
    option ifname 'eth0.1'
    option ipv6 '0'
    option proto 'static'
    option type 'bridge'
    list ipaddr '192.168.16.1/24'

config interface 'tor'
    option ipv6 '0'
    option proto 'static'
    option type 'bridge'
    list ipaddr '192.168.17.1/24'

config interface 'gst'
    option ipv6 '0'
    option proto 'static'
    option type 'bridge'
    list ipaddr '192.168.18.1/24'

config interface 'pub'
    option ipv6 '0'
    option proto 'static'
    option type 'bridge'
    list ipaddr '192.168.19.1/24'

config interface 'wgl'
    option ipv6 '0'
    option listen_port '995'
    option proto 'wireguard'
    list addresses '10.0.0.1/29'

config wireguard_wgl
    option route_allowed_ips '1'
    list allowed_ips '192.168.240.0/24'

config wireguard_wgl
    list allowed_ips '10.0.0.4/32'

config wireguard_wgl
    list allowed_ips '10.0.0.5/32'

config interface 'wgt'
    option ipv6 '0'
    option listen_port '443'
    option proto 'wireguard'
    list addresses '10.0.1.1/30'

config wireguard_wgt
    list allowed_ips '10.0.1.2/32'

config interface 'wgk'
    option ipv6 '0'
    option listen_port '80'
    option proto 'wireguard'
    list addresses '10.0.2.2/30'

config wireguard_wgk
    option endpoint_host '62.28.38.138'
    option endpoint_port '443'
    option route_allowed_ips '1'
    list allowed_ips '192.168.1.0/24'

config interface 'wan'
    option ifname 'eth0.2'
    option ipv6 '0'
    option proto 'dhcp'

config switch
    option enable_vlan '1'
    option name 'switch0'
    option reset '1'

config switch_vlan
    option device 'switch0'
    option ports '2 3 4 5 0t'
    option vlan '1'

config switch_vlan
    option device 'switch0'
    option ports '1 0t'
    option vlan '2'

Thanks,
Rui
e9hack Nov. 13, 2020, 12:03 p.m. UTC | #5
Am 13.11.2020 um 11:19 schrieb Rui Salvaterra:
> This broke the switch VLAN configuration on at least Archer C6 v2 EU and Archer
> C7 (both switchdev-based one-armed routers).

Which Archer C7 version is mentioned here? I'm using an Archer C7 v2 and didn't see any issues. 

Regards,
Hartmut
diff mbox series

Patch

diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 92bdb34fc8..2c26517f44 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -5,9 +5,9 @@  PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
-PKG_SOURCE_DATE:=2020-11-05
-PKG_SOURCE_VERSION:=ed11f0c0ffe4fdacfe3f8223049ef8a61d9c53e9
-PKG_MIRROR_HASH:=0abd8aaa3818147b6a550a054d97c6cd21d22e806195d863aa87b6b2c808d409
+PKG_SOURCE_DATE:=2020-10-22
+PKG_SOURCE_VERSION:=24ce1eab4910869576406bafd0489daf0d3e6e28
+PKG_MIRROR_HASH:=aa73b4e470e81165baba0262144f410bb05a3ff141cf72ad451914f033868ea1
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 PKG_LICENSE:=GPL-2.0