diff mbox series

iproute2: update to 5.9

Message ID 20201112171852.127080-1-dedeckeh@gmail.com
State Accepted
Delegated to: Hans Dedecker
Headers show
Series iproute2: update to 5.9 | expand

Commit Message

Hans Dedecker Nov. 12, 2020, 5:18 p.m. UTC
Update iproute2 to latest stable 5.9; for the changes see https://lwn.net/Articles/834755/

Refresh patches

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
---
 package/network/utils/iproute2/Makefile                     | 4 ++--
 .../utils/iproute2/patches/115-add-config-xtlibdir.patch    | 2 +-
 .../utils/iproute2/patches/175-reduce-dynamic-syms.patch    | 6 +++---
 3 files changed, 6 insertions(+), 6 deletions(-)

Comments

Hauke Mehrtens Nov. 13, 2020, 7:52 p.m. UTC | #1
On 11/12/20 6:18 PM, Hans Dedecker wrote:
> Update iproute2 to latest stable 5.9; for the changes see https://lwn.net/Articles/834755/
> 
> Refresh patches
> 
> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>

Acked-by: Hauke Mehrtens <hauke@huake-m.de>

> ---
>   package/network/utils/iproute2/Makefile                     | 4 ++--
>   .../utils/iproute2/patches/115-add-config-xtlibdir.patch    | 2 +-
>   .../utils/iproute2/patches/175-reduce-dynamic-syms.patch    | 6 +++---
>   3 files changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
> index 90f8b59a02..237f84736b 100644
> --- a/package/network/utils/iproute2/Makefile
> +++ b/package/network/utils/iproute2/Makefile
> @@ -8,12 +8,12 @@
>   include $(TOPDIR)/rules.mk
>   
>   PKG_NAME:=iproute2
> -PKG_VERSION:=5.8.0
> +PKG_VERSION:=5.9.0
>   PKG_RELEASE:=1
>   
>   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
>   PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
> -PKG_HASH:=cfcd1f890290f8c8afcc91d9444ad929b9252c16f9ab3f286c50dd3c59dc646e
> +PKG_HASH:=a25dac94bcdcf2f73316c7f812115ea7a5710580bad892b08a83d00c6b33dacf
>   PKG_BUILD_PARALLEL:=1
>   PKG_BUILD_DEPENDS:=iptables
>   PKG_LICENSE:=GPL-2.0
> diff --git a/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch b/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
> index 03df7809f7..8702d5fd2d 100644
> --- a/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
> +++ b/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
> @@ -1,6 +1,6 @@
>   --- a/tc/Makefile
>   +++ b/tc/Makefile
> -@@ -127,6 +127,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
> +@@ -128,6 +128,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
>    ifneq ($(IPT_LIB_DIR),)
>    	CFLAGS += -DIPT_LIB_DIR=\"$(IPT_LIB_DIR)\"
>    endif
> diff --git a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
> index e5d5492a35..da961a183b 100644
> --- a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
> +++ b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
> @@ -9,7 +9,7 @@
>    endif
>    
>    TCLIB := tc_core.o
> -@@ -143,7 +143,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
> +@@ -144,7 +144,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
>    all: tc $(TCSO)
>    
>    tc: $(TCOBJ) $(LIBNETLINK) libtc.a
> @@ -18,7 +18,7 @@
>    
>    libtc.a: $(TCLIB)
>    	$(QUIET_AR)$(AR) rcs $@ $^
> -@@ -165,6 +165,7 @@ install: all
> +@@ -166,6 +166,7 @@ install: all
>    clean:
>    	rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.tab.h; \
>    	rm -f emp_ematch.tab.*
> @@ -26,7 +26,7 @@
>    
>    q_atm.so: q_atm.c
>    	$(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
> -@@ -204,4 +205,15 @@ static-syms.h: $(wildcard *.c)
> +@@ -205,4 +206,15 @@ static-syms.h: $(wildcard *.c)
>    		sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
>    	done > $@
>    
>
diff mbox series

Patch

diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 90f8b59a02..237f84736b 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -8,12 +8,12 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=5.8.0
+PKG_VERSION:=5.9.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=cfcd1f890290f8c8afcc91d9444ad929b9252c16f9ab3f286c50dd3c59dc646e
+PKG_HASH:=a25dac94bcdcf2f73316c7f812115ea7a5710580bad892b08a83d00c6b33dacf
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=iptables
 PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch b/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
index 03df7809f7..8702d5fd2d 100644
--- a/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
+++ b/package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
@@ -1,6 +1,6 @@ 
 --- a/tc/Makefile
 +++ b/tc/Makefile
-@@ -127,6 +127,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
+@@ -128,6 +128,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
  ifneq ($(IPT_LIB_DIR),)
  	CFLAGS += -DIPT_LIB_DIR=\"$(IPT_LIB_DIR)\"
  endif
diff --git a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
index e5d5492a35..da961a183b 100644
--- a/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
+++ b/package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
@@ -9,7 +9,7 @@ 
  endif
  
  TCLIB := tc_core.o
-@@ -143,7 +143,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
+@@ -144,7 +144,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
  all: tc $(TCSO)
  
  tc: $(TCOBJ) $(LIBNETLINK) libtc.a
@@ -18,7 +18,7 @@ 
  
  libtc.a: $(TCLIB)
  	$(QUIET_AR)$(AR) rcs $@ $^
-@@ -165,6 +165,7 @@ install: all
+@@ -166,6 +166,7 @@ install: all
  clean:
  	rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.tab.h; \
  	rm -f emp_ematch.tab.*
@@ -26,7 +26,7 @@ 
  
  q_atm.so: q_atm.c
  	$(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
-@@ -204,4 +205,15 @@ static-syms.h: $(wildcard *.c)
+@@ -205,4 +206,15 @@ static-syms.h: $(wildcard *.c)
  		sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
  	done > $@