diff mbox series

[v2] hostapd: enable OWE for the basic-{openssl, wolfssl} variants

Message ID 20201031115948.127305-1-rsalvaterra@gmail.com
State Accepted
Delegated to: Daniel Golle
Headers show
Series [v2] hostapd: enable OWE for the basic-{openssl, wolfssl} variants | expand

Commit Message

Rui Salvaterra Oct. 31, 2020, 11:59 a.m. UTC
Opportunistic Wireless Encryption is needed to create/access encrypted networks
which don't require authentication.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
---
v2: reword the commit message.

 package/network/services/hostapd/Makefile | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index c03ec6bdc4..f076eba88f 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -102,6 +102,9 @@  ifeq ($(SSL_VARIANT),openssl)
   DRIVER_MAKEOPTS += CONFIG_TLS=openssl CONFIG_SAE=y
   TARGET_LDFLAGS += -lcrypto -lssl
 
+  ifeq ($(LOCAL_VARIANT),basic)
+    DRIVER_MAKEOPTS += CONFIG_OWE=y
+  endif
   ifeq ($(LOCAL_VARIANT),mesh)
     DRIVER_MAKEOPTS += CONFIG_AP=y CONFIG_MESH=y
   endif
@@ -114,6 +117,9 @@  ifeq ($(SSL_VARIANT),wolfssl)
   DRIVER_MAKEOPTS += CONFIG_TLS=wolfssl CONFIG_SAE=y
   TARGET_LDFLAGS += -lwolfssl
 
+  ifeq ($(LOCAL_VARIANT),basic)
+    DRIVER_MAKEOPTS += CONFIG_OWE=y
+  endif
   ifeq ($(LOCAL_VARIANT),mesh)
     DRIVER_MAKEOPTS += CONFIG_AP=y CONFIG_MESH=y CONFIG_WPS_NFC=1
   endif