diff mbox series

omap: update uboot to v2020.04

Message ID 20200904073049.1255919-1-a.heider@gmail.com
State Accepted
Delegated to: Alexander Couzens
Headers show
Series omap: update uboot to v2020.04 | expand

Commit Message

Andre Heider Sept. 4, 2020, 7:30 a.m. UTC
Fixes the build error:
/usr/bin/ld: scripts/dtc/dtc-parser.tab.o:(.bss+0x10): multiple definition of `yylloc'; scripts/dtc/dtc-lexer.lex.o:(.bss+0x0): first defined here
collect2: error: ld returned 1 exit status

Successfully tested on boneblack.

Signed-off-by: Andre Heider <a.heider@gmail.com>
---
 package/boot/uboot-omap/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Andre Heider Sept. 14, 2020, 8:49 a.m. UTC | #1
Hi Adrian,

On 04/09/2020 09:30, Andre Heider wrote:
> Fixes the build error:
> /usr/bin/ld: scripts/dtc/dtc-parser.tab.o:(.bss+0x10): multiple definition of `yylloc'; scripts/dtc/dtc-lexer.lex.o:(.bss+0x0): first defined here
> collect2: error: ld returned 1 exit status
> 
> Successfully tested on boneblack.
> 
> Signed-off-by: Andre Heider <a.heider@gmail.com>

you took care of my last omap patches, would you take a look at this one 
too please?

See your comment here:
https://github.com/openwrt/openwrt/pull/2852#issuecomment-620281604

Thanks,
Andre

> ---
>   package/boot/uboot-omap/Makefile | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
> index 70c8af1dc4..f66b8d5331 100644
> --- a/package/boot/uboot-omap/Makefile
> +++ b/package/boot/uboot-omap/Makefile
> @@ -8,10 +8,10 @@
>   include $(TOPDIR)/rules.mk
>   include $(INCLUDE_DIR)/kernel.mk
>   
> -PKG_VERSION:=2019.10
> +PKG_VERSION:=2020.04
>   PKG_RELEASE:=1
>   
> -PKG_HASH:=8d6d6070739522dd236cba7055b8736bfe92b4fac0ea18ad809829ca79667014
> +PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
>   
>   include $(INCLUDE_DIR)/u-boot.mk
>   include $(INCLUDE_DIR)/package.mk
>
Adrian Schmutzler Sept. 14, 2020, 9:06 a.m. UTC | #2
> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org]
> On Behalf Of Andre Heider
> Sent: Montag, 14. September 2020 10:50
> To: Adrian Schmutzler <freifunk@adrianschmutzler.de>
> Cc: OpenWrt Development List <openwrt-devel@lists.openwrt.org>
> Subject: Re: [PATCH] omap: update uboot to v2020.04
> 
> Hi Adrian,
> 
> On 04/09/2020 09:30, Andre Heider wrote:
> > Fixes the build error:
> > /usr/bin/ld: scripts/dtc/dtc-parser.tab.o:(.bss+0x10): multiple
> > definition of `yylloc'; scripts/dtc/dtc-lexer.lex.o:(.bss+0x0): first
> > defined here
> > collect2: error: ld returned 1 exit status
> >
> > Successfully tested on boneblack.
> >
> > Signed-off-by: Andre Heider <a.heider@gmail.com>
> 
> you took care of my last omap patches, would you take a look at this one too
> please?

Sorry, u-boot is not my area.

Best

Adrian

> 
> See your comment here:
> https://github.com/openwrt/openwrt/pull/2852#issuecomment-620281604
> 
> Thanks,
> Andre
> 
> > ---
> >   package/boot/uboot-omap/Makefile | 4 ++--
> >   1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/package/boot/uboot-omap/Makefile
> > b/package/boot/uboot-omap/Makefile
> > index 70c8af1dc4..f66b8d5331 100644
> > --- a/package/boot/uboot-omap/Makefile
> > +++ b/package/boot/uboot-omap/Makefile
> > @@ -8,10 +8,10 @@
> >   include $(TOPDIR)/rules.mk
> >   include $(INCLUDE_DIR)/kernel.mk
> >
> > -PKG_VERSION:=2019.10
> > +PKG_VERSION:=2020.04
> >   PKG_RELEASE:=1
> >
> > -
> PKG_HASH:=8d6d6070739522dd236cba7055b8736bfe92b4fac0ea18ad809829c
> a796
> > 67014
> >
> +PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff
> 4ad5
> > +65372
> >
> >   include $(INCLUDE_DIR)/u-boot.mk
> >   include $(INCLUDE_DIR)/package.mk
> >
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Andre Heider Sept. 21, 2020, 4:31 p.m. UTC | #3
Hi Alexander,

On 04/09/2020 09:30, Andre Heider wrote:
> Fixes the build error:
> /usr/bin/ld: scripts/dtc/dtc-parser.tab.o:(.bss+0x10): multiple definition of `yylloc'; scripts/dtc/dtc-lexer.lex.o:(.bss+0x0): first defined here
> collect2: error: ld returned 1 exit status
> 
> Successfully tested on boneblack.
> 
> Signed-off-by: Andre Heider <a.heider@gmail.com>

do you mind to take a quick look? In the end this is just a tiny package 
bump! :)

Thanks,
Andre

> ---
>   package/boot/uboot-omap/Makefile | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
> index 70c8af1dc4..f66b8d5331 100644
> --- a/package/boot/uboot-omap/Makefile
> +++ b/package/boot/uboot-omap/Makefile
> @@ -8,10 +8,10 @@
>   include $(TOPDIR)/rules.mk
>   include $(INCLUDE_DIR)/kernel.mk
>   
> -PKG_VERSION:=2019.10
> +PKG_VERSION:=2020.04
>   PKG_RELEASE:=1
>   
> -PKG_HASH:=8d6d6070739522dd236cba7055b8736bfe92b4fac0ea18ad809829ca79667014
> +PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
>   
>   include $(INCLUDE_DIR)/u-boot.mk
>   include $(INCLUDE_DIR)/package.mk
>
Alexander 'lynxis' Couzens Sept. 21, 2020, 4:53 p.m. UTC | #4
> do you mind to take a quick look? In the end this is just a tiny
> package bump! :)

let me have a tiny look on other devices ;)
Alexander 'lynxis' Couzens Sept. 27, 2020, 4:16 a.m. UTC | #5
On Mon, 21 Sep 2020 18:53:13 +0200
Alexander 'lynxis' Couzens <lynxis@fe80.eu> wrote:

> > do you mind to take a quick look? In the end this is just a tiny
> > package bump! :)  
> 
> let me have a tiny look on other devices ;)

the pandaboards fails, but the bbb boots. same as before.
the panda is only booting the spl.
i'll have a look tomorrow on the panda with jtag but it's not a blocker
for your patch. it didn't worked before.

i'll merge your patch within the next week.

best,
lynxis
Andre Heider Oct. 5, 2020, 4:07 p.m. UTC | #6
On 27/09/2020 06:16, Alexander 'lynxis' Couzens wrote:
> On Mon, 21 Sep 2020 18:53:13 +0200
> Alexander 'lynxis' Couzens <lynxis@fe80.eu> wrote:
> 
>>> do you mind to take a quick look? In the end this is just a tiny
>>> package bump! :)
>>
>> let me have a tiny look on other devices ;)
> 
> the pandaboards fails, but the bbb boots. same as before.
> the panda is only booting the spl.
> i'll have a look tomorrow on the panda with jtag but it's not a blocker
> for your patch. it didn't worked before.
> 
> i'll merge your patch within the next week.

Thanks!

I think we're the only omap users left? ;)

Andre
diff mbox series

Patch

diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index 70c8af1dc4..f66b8d5331 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -8,10 +8,10 @@ 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_VERSION:=2019.10
+PKG_VERSION:=2020.04
 PKG_RELEASE:=1
 
-PKG_HASH:=8d6d6070739522dd236cba7055b8736bfe92b4fac0ea18ad809829ca79667014
+PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk