diff mbox series

[v2,1/2] rules.mk: remove redundant -I/-L

Message ID 20200826061503.454068-1-a.heider@gmail.com
State Superseded
Delegated to: Petr Štetiar
Headers show
Series [v2,1/2] rules.mk: remove redundant -I/-L | expand

Commit Message

Andre Heider Aug. 26, 2020, 6:15 a.m. UTC
$STAGING_DIR/usr/{include,lib} are already added using the gcc specs file, see
scripts/patch-specs.sh

$STAGING_DIR/lib is unused and seems to be a leftover from
1f0063b5 "rules.mk: remove "$(STAGING_DIR)/include""

Signed-off-by: Andre Heider <a.heider@gmail.com>
---
 rules.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Andre Heider Sept. 3, 2020, 3:49 p.m. UTC | #1
Hi Jo,

On 26/08/2020 08:15, Andre Heider wrote:
> $STAGING_DIR/usr/{include,lib} are already added using the gcc specs file, see
> scripts/patch-specs.sh
> 
> $STAGING_DIR/lib is unused and seems to be a leftover from
> 1f0063b5 "rules.mk: remove "$(STAGING_DIR)/include""
> 
> Signed-off-by: Andre Heider <a.heider@gmail.com>

do these two patches look acceptable now?

Thanks,
Andre

> ---
>   rules.mk | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/rules.mk b/rules.mk
> index 45d96d6be4..a6615647f9 100644
> --- a/rules.mk
> +++ b/rules.mk
> @@ -174,8 +174,8 @@ TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3) $(call qstrip,$(
>   TARGET_CXXFLAGS = $(TARGET_CFLAGS)
>   TARGET_ASFLAGS_DEFAULT = $(TARGET_CFLAGS)
>   TARGET_ASFLAGS = $(TARGET_ASFLAGS_DEFAULT)
> -TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include
> -TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
> +TARGET_CPPFLAGS:=
> +TARGET_LDFLAGS:=
>   ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
>   LIBGCC_S_PATH=$(realpath $(wildcard $(call qstrip,$(CONFIG_LIBGCC_ROOT_DIR))/$(call qstrip,$(CONFIG_LIBGCC_FILE_SPEC))))
>   LIBGCC_S=$(if $(LIBGCC_S_PATH),-L$(dir $(LIBGCC_S_PATH)) -lgcc_s)
>
Andre Heider Sept. 14, 2020, 8:45 a.m. UTC | #2
On 26/08/2020 08:15, Andre Heider wrote:
> $STAGING_DIR/usr/{include,lib} are already added using the gcc specs file, see
> scripts/patch-specs.sh
> 
> $STAGING_DIR/lib is unused and seems to be a leftover from
> 1f0063b5 "rules.mk: remove "$(STAGING_DIR)/include""
> 
> Signed-off-by: Andre Heider <a.heider@gmail.com>

Anyone else? The tiny patches fix just a small annoyance, but an 
annoyance nevertheless ;)

Thanks,
Andre
diff mbox series

Patch

diff --git a/rules.mk b/rules.mk
index 45d96d6be4..a6615647f9 100644
--- a/rules.mk
+++ b/rules.mk
@@ -174,8 +174,8 @@  TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3) $(call qstrip,$(
 TARGET_CXXFLAGS = $(TARGET_CFLAGS)
 TARGET_ASFLAGS_DEFAULT = $(TARGET_CFLAGS)
 TARGET_ASFLAGS = $(TARGET_ASFLAGS_DEFAULT)
-TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include
-TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+TARGET_CPPFLAGS:=
+TARGET_LDFLAGS:=
 ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 LIBGCC_S_PATH=$(realpath $(wildcard $(call qstrip,$(CONFIG_LIBGCC_ROOT_DIR))/$(call qstrip,$(CONFIG_LIBGCC_FILE_SPEC))))
 LIBGCC_S=$(if $(LIBGCC_S_PATH),-L$(dir $(LIBGCC_S_PATH)) -lgcc_s)