diff mbox series

[RFC] procd: Remove the remnants of tmp-on-zram from the makefile

Message ID 20200629183139.16837-1-rsalvaterra@gmail.com
State Not Applicable
Delegated to: Petr Štetiar
Headers show
Series [RFC] procd: Remove the remnants of tmp-on-zram from the makefile | expand

Commit Message

Rui Salvaterra June 29, 2020, 6:31 p.m. UTC
Now that this feature is gone, clean-up the makefile accordingly.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
---
 package/system/procd/Makefile | 10 +---------
 1 file changed, 1 insertion(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 8553b4e304..091a0a6d11 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -24,8 +24,7 @@  PKG_MAINTAINER:=John Crispin <john@phrozen.org>
 
 PKG_ASLR_PIE_REGULAR:=1
 PKG_CONFIG_DEPENDS:= \
-	CONFIG_TARGET_INIT_PATH CONFIG_KERNEL_SECCOMP \
-	CONFIG_PROCD_SHOW_BOOT CONFIG_PROCD_ZRAM_TMPFS \
+	CONFIG_TARGET_INIT_PATH CONFIG_KERNEL_SECCOMP CONFIG_PROCD_SHOW_BOOT \
 	CONFIG_KERNEL_NAMESPACES CONFIG_PACKAGE_procd-ujail CONFIG_PACKAGE_procd-seccomp
 
 include $(INCLUDE_DIR)/package.mk
@@ -79,9 +78,6 @@  config PROCD_SHOW_BOOT
 	default n
 	prompt "Print the shutdown to the console as well as logging it to syslog"
 
-config PROCD_ZRAM_TMPFS
-	bool
-	default n
 endmenu
 endef
 
@@ -90,10 +86,6 @@  ifeq ($(CONFIG_PROCD_SHOW_BOOT),y)
   CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE=1
 endif
 
-ifeq ($(CONFIG_PROCD_ZRAM_TMPFS),y)
-  CMAKE_OPTIONS += -DZRAM_TMPFS=1
-endif
-
 ifdef CONFIG_PACKAGE_procd-ujail
   CMAKE_OPTIONS += -DJAIL_SUPPORT=1
 endif