diff mbox series

mvebu: move definition of factory.img out of Device/Default

Message ID 20200624180313.14251-1-freifunk@adrianschmutzler.de
State Accepted
Delegated to: Adrian Schmutzler
Headers show
Series mvebu: move definition of factory.img out of Device/Default | expand

Commit Message

Adrian Schmutzler June 24, 2020, 6:03 p.m. UTC
The Device/Default definition in mvebu defines an IMAGE/factory.img
which is not included in IMAGES, and only used twice in the
individual definitions. Move it out of the default definition
to keep it closer to the reassignment of IMAGES and make it more
consistent with respect to other values of IMAGE/factory.img

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 target/linux/mvebu/image/Makefile    | 1 -
 target/linux/mvebu/image/cortexa9.mk | 4 ++++
 2 files changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index cbf34c1bc8..502e081ec3 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -104,7 +104,6 @@  define Device/Default
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | append-dtb | uImage none
   IMAGES := sysupgrade.bin
-  IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
   UBINIZE_OPTS := -E 5
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index bb09d2b6f7..f01a76a9d3 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -55,6 +55,8 @@  define Device/linksys
   DEVICE_VENDOR := Linksys
   DEVICE_PACKAGES := kmod-mwlwifi wpad-basic
   IMAGES += factory.img
+  IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
+	append-ubi | pad-to $$$$(PAGESIZE)
   KERNEL_SIZE := 6144k
 endef
 
@@ -151,6 +153,8 @@  define Device/marvell_a385-db-ap
   DEVICE_MODEL := Armada 385 Development Board AP (DB-88F6820-AP)
   DEVICE_DTS := armada-385-db-ap
   IMAGES += factory.img
+  IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
+	append-ubi | pad-to $$$$(PAGESIZE)
   KERNEL_SIZE := 8192k
   SUPPORTED_DEVICES += armada-385-db-ap
 endef