diff mbox series

ath79: do not build TP-Link tiny images by default

Message ID 20200622114459.8472-1-freifunk@adrianschmutzler.de
State Accepted
Headers show
Series ath79: do not build TP-Link tiny images by default | expand

Commit Message

Adrian Schmutzler June 22, 2020, 11:44 a.m. UTC
For quite some time, the tiny (4M flash) TP-Link sysupgrade and
factory images cannot be built anymore by the buildbots, just
the initramfs-kernel.bin file are still there.

Disable these images for the buildbots and save some CPU cycles.

Note that these devices still build fine with default settings,
even for kernel 5.4.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 target/linux/ath79/image/common-tp-link.mk | 2 ++
 target/linux/ath79/image/tiny-tp-link.mk   | 1 +
 2 files changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
index 81a557df48..3ae377f78f 100644
--- a/target/linux/ath79/image/common-tp-link.mk
+++ b/target/linux/ath79/image/common-tp-link.mk
@@ -48,12 +48,14 @@  define Device/tplink-4m
   $(Device/tplink-nolzma)
   TPLINK_FLASHLAYOUT := 4M
   IMAGE_SIZE := 3904k
+  DEFAULT := n
 endef
 
 define Device/tplink-4mlzma
   $(Device/tplink-v1)
   TPLINK_FLASHLAYOUT := 4Mlzma
   IMAGE_SIZE := 3904k
+  DEFAULT := n
 endef
 
 define Device/tplink-8m
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 4926084597..0da712c5d4 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -157,6 +157,7 @@  define Device/tplink_tl-wa850re-v2
   TPLINK_HWID := 0x08500002
   DEVICE_PACKAGES := rssileds
   SUPPORTED_DEVICES += tl-wa850re-v2
+  DEFAULT := n
 endef
 TARGET_DEVICES += tplink_tl-wa850re-v2