diff mbox series

[OpenWrt-Devel,3/3] ath79: add support for Teltonika RUT955

Message ID 20200205170651.GA879610@makrotopia.org
State Superseded
Delegated to: Daniel Golle
Headers show
Series None | expand

Commit Message

Daniel Golle Feb. 5, 2020, 5:06 p.m. UTC
Specification:

- 550/400/200 MHz (CPU/DDR/AHB)
- 128 MB of RAM (DDR2)
- 16 MB of FLASH (SPI NOR)
- 4x 10/100 Mbps Ethernet, with passive PoE support on LAN1
- 2T2R 2,4 GHz (AR9344)
- built-in 3G module (example: Quectel EC-25EU)
- internal microSD slot (spi-mmc, buggy)
- RS232 on D-Sub9 port (Cypress ACM via USB, /dev/ttyACM0)
- RS422/RS485 (AR934x high speed UART, /dev/ttyATH1)
- analog 0-24V input (MCP3221)
- various digital inputs and outputs incl. a relay
- 12x LED (4 are driven by AR9344, 7 by 74HC595)
- 2x miniSIM slot (can be swapped via GPIO)
- 2x RP-SMA/F (Wi-Fi), 3x SMA/F (2x WWAN, GPS)
- 1x button (reset)
- DC jack for main power input (9-30 V)
- debugging UART available on PCB edge connector

Serial console (/dev/ttyS0) pinout:

- RX: pin1 (square) on top side of the main PCB (AR9344 is on top)
- TX: pin1 (square) on bottom side

Flash instruction:

Vendor firmware is based on OpenWrt CC release. Use the "factory" image
directly in GUI (make sure to uncheck "keep settings") or in U-Boot web
based recovery. To avoid any problems, make sure to first update vendor
firmware to latest version - "factory" image was successfully tested on
device running "RUT9XX_R_00.06.051" firmware and U-Boot "3.0.2".

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
---
 .../ath79/dts/ar9344_teltonika_rut955.dts     | 345 ++++++++++++++++++
 .../generic/base-files/etc/board.d/02_network |   5 +
 .../base-files/etc/board.d/03_gpio_switches   |   8 +
 target/linux/ath79/image/generic.mk           |  38 ++
 4 files changed, 396 insertions(+)
 create mode 100644 target/linux/ath79/dts/ar9344_teltonika_rut955.dts

Comments

Adrian Schmutzler Feb. 5, 2020, 5:23 p.m. UTC | #1
Hi,

> +	leds {
> +		compatible = "gpio-leds";
> +
> +		signal0 {
> +			label = "rut955:green:signal1";

Still signalX not matching here.

> +			gpios = <&gpio_ext 0 GPIO_ACTIVE_HIGH>;
> +		};

[...]

> +
> +		led_system_green: system_green {
> +			label = "rut955:green:system";
> +			gpios = <&gpio_ext 6 GPIO_ACTIVE_HIGH>;
> +			default-state = "on";
> +			linux,default-trigger = "phy0tpt";

tpt trigger to the system LED? Don't think that would be really helpful, maybe
one can use one of the signal leds for that?

> +		};
> +	};
> +

[...]

> +define Build/teltonika-fw-fake-checksum
> +	# Teltonika U-Boot web based firmware upgrade/recovery routine
> compares
> +	# 16 bytes from md5sum1[16] field in TP-Link v1 header (offset: 76 bytes
> +	# from begin of the firmware file) with 16 bytes stored just before
> +	# 0xdeadc0de marker. Values are only compared, MD5 sum is not
> verified.
> +	let \
> +		offs="$$(stat -c%s $@) - 20"; \
> +		dd if=$@ bs=1 count=16 skip=76 |\
> +		dd of=$@ bs=1 count=16 seek=$$offs conv=notrunc

Maybe change to bs=16 count=1 for both? (Don't forget seek_bytes/skip_bytes
flags in this case.)

Best

Adrian
Daniel Golle Feb. 5, 2020, 5:49 p.m. UTC | #2
On Wed, Feb 05, 2020 at 06:23:46PM +0100, Adrian Schmutzler wrote:
> Hi,
> 
> > +	leds {
> > +		compatible = "gpio-leds";
> > +
> > +		signal0 {
> > +			label = "rut955:green:signal1";
> 
> Still signalX not matching here.

Ah, I'll fix that.

> 
> > +			gpios = <&gpio_ext 0 GPIO_ACTIVE_HIGH>;
> > +		};
> 
> [...]
> 
> > +
> > +		led_system_green: system_green {
> > +			label = "rut955:green:system";
> > +			gpios = <&gpio_ext 6 GPIO_ACTIVE_HIGH>;
> > +			default-state = "on";
> > +			linux,default-trigger = "phy0tpt";
> 
> tpt trigger to the system LED? Don't think that would be really helpful, maybe
> one can use one of the signal leds for that?

This is how the vendor firmware handles it as well and there is a
Wifi-symbol next to that LED. The signal bars are supposedly intended
for the GSM/WCDMA/LTE WWAN signal strength.

> 
> > +		};
> > +	};
> > +
> 
> [...]
> 
> > +define Build/teltonika-fw-fake-checksum
> > +	# Teltonika U-Boot web based firmware upgrade/recovery routine
> > compares
> > +	# 16 bytes from md5sum1[16] field in TP-Link v1 header (offset: 76 bytes
> > +	# from begin of the firmware file) with 16 bytes stored just before
> > +	# 0xdeadc0de marker. Values are only compared, MD5 sum is not
> > verified.
> > +	let \
> > +		offs="$$(stat -c%s $@) - 20"; \
> > +		dd if=$@ bs=1 count=16 skip=76 |\
> > +		dd of=$@ bs=1 count=16 seek=$$offs conv=notrunc
> 
> Maybe change to bs=16 count=1 for both? (Don't forget seek_bytes/skip_bytes
> flags in this case.)
> 
> Best
> 
> Adrian
> 
>
Adrian Schmutzler Feb. 6, 2020, 10:24 a.m. UTC | #3
Hi,

> > > +
> > > +		led_system_green: system_green {
> > > +			label = "rut955:green:system";
> > > +			gpios = <&gpio_ext 6 GPIO_ACTIVE_HIGH>;
> > > +			default-state = "on";
> > > +			linux,default-trigger = "phy0tpt";
> >
> > tpt trigger to the system LED? Don't think that would be really helpful,
maybe
> > one can use one of the signal leds for that?
> 
> This is how the vendor firmware handles it as well and there is a
> Wifi-symbol next to that LED. The signal bars are supposedly intended
> for the GSM/WCDMA/LTE WWAN signal strength.
> 

Okay. But the name/label should somehow indicate that, so it doesn't look like a
mistake.

If there is a WiFi symbol next to the LED, I'd actually consider renaming it to
"wifi" or "wlan", though.

Best

Adrian
Simonas Tamošaitis Feb. 6, 2020, 10:45 a.m. UTC | #4
Hello,

On 2/6/20 12:24 PM, Adrian Schmutzler wrote:
> Hi,
>
>>>> +
>>>> +		led_system_green: system_green {
>>>> +			label = "rut955:green:system";
>>>> +			gpios = <&gpio_ext 6 GPIO_ACTIVE_HIGH>;
>>>> +			default-state = "on";
>>>> +			linux,default-trigger = "phy0tpt";
>>> tpt trigger to the system LED? Don't think that would be really helpful,
> maybe
>>> one can use one of the signal leds for that?
>> This is how the vendor firmware handles it as well and there is a
>> Wifi-symbol next to that LED. The signal bars are supposedly intended
>> for the GSM/WCDMA/LTE WWAN signal strength.
>>
> Okay. But the name/label should somehow indicate that, so it doesn't look like a
> mistake.
>
> If there is a WiFi symbol next to the LED, I'd actually consider renaming it to
> "wifi" or "wlan", though.
>
> Best
>
> Adrian
It's not wifi led. Its mobile connection type indicator 2G/3G/4G. RUT955 
do not have leds for wifi.
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Chuanhong Guo Feb. 7, 2020, 2:35 a.m. UTC | #5
Hi!

some minor comments below:
On Thu, Feb 6, 2020 at 1:07 AM Daniel Golle <daniel@makrotopia.org> wrote:
...
> +
> +       gpio_ext_spi {
> +               compatible = "spi-gpio";
> +               pinctrl-names = "default";
> +               pinctrl-0 = <&pmx_led_spi_gpio>;
> +               #address-cells = <1>;
> +               #size-cells = <0>;
> +
> +               sck-gpios = <&gpio 4 GPIO_ACTIVE_HIGH>;     // 74HC595 SRCLK (Serial Clock)
> +               mosi-gpios = <&gpio 12 GPIO_ACTIVE_HIGH>;   // 74HC595 SER (Serial)
> +               cs-gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;     // 74HC595 RCLK (Register Clock)
> +               num-chipselects = <1>;
> +
> +               gpio_ext: gpio_ext@0 {
> +                       compatible = "fairchild,74hc595";
> +                       reg = <0>;
> +                       gpio-controller;
> +                       #gpio-cells = <2>;
> +                       registers-number = <2>;
> +                       spi-max-frequency = <10000000>;
> +                       gpio-line-names = "led_signal_bar1", "led_signal_bar2", "led_signal_bar3", "led_signal_bar4",
> +                               "led_signal_bar5", "led_status_red", "led_status_green", "sim_sel",
> +                               "DOUT1", "DOUT2", "modem_vbus", "modem_rst",
> +                               "DOUT3", "RS485_R", "SDCS", "HWRST";
> +               };
> +       };

Would you mind to test whether it's possible to move this 74hc595
under hardware spi instead? I believe using hw spi has a tiny bit less
cpu overhead than gpio spi.
It's possible to hook one output signal to multiple gpio pins
simultaneously on ath79. Try setting gpio 4/12/20 to clk/mosi/cs2 in
gpio function register respectively, move gpio_ext node under spi and
change reg to 2.

> +
> +       leds {
> +               compatible = "gpio-leds";
> +
> +               signal0 {
> +                       label = "rut955:green:signal1";
> +                       gpios = <&gpio_ext 0 GPIO_ACTIVE_HIGH>;
> +               };
...
> +&spi {
> +       status = "okay";
> +
> +       cs-gpios = <0>, <0>;

I pushed a spi driver replacement yesterday and we don't need this
cs-gpios to fix num_chipselect in driver now :)

> +       num-cs = <2>;
> +       pinctrl-names = "default";
> +       pinctrl-0 = <&jtag_disable_pins>, <&pmx_spi_cs1>;
> +
...
> +&eth1 {
> +       status = "okay";
> +
> +       mtd-mac-address = <&config 0x0>;
> +
> +       gmac-config {
> +               device = <&gmac>;
> +       };

This gmac-config can be removed if you don't need it.

> +};
> +
> +&builtin_switch {
> +       pinctrl-names = "default";
> +       pinctrl-0 = <&pmx_leds_switch>;
> +};
...
> +  IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs |\
> +       pad-rootfs | teltonika-fw-fake-checksum | append-string master |\
> +       append-md5sum-bin | check-size $$$$(IMAGE_SIZE)
> +  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\

Do we need this "pad-to $$$$(BLOCKSIZE)" in
factory.bin/sysupgrade.bin? kernel/rootfs can be split anywhere and we
may squeeze out several kilobytes by removing this image padding.
Also I'm wondering whether "tplink-v1-image sysupgrade" recipe could
replace "append-kernel | append-rootfs | pad-rootfs" here.
("tplink-v1-header" needs to be removed from KERNEL or there'll be
duplicated headers)

> +       append-rootfs | pad-rootfs | append-metadata |\
> +       check-size $$$$(IMAGE_SIZE)
> +endef
> +TARGET_DEVICES += teltonika_rut955
> +
>  define Device/trendnet_tew-823dru
>    SOC := qca9558
>    DEVICE_VENDOR := Trendnet
> --

Regards,
Chuanhong Guo
Daniel Golle Feb. 11, 2020, 1:40 p.m. UTC | #6
Hi Chuanhong,

thanks for the review and suggestions!

On Fri, Feb 07, 2020 at 10:35:08AM +0800, Chuanhong Guo wrote:
> Hi!
> 
> some minor comments below:
> On Thu, Feb 6, 2020 at 1:07 AM Daniel Golle <daniel@makrotopia.org> wrote:
> ...
> > +
> > +       gpio_ext_spi {
> > +               compatible = "spi-gpio";
> > +               pinctrl-names = "default";
> > +               pinctrl-0 = <&pmx_led_spi_gpio>;
> > +               #address-cells = <1>;
> > +               #size-cells = <0>;
> > +
> > +               sck-gpios = <&gpio 4 GPIO_ACTIVE_HIGH>;     // 74HC595 SRCLK (Serial Clock)
> > +               mosi-gpios = <&gpio 12 GPIO_ACTIVE_HIGH>;   // 74HC595 SER (Serial)
> > +               cs-gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;     // 74HC595 RCLK (Register Clock)
> > +               num-chipselects = <1>;
> > +
> > +               gpio_ext: gpio_ext@0 {
> > +                       compatible = "fairchild,74hc595";
> > +                       reg = <0>;
> > +                       gpio-controller;
> > +                       #gpio-cells = <2>;
> > +                       registers-number = <2>;
> > +                       spi-max-frequency = <10000000>;
> > +                       gpio-line-names = "led_signal_bar1", "led_signal_bar2", "led_signal_bar3", "led_signal_bar4",
> > +                               "led_signal_bar5", "led_status_red", "led_status_green", "sim_sel",
> > +                               "DOUT1", "DOUT2", "modem_vbus", "modem_rst",
> > +                               "DOUT3", "RS485_R", "SDCS", "HWRST";
> > +               };
> > +       };
> 
> Would you mind to test whether it's possible to move this 74hc595
> under hardware spi instead? I believe using hw spi has a tiny bit less
> cpu overhead than gpio spi.
> It's possible to hook one output signal to multiple gpio pins
> simultaneously on ath79. Try setting gpio 4/12/20 to clk/mosi/cs2 in
> gpio function register respectively, move gpio_ext node under spi and
> change reg to 2.

I've tried that and it works just as good as it does with spi-gpio.
Now I don't know what's better: Sacrificing bus-access time on the
SPI bus of the NOR flash (CS0) and microSD-card (CS1) by adding the
HC959s (CS2) there in the way you described **or** having an
independent bit-banged bus just for the SPI-connected HC595 driven
LEDs. It's trading CPU-time for SPI-bus-access time for a rather
neglectable load, so I'm also biased to go with sacrificing SPI bus-
access time, ie. using CS2 and pinmux in the way you suggested and
I've just successfully tested.

> 
> > +
> > +       leds {
> > +               compatible = "gpio-leds";
> > +
> > +               signal0 {
> > +                       label = "rut955:green:signal1";
> > +                       gpios = <&gpio_ext 0 GPIO_ACTIVE_HIGH>;
> > +               };
> ...
> > +&spi {
> > +       status = "okay";
> > +
> > +       cs-gpios = <0>, <0>;
> 
> I pushed a spi driver replacement yesterday and we don't need this
> cs-gpios to fix num_chipselect in driver now :)

Ack. removed.

> 
> > +       num-cs = <2>;
> > +       pinctrl-names = "default";
> > +       pinctrl-0 = <&jtag_disable_pins>, <&pmx_spi_cs1>;
> > +
> ...
> > +&eth1 {
> > +       status = "okay";
> > +
> > +       mtd-mac-address = <&config 0x0>;
> > +
> > +       gmac-config {
> > +               device = <&gmac>;
> > +       };
> 
> This gmac-config can be removed if you don't need it.

Ack. removed.

> 
> > +};
> > +
> > +&builtin_switch {
> > +       pinctrl-names = "default";
> > +       pinctrl-0 = <&pmx_leds_switch>;
> > +};
> ...
> > +  IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs |\
> > +       pad-rootfs | teltonika-fw-fake-checksum | append-string master |\
> > +       append-md5sum-bin | check-size $$$$(IMAGE_SIZE)
> > +  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
> 
> Do we need this "pad-to $$$$(BLOCKSIZE)" in
> factory.bin/sysupgrade.bin? kernel/rootfs can be split anywhere and we
> may squeeze out several kilobytes by removing this image padding.
> Also I'm wondering whether "tplink-v1-image sysupgrade" recipe could
> replace "append-kernel | append-rootfs | pad-rootfs" here.
> ("tplink-v1-header" needs to be removed from KERNEL or there'll be
> duplicated headers)

I've copied the image generation code from ar71xx/generic/rut900 which
shares the same base-board and flash layout. As pepe2k was suggesting
he would add RUT900 to ath79 after support for RUT955 got merged, I
leave it up to him so also re-organize the image generation code
because he is also the author of the original ar71xx code and I will
no longer have physical access to the device to play around with from
next week on... Hence I'd just leave it like it is for now.


> 
> > +       append-rootfs | pad-rootfs | append-metadata |\
> > +       check-size $$$$(IMAGE_SIZE)
> > +endef
> > +TARGET_DEVICES += teltonika_rut955
> > +
> >  define Device/trendnet_tew-823dru
> >    SOC := qca9558
> >    DEVICE_VENDOR := Trendnet
> > --
> 
> Regards,
> Chuanhong Guo
diff mbox series

Patch

diff --git a/target/linux/ath79/dts/ar9344_teltonika_rut955.dts b/target/linux/ath79/dts/ar9344_teltonika_rut955.dts
new file mode 100644
index 0000000000..382b2fc950
--- /dev/null
+++ b/target/linux/ath79/dts/ar9344_teltonika_rut955.dts
@@ -0,0 +1,345 @@ 
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9344.dtsi"
+
+/ {
+	model = "Teltonika RUT955";
+	compatible = "teltonika,rut955", "qca,ar9344";
+
+	aliases {
+		serial0 = &uart;
+		serial1 = &hs_uart;
+		led-boot = &led_system_green;
+		led-failsafe = &led_system_red;
+		led-running = &led_system_green;
+		led-upgrade = &led_system_red;
+		label-mac-device = &eth1;
+	};
+
+	i2c {
+		compatible = "i2c-gpio";
+		scl-gpios = <&gpio 16 (GPIO_ACTIVE_HIGH|GPIO_OPEN_DRAIN)>;
+		sda-gpios = <&gpio 17 (GPIO_ACTIVE_HIGH|GPIO_OPEN_DRAIN)>;
+		#address-cells = <1>;
+		#size-cells = <0>;
+
+		hwmon@4d {
+			compatible = "microchip,mcp3221";
+			reg = <0x4d>;
+		};
+	};
+
+	gpio_ext_spi {
+		compatible = "spi-gpio";
+		pinctrl-names = "default";
+		pinctrl-0 = <&pmx_led_spi_gpio>;
+		#address-cells = <1>;
+		#size-cells = <0>;
+
+		sck-gpios = <&gpio 4 GPIO_ACTIVE_HIGH>;     // 74HC595 SRCLK (Serial Clock)
+		mosi-gpios = <&gpio 12 GPIO_ACTIVE_HIGH>;   // 74HC595 SER (Serial)
+		cs-gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;     // 74HC595 RCLK (Register Clock)
+		num-chipselects = <1>;
+
+		gpio_ext: gpio_ext@0 {
+			compatible = "fairchild,74hc595";
+			reg = <0>;
+			gpio-controller;
+			#gpio-cells = <2>;
+			registers-number = <2>;
+			spi-max-frequency = <10000000>;
+			gpio-line-names = "led_signal_bar1", "led_signal_bar2", "led_signal_bar3", "led_signal_bar4",
+				"led_signal_bar5", "led_status_red", "led_status_green", "sim_sel",
+				"DOUT1", "DOUT2", "modem_vbus", "modem_rst",
+				"DOUT3", "RS485_R", "SDCS", "HWRST";
+		};
+	};
+
+	leds {
+		compatible = "gpio-leds";
+
+		signal0 {
+			label = "rut955:green:signal1";
+			gpios = <&gpio_ext 0 GPIO_ACTIVE_HIGH>;
+		};
+
+		signal1 {
+			label = "rut955:green:signal2";
+			gpios = <&gpio_ext 1 GPIO_ACTIVE_HIGH>;
+		};
+
+		signal2 {
+			label = "rut955:green:signal3";
+			gpios = <&gpio_ext 2 GPIO_ACTIVE_HIGH>;
+		};
+
+		signal3 {
+			label = "rut955:green:signal4";
+			gpios = <&gpio_ext 3 GPIO_ACTIVE_HIGH>;
+		};
+
+		signal4 {
+			label = "rut955:green:signal5";
+			gpios = <&gpio_ext 4 GPIO_ACTIVE_HIGH>;
+		};
+
+		led_system_red: system_red {
+			label = "rut955:red:system";
+			gpios = <&gpio_ext 5 GPIO_ACTIVE_HIGH>;
+		};
+
+		led_system_green: system_green {
+			label = "rut955:green:system";
+			gpios = <&gpio_ext 6 GPIO_ACTIVE_HIGH>;
+			default-state = "on";
+			linux,default-trigger = "phy0tpt";
+		};
+	};
+
+	keys {
+		compatible = "gpio-keys";
+
+		reset {
+			label = "reset";
+			linux,code = <KEY_RESTART>;
+			gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+			debounce-interval = <60>;
+		};
+	};
+};
+
+&gpio {
+	gpio-line-names = "RS485_D", "wan_led", "DIN3", "mmc_cs",
+		"leds_sck", "", "", "",
+		"", "", "", "",
+		"leds_mosi", "lan2_led", "lan1_led", "",
+		"i2c_scl", "i2c_sda", "", "DIN2",
+		"leds_cs", "DIN1", "lan3_led", "",
+		"", "", "", "",
+		"", "", "", "";
+
+	gpio_mmc_cs {
+		gpio-hog;
+		gpios = <3 GPIO_ACTIVE_HIGH>;
+		output-high;
+		line-name = "rut955:mmc:cs";
+	};
+
+	gpio_uart1_td {
+		gpio-hog;
+		gpios = <18 GPIO_ACTIVE_HIGH>;
+		output-high;
+		line-name = "rut955:uart1:td";
+	};
+
+	gpio_uart1_rd {
+		gpio-hog;
+		gpios = <11 GPIO_ACTIVE_LOW>;
+		input;
+		line-name = "rut955:uart1:rd";
+	};
+
+	gpio_switch_led1 {
+		gpio-hog;
+		gpios = <1 GPIO_ACTIVE_HIGH>;
+		output-high;
+		line-name = "rut955:led:wan";
+	};
+
+	gpio_switch_led2 {
+		gpio-hog;
+		gpios = <13 GPIO_ACTIVE_HIGH>;
+		output-high;
+		line-name = "rut955:led:lan2";
+	};
+
+	gpio_switch_led3 {
+		gpio-hog;
+		gpios = <14 GPIO_ACTIVE_HIGH>;
+		output-high;
+		line-name = "rut955:led:lan1";
+	};
+
+	gpio_switch_led4 {
+		gpio-hog;
+		gpios = <22 GPIO_ACTIVE_HIGH>;
+		output-high;
+		line-name = "rut955:led:lan3";
+	};
+};
+
+&ref {
+	clock-frequency = <40000000>;
+};
+
+&uart {
+	status = "okay";
+};
+
+&hs_uart {
+	status = "okay";
+
+	pinctrl-names = "default";
+	pinctrl-0 = <&pmx_uart2>;
+
+	rts-gpios = <&gpio_ext 13 GPIO_ACTIVE_HIGH>;
+	dtr-gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+
+	linux,rs485-enabled-at-boot-time;
+};
+
+&spi {
+	status = "okay";
+
+	cs-gpios = <0>, <0>;
+	num-cs = <2>;
+	pinctrl-names = "default";
+	pinctrl-0 = <&jtag_disable_pins>, <&pmx_spi_cs1>;
+
+	flash@0 {
+		compatible = "jedec,spi-nor";
+		reg = <0>;
+		spi-max-frequency = <25000000>;
+
+		partitions {
+			compatible = "fixed-partitions";
+			#address-cells = <1>;
+			#size-cells = <1>;
+
+			partition@0 {
+				label = "u-boot";
+				reg = <0x0 0x20000>;
+				read-only;
+			};
+
+			config: partition@20000 {
+				label = "config";
+				reg = <0x20000 0x10000>;
+				read-only;
+			};
+
+			art: partition@30000 {
+				label = "art";
+				reg = <0x30000 0x10000>;
+				read-only;
+			};
+
+			partition@40000 {
+				label = "firmware";
+				reg = <0x40000 0xf30000>;
+				compatible = "tplink,firmware";
+			};
+
+			partition@f70000 {
+				label = "event-log";
+				reg = <0xf70000 0x90000>;
+				read-only;
+			};
+		};
+	};
+
+	microsd@1 {
+		compatible = "mmc-spi-slot";
+		spi-max-frequency = <25000000>;
+		reg = <1>;
+		voltage-ranges = <3200 3400>;
+		broken-cd;
+		status = "disabled";
+	};
+};
+
+&usb {
+	#address-cells = <1>;
+	#size-cells = <0>;
+	status = "okay";
+
+	port@1 {
+		#address-cells = <1>;
+		#size-cells = <0>;
+		reg = <1>;
+
+		port@1 {
+			compatible = "usb-a-connector";
+			label = "USB2.0 port";
+			reg = <1>;
+		};
+
+		port@3 {
+			label = "internal Cypress CDC-ACM serial";
+			reg = <3>;
+		};
+
+		port@4 {
+			label = "internal Quectel EC-25 modem";
+			reg = <4>;
+		};
+	};
+};
+
+&usb_phy {
+	status = "okay";
+};
+
+&wmac {
+	status = "okay";
+
+	mtd-cal-data = <&art 0x1000>;
+	mtd-mac-address = <&config 0x0>;
+	mtd-mac-address-increment = <2>;
+};
+
+&eth0 {
+	status = "okay";
+
+	phy-handle = <&swphy4>;
+
+	mtd-mac-address = <&config 0x0>;
+	mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+	status = "okay";
+
+	mtd-mac-address = <&config 0x0>;
+
+	gmac-config {
+		device = <&gmac>;
+	};
+};
+
+&builtin_switch {
+	pinctrl-names = "default";
+	pinctrl-0 = <&pmx_leds_switch>;
+};
+
+&pinmux {
+	pmx_spi_cs1: pinmux_spi_cs1 {
+		// SPI_CS1 on GPIO 3
+		pinctrl-single,bits = <0x0 0x07000000 0xff000000>;
+	};
+
+	pmx_led_spi_gpio: pinmux_led_spi_gpio {
+		// spi-gpio for LEDs on GPIO 4, GPIO 12 and GPIO 20
+		pinctrl-single,bits = <0x4 0x0 0xff>,
+					<0xc 0x0 0xff>,
+					<0x14 0x0 0xff>;
+	};
+
+	pmx_leds_switch: pinmux_leds_switch {
+		// switch port LEDs on GPIO 1, GPIO 13, GPIO 14 and GPIO 22
+		pinctrl-single,bits =  <0x0 0x00002d00 0x0000ff00>,
+					<0xc 0x002c2b00 0x00ffff00>,
+					<0x14 0x002a0000 0x00ff0000>;
+	};
+
+	pmx_uart2: pinmux_uart2 {
+		// UART1_DTR on GPIO 0, UART1_RD on GPIO 11, UART1_TD on GPIO 18
+		pinctrl-single,bits = <0x0 0x0 0xff>,
+				<0x10 0x4f000000 0xff000000>,
+				<0x3c 0x000b0000 0x00ff0000>;
+	};
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index a3fcf35715..6ba782f89b 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -217,6 +217,11 @@  ath79_setup_interfaces()
 		ucidef_add_switch "switch0" \
 			"0@eth0" "1:lan" "2:lan" "3:wan"
 		;;
+	teltonika,rut955)
+		ucidef_set_interface_wan "eth1"
+		ucidef_add_switch "switch0" \
+			"0@eth0" "2:lan:3" "3:lan:2" "4:lan:1"
+		;;
 	tplink,archer-a7-v5|\
 	tplink,archer-c6-v2|\
 	tplink,archer-c6-v2-us|\
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches b/target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches
index 967e2c7680..b5b46f16bf 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches
+++ b/target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches
@@ -38,6 +38,14 @@  dlink,dir-835-a1)
 librerouter,librerouter-v1)
 	ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "1" "0"
 	;;
+teltonika,rut955)
+	ucidef_add_gpio_switch "sim_sel" "SIM select" "503" "1"
+	ucidef_add_gpio_switch "DOUT1" "DOUT1 (OC)" "504" "0"
+	ucidef_add_gpio_switch "DOUT2" "DOUT2 (Relay)" "505" "0"
+	ucidef_add_gpio_switch "modem_vbus" "Modem enable" "506" "1"
+	ucidef_add_gpio_switch "modem_rst" "Modem reset" "507" "0"
+	ucidef_add_gpio_switch "DOUT3" "DOUT3" "508" "0"
+	;;
 tplink,archer-c25-v1)
 	ucidef_add_gpio_switch "led_control" "LED control" "21" "0"
 	ucidef_add_gpio_switch "led_reset" "LED reset" "19" "1"
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 3c74b0f7d7..3447871385 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -36,6 +36,11 @@  define Build/addpattern
 	-mv "$@.new" "$@"
 endef
 
+define Build/append-md5sum-bin
+	$(STAGING_DIR_HOST)/bin/mkhash md5 $@ | sed 's/../\\\\x&/g' |\
+		xargs echo -ne >> $@
+endef
+
 define Build/cybertan-trx
 	@echo -n '' > $@-empty.bin
 	-$(STAGING_DIR_HOST)/bin/trx -o $@.new \
@@ -73,6 +78,17 @@  define Build/pisen_wmb001n-factory
   rm -rf "$@.tmp"
 endef
 
+define Build/teltonika-fw-fake-checksum
+	# Teltonika U-Boot web based firmware upgrade/recovery routine compares
+	# 16 bytes from md5sum1[16] field in TP-Link v1 header (offset: 76 bytes
+	# from begin of the firmware file) with 16 bytes stored just before
+	# 0xdeadc0de marker. Values are only compared, MD5 sum is not verified.
+	let \
+		offs="$$(stat -c%s $@) - 20"; \
+		dd if=$@ bs=1 count=16 skip=76 |\
+		dd of=$@ bs=1 count=16 seek=$$offs conv=notrunc
+endef
+
 define Device/seama
   KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
   KERNEL_INITRAMFS := $$(KERNEL) | seama
@@ -1054,6 +1070,28 @@  define Device/sitecom_wlr-7100
 endef
 TARGET_DEVICES += sitecom_wlr-7100
 
+define Device/teltonika_rut955
+  SOC := ar9344
+  DEVICE_VENDOR := Teltonika
+  DEVICE_MODEL := RUT955
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-acm kmod-usb-net-qmi-wwan \
+	kmod-usb-serial-option kmod-hwmon-mcp3021 uqmi -uboot-envtools
+  IMAGE_SIZE := 15552k
+  TPLINK_HWID := 0x35000001
+  TPLINK_HWREV := 0x1
+  TPLINK_HEADER_VERSION := 1
+  KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
+  IMAGES += factory.bin
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs |\
+	pad-rootfs | teltonika-fw-fake-checksum | append-string master |\
+	append-md5sum-bin | check-size $$$$(IMAGE_SIZE)
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+	append-rootfs | pad-rootfs | append-metadata |\
+	check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += teltonika_rut955
+
 define Device/trendnet_tew-823dru
   SOC := qca9558
   DEVICE_VENDOR := Trendnet