diff mbox series

[OpenWrt-Devel,2/2] mvebu: use SOC to derive DEVICE_DTS

Message ID 20200118012115.46148-2-freifunk@adrianschmutzler.de
State Accepted
Delegated to: Adrian Schmutzler
Headers show
Series [OpenWrt-Devel,1/2] mvebu: move subtarget image Makefile switch to parent Makefile | expand

Commit Message

Adrian Schmutzler Jan. 18, 2020, 1:21 a.m. UTC
This introduces the SOC variable to mvebu target to derive some of
the DEVICE_DTS variables based on the SOC prefix and the device
definition name.

Since DTS names and compatible are inconsistent also in the kernel
for this target, the scheme cannot be applied to all devices, though.

While at it, change the DTS name of the armada-3720-udpu to lower-case,
which is the common practice for DTS file names.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 .../{armada-3720-uDPU.dts => armada-3720-udpu.dts}     |  0
 target/linux/mvebu/image/Makefile                      |  1 +
 target/linux/mvebu/image/cortex-a53.mk                 | 10 +++++-----
 target/linux/mvebu/image/cortex-a9.mk                  |  6 +++---
 .../patches-4.19/530-add_armada-3820-uDPU-dts.patch    |  2 +-
 5 files changed, 10 insertions(+), 9 deletions(-)
 rename target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/{armada-3720-uDPU.dts => armada-3720-udpu.dts} (100%)

Comments

Tomasz Maciej Nowak Jan. 20, 2020, 3:07 p.m. UTC | #1
W dniu 18.01.2020 o 02:21, Adrian Schmutzler pisze:
> This introduces the SOC variable to mvebu target to derive some of
> the DEVICE_DTS variables based on the SOC prefix and the device
> definition name.
> 
> Since DTS names and compatible are inconsistent also in the kernel
> for this target, the scheme cannot be applied to all devices, though.
> 
> While at it, change the DTS name of the armada-3720-udpu to lower-case,
> which is the common practice for DTS file names.

Well, this (uDPU change) will be reverted anyway, when kernel 5.4 will be
introduced, since in upstream it's upper case. So it makes no sense.

For the rest
Acked-by: Tomasz Maciej Nowak <tomek_n@o2.pl>

> 
> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
> ---
>  .../{armada-3720-uDPU.dts => armada-3720-udpu.dts}     |  0
>  target/linux/mvebu/image/Makefile                      |  1 +
>  target/linux/mvebu/image/cortex-a53.mk                 | 10 +++++-----
>  target/linux/mvebu/image/cortex-a9.mk                  |  6 +++---
>  .../patches-4.19/530-add_armada-3820-uDPU-dts.patch    |  2 +-
>  5 files changed, 10 insertions(+), 9 deletions(-)
>  rename target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/{armada-3720-uDPU.dts => armada-3720-udpu.dts} (100%)
> 
> diff --git a/target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-uDPU.dts b/target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-udpu.dts
> similarity index 100%
> rename from target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-uDPU.dts
> rename to target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-udpu.dts
> diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
> index 6dd7bde7ae..c08b113b36 100644
> --- a/target/linux/mvebu/image/Makefile
> +++ b/target/linux/mvebu/image/Makefile
> @@ -77,6 +77,7 @@ endef
>  
>  define Device/Default
>    PROFILES := Default
> +  DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
>    BOARD_NAME = $$(DEVICE_DTS)
>    KERNEL_NAME := zImage
>    KERNEL := kernel-bin | append-dtb | uImage none
> diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
> index e58a3c42b9..c9d06ddbad 100644
> --- a/target/linux/mvebu/image/cortex-a53.mk
> +++ b/target/linux/mvebu/image/cortex-a53.mk
> @@ -6,7 +6,7 @@ define Device/globalscale_espressobin
>    DEVICE_ALT0_VENDOR := Marvell
>    DEVICE_ALT0_MODEL := Armada 3700 Community Board
>    DEVICE_ALT0_VARIANT := Non-eMMC
> -  DEVICE_DTS := armada-3720-espressobin
> +  SOC := armada-3720
>  endef
>  TARGET_DEVICES += globalscale_espressobin
>  
> @@ -18,7 +18,7 @@ define Device/globalscale_espressobin-emmc
>    DEVICE_ALT0_VENDOR := Marvell
>    DEVICE_ALT0_MODEL := Armada 3700 Community Board
>    DEVICE_ALT0_VARIANT := eMMC
> -  DEVICE_DTS := armada-3720-espressobin-emmc
> +  SOC := armada-3720
>  endef
>  TARGET_DEVICES += globalscale_espressobin-emmc
>  
> @@ -30,7 +30,7 @@ define Device/globalscale_espressobin-v7
>    DEVICE_ALT0_VENDOR := Marvell
>    DEVICE_ALT0_MODEL := Armada 3700 Community Board
>    DEVICE_ALT0_VARIANT := V7 Non-eMMC
> -  DEVICE_DTS := armada-3720-espressobin-v7
> +  SOC := armada-3720
>  endef
>  TARGET_DEVICES += globalscale_espressobin-v7
>  
> @@ -42,7 +42,7 @@ define Device/globalscale_espressobin-v7-emmc
>    DEVICE_ALT0_VENDOR := Marvell
>    DEVICE_ALT0_MODEL := Armada 3700 Community Board
>    DEVICE_ALT0_VARIANT := V7 eMMC
> -  DEVICE_DTS := armada-3720-espressobin-v7-emmc
> +  SOC := armada-3720
>  endef
>  TARGET_DEVICES += globalscale_espressobin-v7-emmc
>  
> @@ -58,7 +58,7 @@ define Device/methode_udpu
>    $(call Device/Default-arm64)
>    DEVICE_VENDOR := Methode
>    DEVICE_MODEL := micro-DPU (uDPU)
> -  DEVICE_DTS := armada-3720-uDPU
> +  SOC := armada-3720
>    KERNEL_LOADADDR := 0x00080000
>    KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
>    KERNEL_INITRAMFS_SUFFIX := .itb
> diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
> index 389082e426..79253049c7 100644
> --- a/target/linux/mvebu/image/cortex-a9.mk
> +++ b/target/linux/mvebu/image/cortex-a9.mk
> @@ -93,7 +93,7 @@ define Device/plathome_openblocks-ax3-4
>    DEVICE_VENDOR := Plat'Home
>    DEVICE_MODEL := OpenBlocks AX3
>    DEVICE_VARIANT := 4 ports
> -  DEVICE_DTS := armada-xp-openblocks-ax3-4
> +  SOC := armada-xp
>    SUPPORTED_DEVICES += openblocks-ax3-4
>    BLOCKSIZE := 128k
>    PAGESIZE := 1
> @@ -193,7 +193,7 @@ define Device/globalscale_mirabox
>    $(Device/NAND-512K)
>    DEVICE_VENDOR := Globalscale
>    DEVICE_MODEL := Mirabox
> -  DEVICE_DTS := armada-370-mirabox
> +  SOC := armada-370
>    SUPPORTED_DEVICES += mirabox
>  endef
>  TARGET_DEVICES += globalscale_mirabox
> @@ -212,7 +212,7 @@ define Device/cznic_turris-omnia
>    IMAGE/$$(IMAGE_PREFIX)-sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
>    IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip
>    IMAGE_NAME = $$(2)
> -  DEVICE_DTS := armada-385-turris-omnia
> +  SOC := armada-385
>    SUPPORTED_DEVICES += armada-385-turris-omnia
>  endef
>  TARGET_DEVICES += cznic_turris-omnia
> diff --git a/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-dts.patch b/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-dts.patch
> index bd4f0aef9a..635e141c69 100644
> --- a/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-dts.patch
> +++ b/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-dts.patch
> @@ -4,7 +4,7 @@
>   # Mvebu SoC Family
>   dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-db.dtb
>   dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-espressobin.dtb
> -+dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-uDPU.dtb
> ++dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-udpu.dtb
>   dtb-$(CONFIG_ARCH_MVEBU) += armada-7040-db.dtb
>   dtb-$(CONFIG_ARCH_MVEBU) += armada-8040-db.dtb
>   dtb-$(CONFIG_ARCH_MVEBU) += armada-8040-mcbin.dtb
>
Adrian Schmutzler Jan. 20, 2020, 3:26 p.m. UTC | #2
Hi,

> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org] On
> Behalf Of Tomasz Maciej Nowak
> Sent: Montag, 20. Januar 2020 16:08
> To: Adrian Schmutzler <freifunk@adrianschmutzler.de>; openwrt-
> devel@lists.openwrt.org
> Subject: Re: [OpenWrt-Devel] [PATCH 2/2] mvebu: use SOC to derive
> DEVICE_DTS
> 
> W dniu 18.01.2020 o 02:21, Adrian Schmutzler pisze:
> > This introduces the SOC variable to mvebu target to derive some of
> > the DEVICE_DTS variables based on the SOC prefix and the device
> > definition name.
> >
> > Since DTS names and compatible are inconsistent also in the kernel
> > for this target, the scheme cannot be applied to all devices, though.
> >
> > While at it, change the DTS name of the armada-3720-udpu to lower-case,
> > which is the common practice for DTS file names.
> 
> Well, this (uDPU change) will be reverted anyway, when kernel 5.4 will be
> introduced, since in upstream it's upper case. So it makes no sense.

thanks for the info, I actually didn't check kernel here.
Although I dislike this inconsistency and wonder how it got accepted into kernel, you're right that it makes no sense to have it lower-case in OpenWrt then and I will change it back.

Best

Adrian

> 
> For the rest
> Acked-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
> 
> >
> > Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
> > ---
> >  .../{armada-3720-uDPU.dts => armada-3720-udpu.dts}     |  0
> >  target/linux/mvebu/image/Makefile                      |  1 +
> >  target/linux/mvebu/image/cortex-a53.mk                 | 10 +++++-----
> >  target/linux/mvebu/image/cortex-a9.mk                  |  6 +++---
> >  .../patches-4.19/530-add_armada-3820-uDPU-dts.patch    |  2 +-
> >  5 files changed, 10 insertions(+), 9 deletions(-)
> >  rename target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/{armada-
> 3720-uDPU.dts => armada-3720-udpu.dts} (100%)
> >
> > diff --git a/target/linux/mvebu/files-
> 4.19/arch/arm64/boot/dts/marvell/armada-3720-uDPU.dts
> b/target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-
> udpu.dts
> > similarity index 100%
> > rename from target/linux/mvebu/files-
> 4.19/arch/arm64/boot/dts/marvell/armada-3720-uDPU.dts
> > rename to target/linux/mvebu/files-
> 4.19/arch/arm64/boot/dts/marvell/armada-3720-udpu.dts
> > diff --git a/target/linux/mvebu/image/Makefile
> b/target/linux/mvebu/image/Makefile
> > index 6dd7bde7ae..c08b113b36 100644
> > --- a/target/linux/mvebu/image/Makefile
> > +++ b/target/linux/mvebu/image/Makefile
> > @@ -77,6 +77,7 @@ endef
> >
> >  define Device/Default
> >    PROFILES := Default
> > +  DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
> >    BOARD_NAME = $$(DEVICE_DTS)
> >    KERNEL_NAME := zImage
> >    KERNEL := kernel-bin | append-dtb | uImage none
> > diff --git a/target/linux/mvebu/image/cortex-a53.mk
> b/target/linux/mvebu/image/cortex-a53.mk
> > index e58a3c42b9..c9d06ddbad 100644
> > --- a/target/linux/mvebu/image/cortex-a53.mk
> > +++ b/target/linux/mvebu/image/cortex-a53.mk
> > @@ -6,7 +6,7 @@ define Device/globalscale_espressobin
> >    DEVICE_ALT0_VENDOR := Marvell
> >    DEVICE_ALT0_MODEL := Armada 3700 Community Board
> >    DEVICE_ALT0_VARIANT := Non-eMMC
> > -  DEVICE_DTS := armada-3720-espressobin
> > +  SOC := armada-3720
> >  endef
> >  TARGET_DEVICES += globalscale_espressobin
> >
> > @@ -18,7 +18,7 @@ define Device/globalscale_espressobin-emmc
> >    DEVICE_ALT0_VENDOR := Marvell
> >    DEVICE_ALT0_MODEL := Armada 3700 Community Board
> >    DEVICE_ALT0_VARIANT := eMMC
> > -  DEVICE_DTS := armada-3720-espressobin-emmc
> > +  SOC := armada-3720
> >  endef
> >  TARGET_DEVICES += globalscale_espressobin-emmc
> >
> > @@ -30,7 +30,7 @@ define Device/globalscale_espressobin-v7
> >    DEVICE_ALT0_VENDOR := Marvell
> >    DEVICE_ALT0_MODEL := Armada 3700 Community Board
> >    DEVICE_ALT0_VARIANT := V7 Non-eMMC
> > -  DEVICE_DTS := armada-3720-espressobin-v7
> > +  SOC := armada-3720
> >  endef
> >  TARGET_DEVICES += globalscale_espressobin-v7
> >
> > @@ -42,7 +42,7 @@ define Device/globalscale_espressobin-v7-emmc
> >    DEVICE_ALT0_VENDOR := Marvell
> >    DEVICE_ALT0_MODEL := Armada 3700 Community Board
> >    DEVICE_ALT0_VARIANT := V7 eMMC
> > -  DEVICE_DTS := armada-3720-espressobin-v7-emmc
> > +  SOC := armada-3720
> >  endef
> >  TARGET_DEVICES += globalscale_espressobin-v7-emmc
> >
> > @@ -58,7 +58,7 @@ define Device/methode_udpu
> >    $(call Device/Default-arm64)
> >    DEVICE_VENDOR := Methode
> >    DEVICE_MODEL := micro-DPU (uDPU)
> > -  DEVICE_DTS := armada-3720-uDPU
> > +  SOC := armada-3720
> >    KERNEL_LOADADDR := 0x00080000
> >    KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip
> $$(DTS_DIR)/$$(DEVICE_DTS).dtb
> >    KERNEL_INITRAMFS_SUFFIX := .itb
> > diff --git a/target/linux/mvebu/image/cortex-a9.mk
> b/target/linux/mvebu/image/cortex-a9.mk
> > index 389082e426..79253049c7 100644
> > --- a/target/linux/mvebu/image/cortex-a9.mk
> > +++ b/target/linux/mvebu/image/cortex-a9.mk
> > @@ -93,7 +93,7 @@ define Device/plathome_openblocks-ax3-4
> >    DEVICE_VENDOR := Plat'Home
> >    DEVICE_MODEL := OpenBlocks AX3
> >    DEVICE_VARIANT := 4 ports
> > -  DEVICE_DTS := armada-xp-openblocks-ax3-4
> > +  SOC := armada-xp
> >    SUPPORTED_DEVICES += openblocks-ax3-4
> >    BLOCKSIZE := 128k
> >    PAGESIZE := 1
> > @@ -193,7 +193,7 @@ define Device/globalscale_mirabox
> >    $(Device/NAND-512K)
> >    DEVICE_VENDOR := Globalscale
> >    DEVICE_MODEL := Mirabox
> > -  DEVICE_DTS := armada-370-mirabox
> > +  SOC := armada-370
> >    SUPPORTED_DEVICES += mirabox
> >  endef
> >  TARGET_DEVICES += globalscale_mirabox
> > @@ -212,7 +212,7 @@ define Device/cznic_turris-omnia
> >    IMAGE/$$(IMAGE_PREFIX)-sysupgrade.img.gz := boot-img | sdcard-img | gzip
> | append-metadata
> >    IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-
> initramfs | gzip
> >    IMAGE_NAME = $$(2)
> > -  DEVICE_DTS := armada-385-turris-omnia
> > +  SOC := armada-385
> >    SUPPORTED_DEVICES += armada-385-turris-omnia
> >  endef
> >  TARGET_DEVICES += cznic_turris-omnia
> > diff --git a/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-
> dts.patch b/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-
> dts.patch
> > index bd4f0aef9a..635e141c69 100644
> > --- a/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-dts.patch
> > +++ b/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-
> dts.patch
> > @@ -4,7 +4,7 @@
> >   # Mvebu SoC Family
> >   dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-db.dtb
> >   dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-espressobin.dtb
> > -+dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-uDPU.dtb
> > ++dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-udpu.dtb
> >   dtb-$(CONFIG_ARCH_MVEBU) += armada-7040-db.dtb
> >   dtb-$(CONFIG_ARCH_MVEBU) += armada-8040-db.dtb
> >   dtb-$(CONFIG_ARCH_MVEBU) += armada-8040-mcbin.dtb
> >
> 
> 
> --
> TMN
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-uDPU.dts b/target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-udpu.dts
similarity index 100%
rename from target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-uDPU.dts
rename to target/linux/mvebu/files-4.19/arch/arm64/boot/dts/marvell/armada-3720-udpu.dts
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 6dd7bde7ae..c08b113b36 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -77,6 +77,7 @@  endef
 
 define Device/Default
   PROFILES := Default
+  DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
   BOARD_NAME = $$(DEVICE_DTS)
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | append-dtb | uImage none
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
index e58a3c42b9..c9d06ddbad 100644
--- a/target/linux/mvebu/image/cortex-a53.mk
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -6,7 +6,7 @@  define Device/globalscale_espressobin
   DEVICE_ALT0_VENDOR := Marvell
   DEVICE_ALT0_MODEL := Armada 3700 Community Board
   DEVICE_ALT0_VARIANT := Non-eMMC
-  DEVICE_DTS := armada-3720-espressobin
+  SOC := armada-3720
 endef
 TARGET_DEVICES += globalscale_espressobin
 
@@ -18,7 +18,7 @@  define Device/globalscale_espressobin-emmc
   DEVICE_ALT0_VENDOR := Marvell
   DEVICE_ALT0_MODEL := Armada 3700 Community Board
   DEVICE_ALT0_VARIANT := eMMC
-  DEVICE_DTS := armada-3720-espressobin-emmc
+  SOC := armada-3720
 endef
 TARGET_DEVICES += globalscale_espressobin-emmc
 
@@ -30,7 +30,7 @@  define Device/globalscale_espressobin-v7
   DEVICE_ALT0_VENDOR := Marvell
   DEVICE_ALT0_MODEL := Armada 3700 Community Board
   DEVICE_ALT0_VARIANT := V7 Non-eMMC
-  DEVICE_DTS := armada-3720-espressobin-v7
+  SOC := armada-3720
 endef
 TARGET_DEVICES += globalscale_espressobin-v7
 
@@ -42,7 +42,7 @@  define Device/globalscale_espressobin-v7-emmc
   DEVICE_ALT0_VENDOR := Marvell
   DEVICE_ALT0_MODEL := Armada 3700 Community Board
   DEVICE_ALT0_VARIANT := V7 eMMC
-  DEVICE_DTS := armada-3720-espressobin-v7-emmc
+  SOC := armada-3720
 endef
 TARGET_DEVICES += globalscale_espressobin-v7-emmc
 
@@ -58,7 +58,7 @@  define Device/methode_udpu
   $(call Device/Default-arm64)
   DEVICE_VENDOR := Methode
   DEVICE_MODEL := micro-DPU (uDPU)
-  DEVICE_DTS := armada-3720-uDPU
+  SOC := armada-3720
   KERNEL_LOADADDR := 0x00080000
   KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
   KERNEL_INITRAMFS_SUFFIX := .itb
diff --git a/target/linux/mvebu/image/cortex-a9.mk b/target/linux/mvebu/image/cortex-a9.mk
index 389082e426..79253049c7 100644
--- a/target/linux/mvebu/image/cortex-a9.mk
+++ b/target/linux/mvebu/image/cortex-a9.mk
@@ -93,7 +93,7 @@  define Device/plathome_openblocks-ax3-4
   DEVICE_VENDOR := Plat'Home
   DEVICE_MODEL := OpenBlocks AX3
   DEVICE_VARIANT := 4 ports
-  DEVICE_DTS := armada-xp-openblocks-ax3-4
+  SOC := armada-xp
   SUPPORTED_DEVICES += openblocks-ax3-4
   BLOCKSIZE := 128k
   PAGESIZE := 1
@@ -193,7 +193,7 @@  define Device/globalscale_mirabox
   $(Device/NAND-512K)
   DEVICE_VENDOR := Globalscale
   DEVICE_MODEL := Mirabox
-  DEVICE_DTS := armada-370-mirabox
+  SOC := armada-370
   SUPPORTED_DEVICES += mirabox
 endef
 TARGET_DEVICES += globalscale_mirabox
@@ -212,7 +212,7 @@  define Device/cznic_turris-omnia
   IMAGE/$$(IMAGE_PREFIX)-sysupgrade.img.gz := boot-img | sdcard-img | gzip | append-metadata
   IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip
   IMAGE_NAME = $$(2)
-  DEVICE_DTS := armada-385-turris-omnia
+  SOC := armada-385
   SUPPORTED_DEVICES += armada-385-turris-omnia
 endef
 TARGET_DEVICES += cznic_turris-omnia
diff --git a/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-dts.patch b/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-dts.patch
index bd4f0aef9a..635e141c69 100644
--- a/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-dts.patch
+++ b/target/linux/mvebu/patches-4.19/530-add_armada-3820-uDPU-dts.patch
@@ -4,7 +4,7 @@ 
  # Mvebu SoC Family
  dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-db.dtb
  dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-espressobin.dtb
-+dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-uDPU.dtb
++dtb-$(CONFIG_ARCH_MVEBU) += armada-3720-udpu.dtb
  dtb-$(CONFIG_ARCH_MVEBU) += armada-7040-db.dtb
  dtb-$(CONFIG_ARCH_MVEBU) += armada-8040-db.dtb
  dtb-$(CONFIG_ARCH_MVEBU) += armada-8040-mcbin.dtb