diff mbox series

[OpenWrt-Devel,1/2] libcxx: Build with the libsupc++ ABI

Message ID 20200101033735.853371-1-rosenp@gmail.com
State Accepted
Headers show
Series [OpenWrt-Devel,1/2] libcxx: Build with the libsupc++ ABI | expand

Commit Message

Rosen Penev Jan. 1, 2020, 3:37 a.m. UTC
Allows proper exception handling. This includes removing unimplemented
warnings.

File size increased as a result:

Before:

182874

After:

211006

On mipsel_24kc.

Note that this requires libsupc++ anyway. It's specified in g++-libcxx.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 package/libs/libcxx/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Jo-Philipp Wich Jan. 1, 2020, 3:59 p.m. UTC | #1
Merged into master at
http://git.openwrt.org/?p=openwrt/openwrt.git.

Thank you!
diff mbox series

Patch

diff --git a/package/libs/libcxx/Makefile b/package/libs/libcxx/Makefile
index 695b0398fe..60978bdc31 100644
--- a/package/libs/libcxx/Makefile
+++ b/package/libs/libcxx/Makefile
@@ -7,7 +7,7 @@  include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libcxx
 PKG_VERSION:=9.0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://git.llvm.org/git/libcxx
@@ -37,6 +37,7 @@  define Package/libcxx/description
 endef
 
 CMAKE_OPTIONS += \
+	-DLIBCXX_CXX_ABI="libsupc++" \
 	-DLIBCXX_ENABLE_ASSERTIONS=OFF \
 	-DLIBCXX_ENABLE_EXPERIMENTAL_LIBRARY=OFF \
 	-DLIBCXX_INCLUDE_BENCHMARKS=OFF \