diff mbox series

[OpenWrt-Devel,v2,01/12] tools/libaio: new package

Message ID 20191121162322.671035-2-thomas.petazzoni@bootlin.com
State Rejected, archived
Headers show
Series dm-verity support | expand

Commit Message

Thomas Petazzoni Nov. 21, 2019, 4:23 p.m. UTC
libaio for the host will be needed as a dependency of lvm2, itself a
dependency of cryptsetup.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 tools/libaio/Makefile | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 tools/libaio/Makefile
diff mbox series

Patch

diff --git a/tools/libaio/Makefile b/tools/libaio/Makefile
new file mode 100644
index 0000000000..bb5b43a69c
--- /dev/null
+++ b/tools/libaio/Makefile
@@ -0,0 +1,30 @@ 
+#
+# Copyright (C) 2010-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libaio
+PKG_VERSION:=0.3.111
+PKG_HASH:=62cf871ad8fd09eb3418f00aca7a7d449299b8e1de31c65f28bf6a2ef1fa502a
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://releases.pagure.org/libaio
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+	$(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+	$(MAKE) -C $(HOST_BUILD_DIR) prefix=$(HOST_BUILD_PREFIX) install
+endef
+
+$(eval $(call HostBuild))