diff mbox series

[OpenWrt-Devel,libnl-tiny,3/5] cmake: enable extra compiler checks

Message ID 20191021093642.3118-3-ynezz@true.cz
State Accepted
Delegated to: Petr Štetiar
Headers show
Series [OpenWrt-Devel,libnl-tiny,1/5] refactor into separate Git project | expand

Commit Message

Petr Štetiar Oct. 21, 2019, 9:36 a.m. UTC
Let's enforce additional automatic checks enforced by the compiler in
order to catch possible errors during compilation.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
---
 CMakeLists.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4924586e893c..e7d7f86199cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@  INCLUDE(GNUInstallDirs)
 
 INCLUDE_DIRECTORIES(include)
 
-ADD_DEFINITIONS(-Wall -Werror)
+ADD_DEFINITIONS(-Wall -Werror -Wextra -Wno-unused-parameter)
 
 ADD_LIBRARY(nl-tiny SHARED
 	attr.c