diff mbox series

[OpenWrt-Devel] build: call Host/Uninstall before wiping the host build dir

Message ID 20190928111059.4048-1-a.heider@gmail.com
State Accepted
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel] build: call Host/Uninstall before wiping the host build dir | expand

Commit Message

Andre Heider Sept. 28, 2019, 11:10 a.m. UTC
Uninstall targets may depend on build artefacts, like `make uninstall`
or `ninja uninstall`.

Signed-off-by: Andre Heider <a.heider@gmail.com>
---
 include/host-build.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/include/host-build.mk b/include/host-build.mk
index 827ea6bbfb..9fc14241c6 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -190,11 +190,11 @@  ifndef DUMP
   host-install: host-compile
 
   host-clean-build: FORCE
+	$(call Host/Uninstall)
 	rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_BUILT)
 
   host-clean: host-clean-build
 	$(call Host/Clean)
-	$(call Host/Uninstall)
 	rm -rf $(HOST_STAMP_INSTALLED)
 
     ifneq ($(CONFIG_AUTOREMOVE),)